Gaming pc wont turn on after installing wifi card

So, I'm trying to build myself a new computer. (I'll list the specs below) I powered it off like I have been doing every time I install a new part, I installed the card, try to power it back on, but nothing at all. Just that small green light on the motherboard and that's it. I did that paperclip test on the power supply, it turned on, which I assume means it works correctly. Something I should probably let y'all know, and this may be the problem, is that within the first few days of putting it together, I pushed in on the power button too hard and it shoved the button out of its holding place within the case. So what I had been doing is taking like a small screwdriver and reaching in the case and holding the button mechanism in place so I can push the power button on the outside of the case. doing this enough I THINK may have ruined the connection on the power button, so I ordered a whole new button kit and will install it and see what happens from there. I'm hoping this is the problem if any one has any suggestion PLZ let me know.

Specs GTX 1050 (haven't actually hooked it up to the monitor yet, but still hooked to the mobo)
600W LED shark PSU
Asus Z170-A MOBO
Reply to tim_72
9 answers Last reply
More about gaming wont turn installing wifi card
  1. Does the system boot if you remove the wifi card?

    Are you sure the wifi card is compatible with your system? You may be trying to install an old card with a different PCI version then your board is compatible with.

    Can you give us the make and model of your wifi card?
    Reply to androbourne
  2. The system still doesn't come to life with the wifi card removed.

    GIGABYTE GC-WB867D-I (a newer card)
    Reply to tim_72
  3. What does the system do when you try to turn it on via the PSU like you have been doing?

    Do any power go through the system? Do any fans spin up? Does it appear to be on but no display or simply nothing happens?
    Reply to androbourne
  4. No movement at all, no fans no sounds nothing, I sat for a while just to listen and nothing, no beeps, squeaks or anything. there is no display, no lights (other than the green mobo light) I haven't tried to turn it on via the PSU, if you're talking about the paperclip test, then that was separate when it wasn't connected to the mobo.
    Thx for taking time to help by the way
    Reply to tim_72
  5. Well since you don't have a power button yet. Other then turning it on via the PSU or the mobo power leads. There is no real way to turn on the system.

    So try turning it via the paperclip test method.

    Another question is. Did you properly connect the case power button to the mobo power leads? They are normally two small pins (power- and power+) that connect to the mobo to send the power signal. Refer to your manual for proper installation.
    Reply to androbourne
  6. mine don't have Power+ and power-, it only has "pwr" and "pwr ground" I'll go back to check and try to update if anything new turns up
    Reply to tim_72
  7. Well some cases label them differently but those are the correct cables. Make sure they are plugged into the correct pins on the motherboard.
    Reply to androbourne
  8. OK, so I got the power button cable in and it still won't work, the motherboard buzzer/beeper thingy won't make a sound when I try to turn the button on. what would be your next step?. I thought about maybe since I'm still within my return period may be returning the MOBO? what do you think?
    Reply to tim_72
  9. We havn't really found the source of the problem but it is starting to sound like PSU. Not sure if returning the mobo will fix your problem.

    You should at least be getting some power to the system. Fans turning on for a few seconds or anything.
    Reply to androbourne
Ask a new question Answer

Read More

Power Gaming PCs WiFi and Home Networking Computers Build