Solved

Faulty RAM socket or Windows 10

Hi all.

I'm having issues with my pc and I can't locate the problem. I thought I had it figured out but now I'm in doubt. Hardware-wise I'm having a Asus Rampage II Extreme motherboard and 3x2 GB Corsair Dominator RAM
So, here's the deal:
If I boot up my pc after having it turned off completely/unplugged it boots untill the Windows load screen where it freezes. If I enter the BIOS first it sees 6 GB memory available.
When Windows freezes I press the reboot button and then the fail; when the pc starts up it powers up but reboot itself before the motherboard beep. This happens 2 times and third time it comes alive. This boot fail continues every time after if the power hasn't been cut completely.
When entering BIOS after the boot fail I suddently only have 4 GB memory available. Windows boots and in here I can also only see 4 GB installed.

What I've tried:
- Running Lavalys Everest (pc summary/detailing program). It can detect all 3 RAM sticks but only see 4 GB available
- Running Windows Memory Diagnostics. It runs 2 steps of testing which indicates it can only test/detect 2 RAM blocks
- Switching the RAM blocks around to see if one of the blocks is faulty. This narrowed it down to the fact that the order in which they where put in didn't do any difference in blocks but that every time a block was put into DIMM socket A3 (it's a triple channel motherboard) the fault appeared.
- Putting all the RAM blocks into DIMM_B sockets and none in DIMM_A (primary) but the pc can't boot this way. Nor will it boot if I do a DIMM A1+A2+B1 setup.

The pc will boot normally with only 2 RAM blocks/4 GB in it.

I'm aware that it probably is the DIMM_A3 socket that is faulty but what I'm a little frustrated about is why the pc can boot up into Windows load screen with 6 GB memory in BIOS after the power has been cut from it but every single startup from there it seems to make a BIOS/memory fail and will only boot with 4 GB available. It has dual memory tests activated in BIOS so in my head the system should fail at first boot even when the power has been cut prior to the boot.
Can it be because of some sort of delay in the motherboard that lets the system "make it" to Windows load screen the first time?

Sorry for the long post. I hope someone has a solution, or a conclusion that the DIMM socket must be dead...

Thanks
Reply to celica_dk
3 answers Last reply Best Answer
More about faulty ram socket windows
  1. Best answer
    after a full power cycle it assumes that everything is working, the system does not know if a module or slot is bad
    it will probably flag the module bad once it encounters it so a soft reboot and possibly a reset will continue to acknowledge the error and block it.

    the simplest test would be to simply leave a single module in that slot without ANY others and see if it boots.
    also disable quick boot and see if the BIOS with test the memory in POST.
    Unfortunately if its bad, you are stuck using it dual channel if you only have 3 slots total.
    Reply to psoohoo
  2. psoohoo said:

    Unfortunately if its bad, you are stuck using it dual channel if you only have 3 slots total.


    I have 6 sockets in total (2 x triple channel). It just doesn't seem to be able to run 3 RAM sticks with 2 in DIMM_A channel and 1 in B channel...
    Reply to celica_dk
  3. I'm not sure why this has given something but I tried what you suggested by starting the pc with only a RAM stick in the possibly faulty socket + deactivated quick startup.
    It booted without problems! Now I've moved forward and added a stick to socket 2 and finally socket 1. It seems to run without any issues and both BIOS, Windows and the Everest program finds 6 GB installed and accessible. I tried a couple of reboots and complete shutdowns with no errors or problems!
    Thank you for the suggestion...
    Reply to celica_dk
Ask a new question Answer

Read More

RAM Rampage