AsRock H81 PRO BTC R2.0 Does not start BIOS, no POST

Hi everyone!
I’m building my first mining rig and there are one issue i face it right now that I can’t figure out the solution myself.
Here are the specs:
MB asrock h81 pro btc r2.0
SDD
Intel Celeron G1840 Dual Core 2.8GHZ
8 gb ddr3 ram
MSI AMD Radeon RX 580 ARMOR 4gb
1300w PSU

I have one more GPU the same RX 580 and one more to come. Stil haven’t receive my PCI-E risers, so I want to set up bios, install windows and everything. For that one GPU is enaugh, right?

So I installed everything on my motherboard and it worked very well. I mean fans on CPU, PSU and GPU are rotating and…, … that’s it. Nothing happens. Fans rotate for some time, then slow down and then rotate again as normal. I connected monitor using hdmi straight to GPU - nothing showing. I plugged other monitor using D-Sub connector on MB and nothing. I also noticed that my keyboard (Works perfectly on my other PC) I plugged in MB doesn’t work (for example num lock button desn’t light on/off when pressed). Looks like all usb slots on MB are without power. Also this D-sub slot for monitor doesn't give any signal or sign that it's doing something. Monitor is just blank. I expected to see bios startup, so I could install windows, but nothing.
Do You have any idea where is the problem?
Do You need any additional data to understand where the problem is?

Thanks in advance.


Here are how it looks: http://imgur.com/a/bxitZ
3 answers Last reply
More about asrock h81 pro btc start bios post
  1. Hi, An internal speaker would help, to check if CPU and board do work.
  2. alexoiu said:
    Hi, An internal speaker would help, to check if CPU and board do work.


    Ok, will purchase this small beeper and see what sound does it make.

    Any other good ideas while I find this speaker?
Ask a new question

Read More

BIOS Monitors Boot ASrock USB