Solved

USB ports stopped working shortly after motherboard upgrade

Shortly after I upgraded my CPU, MB, and RAM ( ----
AMD A10-5800k --> Intel i5 7600k
MSI A785-E3M --> AsRock Z270m Pro4
Crucial Ballistix 8gb DDR3 --> G.Skill Ripjaws V Series 8gb DDR4

--- ) The mouse and keyboard worked perfectly fine in the BIOS, however not in windows (Also, I kept the same HDD from my previous build so the OS stayed the same as well - Win 7 Pro x64). After a while of plugging and unplugging and testing different solutions nothing worked so I concluded it was a driver error. I then download Win 10 ISO on a Flash Drive on a different computer to start a fresh installation, however now my mouse and keyboard, nor Flash Drive do not work in the BIOS either. I noticed with both rear and front USB, the light of the mouse flickers after being plugged in, but it does not stay lit up, same with the flash drive. Could I have broken my USB ports within the first day of use? Help would greatly be appreciated
2 answers Last reply Best Answer
More about usb ports stopped working shortly motherboard upgrade
  1. Best answer
    Try resetting BIOS to factory settings. If you say they do not work in bios, how did you get into bios?
  2. Sorry For a wasted thread, but all I had to do was take the cmos battery for a minute or two and put it back in and the USBs started working again. And to answer your question, They Were working in the bios for about a day but stopped working for some reason. Either way, I was figured it out and was able to finally install windows after a bunch of different problems and I'm a pretty happy man right now.
Ask a new question