Solved

Asus maximus hero ix a2 error

Just made a build. (Not much experience) and I got everything plugged in but no display and I get an a2 error which means ide detect? I also got that code with just the mobo cpu and cooler and ram I'm pretty sure.

Intel i7 7700k
Geforce 1080 ti
16x2 corsair vengeance Lpx 3200mhz
Asus maximus hero ix
31 answers Last reply Best Answer
More about asus maximus hero error
  1. Just keep one hard drive plugged in until you have installed windows. After that you can plug the rest of your hard drives in.
  2. I only have one hard drive
  3. What kind?
  4. It says Seagate desktop sshd 2000gb sata 7200 rpms
  5. Have you tryed to plug it into a different SATA port on the motherboard?
  6. Yeah I tried that one. Hoping not a defect mobo. I see alot of bad stuff about asus mobo after buying this.
  7. I have the same motherboard that you have and for me it works like a charm.

    But this is a bit strange I have to admit that.


    Just to make sure:

    Strip the system down to a bare minimum, like 1 ram module only, no GPU and run on the CPU`s internal graphics.
    Double check that everything is plugged in correct and that you are not creating a short circuit like the backside of the motherboard is touching the motherboard tray of the case.
  8. I got the error code still with just cpu and cooler and ram. Tried that before putting it in. Thinking it might be because nothing else was plugged in. I just got passed the error code 53 to land in this one. When it starts it goes through all sorts of numbers and it goes through the vga and those other lights and stays on boot red light a2. I don't see my mobo touching my case either. It has to either be my cpu or mobo. I think my new ram is fine. Been stuck trying to make this work for almost 2 weeks. :(
  9. I had problems in the start myself (dont remember Qcode) and it was all down to 1 faulty ram stick out of 4.
    But I dont recall getting the a2 code.

    Have you even tryed a different ram module? and tryed different DIMM slots?
  10. Not different ram. I thought a2 meant something with the sata stuff. I can try crucial 2133 ram here in a couple days.
  11. I just got something on screen. Says what I have hooked up. And says enter setup to recover bios setting. After setting up Intel r optane memory or the raid configuration was built, sata mode selection must be changed to raid mode to avoid unknown issues.
  12. a2 is something to do with the sata you are correct, but it is better to check than not to check.

    But if you have tryed every sata port on the motherboard, the only thing is to try an different hard drive.
  13. I got to settings!!! Not sure what to do next. Error code a9 now.
  14. mustysloot said:
    I just got something on screen. Says what I have hooked up. And says enter setup to recover bios setting. After setting up Intel r optane memory or the raid configuration was built, sata mode selection must be changed to raid mode to avoid unknown issues.


    hmm.. Now I am starting to belive it is your BIOS that is faulty here.
  15. errrr.. hang on I need to get my asus book myself.
  16. What should I do next? I have very very little experience in bios. I can go through bios. Haven't tried exiting yet and seeing what happens. I can't find this raid configuration either. I feel like I'm right there now to getting it running
  17. A9 = Start of setup

    Let it run for a little while on code A9 and see what happens.
  18. ah nice so you are in BIOS now??? if yes. DO NOT GO OUT!
  19. So take it out of bios. And try running? Without changing the sata to raid mode?
  20. No wait for my next reply. DO NOT GO OUT!
  21. It's sitting in bios. I have to leave to work here in a second. Yeah it said I had to configure that. And I think I'm good after that.
  22. First answer this to be 100% sure not to mess up:

    Are you 110% you only have 1 hard drive?
    No other M.2 drives? no other SSD`s? no other SSHD / HDD?
  23. I have one hard drive. No solid state or anything. Same hard drive I used on my last build. I don't know what m.2 is yet
  24. Find:
    PCH Storage Configuration in bios

    Make sure the hard drive is enabled and set to AHCI
  25. It should NOT be set to RAID since that is something you do with 2 or more hard drives.

    Impossible to set RAID with only 1 hard drive
  26. I think it's enabled. But I had to leave for work for a little bit. Hoping it stays in bios for now. Yeah I don't know what configuration it should be because when I got it originally it just worked. I never needed to mess with bios. Ill have to check to what it's set too
  27. It should stay in BIOS until you get home.

    If you have the manual for your motherboard look at page: 3-17 @ section 3.6.5


    Unless there is something wrong with your hard drive you / we should get this computer up and running.


    Sidenote: I live in Norway (thats in Europe) and its 02:35 in the night here so I am soon going to bed. But I will come back to take a look when I wake up.
  28. Okay I was able to come back and it is enabled and on ahci. If I get out of bios wouldn't it just bring me back if it can't start?
  29. It can, but if I where you I would update the bios also now that you are in the bios cause if there is something wrong with it this can fix it.
  30. I didn't see update bios but I did update bios off a flash drive so I think I have the latest. I got out of bios and the pc booted up windows and everything (kinda slow) but I have a red light on my sata port area and I think I still have the a0 code
  31. Best answer
    You should have bios Version 1009 since that is the newest one:
    https://www.asus.com/us/Motherboards/ROG-MAXIMUS-IX-HERO/HelpDesk_BIOS/


    But since you now are in windows thats great. Thats a step forward.

    Might I ask how old you belive your hard drive is?
Ask a new question

Read More

Asus Boot Failure