Solved

Asus maximus X hero error A2

I just finished assemblying my new computer with the following parts

MB : Asus Rog maximus X hero
CPU : i7 8700k
Ram : hyperX 3000 MHz 16G X2
Cooling : crosair h115i
Psu: rm850i

Now I tried to boot it and to see if it works, I get the lights and a beep with an error code of A2
Now I tried to change locations of the ram and even looked if the processor moved or something, discounted everything and still the same problem
Black screen and Q code A2

Can some one help? Or what could it be?

Edit:
I did some digging into it,
First there is no post at all.. or I'm just blind, or my screen disided to play some tricks on me.

Second on this mobo there is a few Leds under the Q-code, before the boot the mobo checks the following:
CPU
DDMI
VGA
Boot
Everything checks out until the boot, here it gets stuck, and shows the error A2.

I checked if I got any HDD or the SSD connect, but no, the SATA is empty.
So I tried with my SSD connected still the same but the mobo shows that it reads it for a few moments (HD_LED - was blinking).

Three, the beeping stopped due to I connected the speaker to the led strips connection pins, yea I'm an ediot.
Yet it beeps once.
Ill be adding a photo in next hour

Thanks in advance
5 answers Last reply Best Answer
More about asus maximus hero error
  1. According to the manual A2 is a IDE Detect. What type of HDD/SSD/M.2 storage are you using?
  2. ATM all of them are disconnected
  3. Did some more digging around,
    By the looks the mobo doesn't like the cooling that it uses only 1 pin from the 4 that there is on the CPU_FAN, I might try to connect one of the other fans for a test if it helps to trick the mobo that there is a normal fan on the CPU.
    OR
    There is a problem with the BIOS, I'll try to flash a new one.
    OR
    I'll try a normal monitor, most of the time I tried it was without a monitor connection
    OR
    Sonehow a screw fell under the mother board or it gets pushed and getting grounded or a short circuit some how, will try to start it out side the case.
    OR
    It's an RMA and I'm toast
  4. For the cpu fan, if the motherboard doesnt like it during the bootup it will come up and say can detect fan on cpu header. I know on Asus boards you can go into the bios and change the settings to ignore the cpu fan.

    At this point is the computer booting up enough that you can get to the bios?

    Also read the manual and try using the mem OK button to check the ram. I had to do this on my rampage 3 extreme board because the ram was set wrong for the Xeon CPU i was using.
  5. Best answer
    Managed to fix it. And for anyone that gonna have the same problem here how I fixed it.

    I was getting A2 Q-error on the mobo.
    While I had only the CPU Ram and the cooling installed on the mobo. No Sata, no PCI.
    Due to it I didn't get anything on the screen (no BIOS no graphics and NO POST).

    So here how I managed to get it to work.
    I took the mobo out of the case and made sure that there is nothing under it. Just to be sure and started from scratch.
    Made sure that the CPU's pins are ok and puted the processor back to the slot.
    Reinstalled the Ram again on the mobo before I puted it back on the case(even if the error code for the ram is 55).

    Assembled the mobo back to the case(with the CPU and the RAM on it already).
    Hooked up the cooling back and rewiered it again.
    This town I connected it to AIO_PUMP and not to the CPU_FAN.
    Connected the ATX power and the 8 pin CPU and gave it a test. Now we are back to the same point where I was getting the error, just this time I got POST and access to the BIOS.
    I'm using the H1151i liquid cooling just if someone wondering.
    So it might was the cooling connection to CPU_FAN, cuz that's was the only difference.

    So problem solved.
    But there is more! After this test I connected the front I/O, and tested it, everything ok, there POST BIOS, hooked up the harddrives, 1 SSD 2 HDD.
    Got the A2 error again, last time there were not connected. Disconnected them and Tried them one by one, found the one that was doing the problem.
    In my case it was an old HDD.

    Hocked up the graphics card, everything worked out fine.

    So in the end I had the A2 twice in one go.
    One from the cooling and one from the HDD later.

    I hope someone found this helpful.
Ask a new question

Read More

Intel i7 Computers CPUs Error Message Boot Failure Asus