Rebuilding old PC from previously working parts - Nothing turns on

Hi all !

About 3 years ago I built a PC that I then had to leave behind when I moved to the US. My family visited recently and I asked them to bring me the spare parts of the computer so that I could try to rebuild it here. The PC was running fine a few days before my dad took it apart and brought it over. He was careful in transporting the parts and bubbled-wrap everything. I tried rebuilding it here in a new case but when I press the power button, nothing happens (no fan, no nothing, except the TPU red light and the green power light on the motherboard).

Here is the list of components that were brought to me:

- MB: Asus P8P67 LE
- CPU: Intel i5-2500 (feeling nostalgic yet ?)
- GPU: Gigabyte GTX 770
- PSU: Seasonic Platinum 660W
- RAM: Kingston Black DDR3-1333 (2*8GB)
- SSD & DD: Sandisk 240Gb and Seagate BarraCuda 3Tb 7200rpm

The things that I had to buy new are the case and CPU fan:
- Case: Corsair 100R silent
- CPU fan: CoolerMaster Hyper 212 LED

I should mention that I had to "tear" the backplate of the previous CPU heatsink off of the Motherboard as it was partially glued to it, and that was not the most delicate process. Apart from that, all the components are the same as before, I checked all the connections with the PSU multiple times, I tried removing the GPU and hard drives to boot with nothing but the PSU and mobo, I tried all the slots for the RAM, but nothing worked: The PC does not start when I press the power button and nothing happens (No PSU fan, no case fan etc).

I then tried bridging the power switch directly and that didn't work so it is not an issue with the case IO pannel. I tried putting the motherboard outside of the case on a flat surface with nothing but the PSU, but that didn't work either. I also made sure that the PSU was not dead by jump starting it with a paper clip and it worked fine (I don't have a multimeter to check if it delivers the correct power, but it is a really good PSU from what I can remember so I would be surprised if it was the source of the problem.).

I am running out of ideas of things to try and am afraid that the motherboard is dead. I even tried cleaning and reapplying thermal paste on the CPU, fearing that I might have put too much and short-circuited something, but the CPU seemed clean and the paste was evenly distributed but did not spread outside of the CPU cover.

I am considering buying an old LGA1155 motherboard but they are not easy to find. I would also consider getting a brand new LGA1151 300 series with something like a i3-8100 and some new RAM but it defeats the point of not spending money on a computer that worked really well a week ago in its old case.

I would love to hear your thoughts on what the problem might be and how to try and solve it before I spend money on new components ! Thanks in advance for your help !
6 answers Last reply
More about rebuilding previously working parts turns
  1. Maybe your already check this multiple times: power for 8 pin CPU and 24 pin for motherboard connected properly?
  2. Bob125484 said:
    Maybe your already check this multiple times: power for 8 pin CPU and 24 pin for motherboard connected properly?


    I did check multiple times. There is a green power light that turns on on the motherboard, which if I understand correctly means that the motherboard is aware that it is being powered, but not necessarily that the rest of the circuits are working ?
  3. USAFRet said:


    Thank you for the list. I went through every single step yesterday except 17 (system speaker) and 21 (resetting the CMOS). On the user manual for the motherboard (Asus P8P67LE), it is indicated that to reset the CMOS I need to move the "jumper cap" from position 1-2 to position 2-3. However I don't seem to have a cap on there. Could this be an issue ?
  4. Only an issue if you want to reset the CMOS.
  5. USAFRet said:
    Only an issue if you want to reset the CMOS.


    But that wouldn't explain why the PSU and CPU fans don't even start, would it ?
Ask a new question

Read More

Rebuild Boot Failure