PSU seems to have something blocking the entrance of my 24 pin atx cable?

My first build. I already feel like I'm doing bad. I go to plug in the motherboard atx pin into the PSU and there seems to be a little white thing blocking the entrance of the bottom pin? I'm not sure how to include a picture from a mobile device. If anyone can help please do.
10 answers Last reply
More about psu blocking entrance pin atx cable
  1. Is the white thing on the plug itself or the mobo? I believe it’s a cap you can just take off, but pics may help. I find it easier to just download imgur app: make an account, post the pic (be sure it’s public), and use the share feature to copy the link here.
  2. jgustin7b said:
    Is the white thing on the plug itself or the mobo? I believe it’s a cap you can just take off, but pics may help. I find it easier to just download imgur app: make an account, post the pic (be sure it’s public), and use the share feature to copy the link here.


    No it's literally inside of the psu connector.
    Idk if you can see that but it's sort of blocking the bottom connector.
  3. jgustin7b said:
    Is the white thing on the plug itself or the mobo? I believe it’s a cap you can just take off, but pics may help. I find it easier to just download imgur app: make an account, post the pic (be sure it’s public), and use the share feature to copy the link here.

    I'm sorry I'm trying to create an imgur but it wont activate my account to post the image so I'm trying to figure this all out.
  4. jgustin7b said:
    Is the white thing on the plug itself or the mobo? I believe it’s a cap you can just take off, but pics may help. I find it easier to just download imgur app: make an account, post the pic (be sure it’s public), and use the share feature to copy the link here.


    Is there a phone number or something I can text it to? It's not working and I'm becoming very stressed out.
  5. No problem on the imgur thing. There should be alt.’s somewhere. As for the number, not happening. Would lead to a ban of sorts knowing the rules of conduct here. Although my email is my username @gmail.com. That I practically gave away to everyone anyways.
  6. After the OP sent a quick email, this is the image given

    https://imgur.com/gallery/jJyq7
  7. seems like a defect to me, to much glue got applied or something.
  8. Snipergod,

    Are you trying to say he/she should RMA it?
  9. Either RMA, or risk voiding the warranty and scraping it off without opening the PSU case if it is indeed glue.
Ask a new question

Read More

ATX Cable Motherboards Build