Solved

Laptop restarts showing "No bootable device insert boot disc and press any key" error until I shut down and power on

Good day all I have always come to this site for problems with my or other's pcs in the past but today I feel the need to ask my first ever question here. I have a peculiar problem with a HP ProBook 650 G3 Laptop that my friend bought.

Specs:
Intel® Core™ i7-7600U with Intel HD Graphics 620
16GB RAM
1TB HDD

Few weeks ago he took out the 1TB HDD and installed an Adata 128gb SSD into the laptop and installed Windows 10. Everything was hunky dorry so far.

Then we found that when we leave the laptop on idle we come back to it in a black screen showing "No bootable device insert boot disc and press any key" error. When we press a key, same error. Until we actually power off the laptop and switch it back on again, then it goes back into windows 10 like normal. But leaving it idle after a random amount of time it does it again.

Funny thing is when we leave it to play movies or shows or whatever it runs for hours with no problem, just when the laptop is doing nothing that this happens. Here is what we have tried so far:

- I have tried turning off any options that limit or idle the hardware of the laptop after a specified amount of time: Still does it.

- I have at a friend's request tried setting it to boot as legacy hardware in BIOS, still does it even though it was already turned on.

- I have run a check on the drive to see if there were any bad sectors, but all the checks I run come up as clean. No bad sectors

I have heard from other friends they think it's the laptop at fault while the owner adamantly believes it's a faulty SSD even though I tested it to hell and back. Are the HP laptops just not compatible with SSD? Are there errors there that we aren't aware of causing a functioning SSD to just stop working and appear invisible in the BIOS until we restart? I hope to get some answers here, please :)
12 answers Last reply Best Answer
More about laptop restarts showing bootable device insert boot disc press key error shut power
  1. Did you wipe the system reserve partition from the 1tb hdd?Did you select the ssd as a boot drive(C:)? If not those things should be done.
  2. did not mean to insert smiley
  3. Lol smileys are always welcom. No we didn't but we removed the 1tb entirely. I amcurrently converting the drive from GPT to MBR to see if that would fix the problem. Will update soon.
  4. UPDATE, seems like I can't install windows on a MBR partition when the system is EFI. What does any of this mean?

    And yes the drive is the main boot device, like I said windows boots up and everything, but then after a few minutes of idling it's like the hard drive vanishes without a trace till we power off and power on. Tested the drive on my desktop as well and it had no issues there as an MBR partition while windows was running for 2 hours and no problems. But the laptop insists on making it GPT.
  5. 1. It doesn't sound like a SSD drive defect but of course it's possible. I know you've indicated you, and/or the laptop's owner, tested the drive, but did the testing include the ADATA SSD Toolbox - http://www.adata.com/us/ss/software-6/ -. If not, do so.

    2. I know you've also checked the power options as well since that would be the first thing that comes to mind re the problem you're experiencing. But double-check to make sure incorrect settings are the cause of the problem.

    3. The laptop is working with that single SSD, yes? The original 1 TB HDD has been uninstalled, yes?

    4. Assuming the 1 TB drive was the original boot drive can you still install that drive as the boot drive to determine if you run into the identical problem? Were the contents of the 1 TB drive cloned to the new SSD?

    5. In your last post you indicated you planned to convert the "drive from GPT to MBR". I assume you're referring to the SSD boot drive. Is that correct?
    It's hard for me to understand what difference/impact, i.e., changing the partitioning scheme of the drive, would make in resolving this problem.

    Also, how would you even undertake this conversion process without losing all the data currently on the drive? You're planning a fresh-install of the Win 10 OS?

    6. You might want to raise this query in the HP Support Forum - https://h30434.www3.hp.com/t5/custom/page/page-id/HPPSocialUserSignonPage?redirectreason=notregistered&referer=https%3A%2F%2Fh30434.www3.hp.com%2Ft5%2Fforums%2Fpostpage
  6. 1. Thanks will download now and check it out.

    2. Triple checked, still does the thing

    3. Yes the SSD is the only drive in the laptop, there are no extra places to put more hdd in lol

    4. We did, and it worked fine, no problems for a whole day.

    5. Used Minitool Partition manager, it's free and does it quickly. When I inserted the SSD in my desktop PC and converted to MBR I installed Win10 with no problems. Seems the laptop doesn't like it though and says the drive needs to be GPT because of the EFI system.

    7. uuuuuuuuuuuuuuuuuuurgh..... lol

    Also I just found that legacy booting the drive immediately makes the drive go dark. Went into boot settings and changed from Legacy/nonsecure boot to nonlegacy/secureboot. Will see how that goes.

    Will also install that ADATA SSDToolbox to see if it picks up any abnormalities.

    Thanks btw for the replies so far. I knew trying here first would help me nail down the problem sooner or later, it's just a matter of running out of options.
  7. 1. Please understand that when you clone a drive, the destination drive will virtually ALWAYS take on the partitioning scheme of the source drive. So if your 1 TB source drive, i.e., the drive you cloned to the SSD, was GPT-partitioned, the destination SSD will likewise be GPT-partitioned, notwithstanding that it might have originally been MBR-partitioned.

    2. That accounts for EFI System Partition on the SSD, i.e., the drive has been GPT-partitioned.

    3. Frankly (SINCE YOU'VE INDICATED THERE'S NO PROBLEM WHEN WORKING WITH THE 1 TB BOOT DRIVE) what I would do is simply reclone the contents of the original 1 TB HDD to the SSD. You don't have to manipulate any partitions/data on the SSD at the time of the disk-cloning operation. That will be taken care of through the disk-cloning operation. (But see 4. below)

    4. Now, of course, if you've added/deleted/modified data on the SSD since the original d-c operation - all that data will be gone. If it's practical to do so copy whatever data you desire from the modified SSD back to the 1 TB HDD BEFORE undertaking the d-c operation. This may not be practical depending on the changes you've made on the SSD since the original d-c operation so you'll have to make a decision here.
  8. We never cloned, and never said that, the data from the 1tb, We just placed the SSD in the laptop and re-installed windows 10. The 1TB was practically empty, so we didn't save anything from it lol.
  9. mattiwe said:
    Then we found that when we leave the laptop on idle we come back to it in a black screen showing "No bootable device insert boot disc and press any key" error.

    That sounds like SSD has some problem with exiting/entering sleep mode. Try disabling "Turn off Hard disk" in power options.
    Alternatively - you may disable sleep altogether and replace it with hibernate.
  10. Tried that too but it still does it. I was also thinking about the drive not going into idle properly or something. Testing it out today with safeboot and legacy support turned off in BIOS. Will see how that goes.
  11. Again.... did you ever delete the system reserve partition form the hdd? Do you have files you can't loose on the hdd? if so transfer them to a flash drive and reformat the hdd
  12. Best answer
    things you can try

    1. not sure if you tried this yet, take ssd out put hdd in , do the symptom go away ?
    yes, then not ssd issue, laptop issue
    no, then ssd issue not laptop issue

    2. put SSD in another system to see if symptom repeat in another laptop?
    yes, ssd issue not laptop
    no, not SSD issue, laptop issue.

    Now "laptop issue" can mean a great deal, like hardware is not compatible to run a SATA SSD, power issues, chip issue, etc.
Ask a new question

Read More

Solid State Boot HP Laptop Laptops windows 10 SSD