Solved

First build, no post

Building my first gaming PC. Got it all together. Went for the first start and all systems seem to run fine besides no display. Tried to do some research before asking but I’m lost. Will post specs bellow. I’ve gone through everything i believed i would need. Processor is aligned and seated right. Cpu has power with a good connection and same goes for mobo. Tried running a single stick of ram and no ram at all with no difference. I even went to the basics and checked monitor had power and was on . I don’t know what else to do.

Ryzen 1500x
Asus prime x370-pro
Gskill trident z 2x8 3000
Samsung 960 m.2 ssd
Corsair rm750x 80+ gold
Gtx1050ti
1 answer Last reply Best Answer
More about build post
  1. Best answer
    xpvtsnowballx said:
    Building my first gaming PC. Got it all together. Went for the first start and all systems seem to run fine besides no display. Tried to do some research before asking but I’m lost. Will post specs bellow. I’ve gone through everything i believed i would need. Processor is aligned and seated right. Cpu has power with a good connection and same goes for mobo. Tried running a single stick of ram and no ram at all with no difference. I even went to the basics and checked monitor had power and was on . I don’t know what else to do.

    Ryzen 1500x
    Asus prime x370-pro
    Gskill trident z 2x8 3000
    Samsung 960 m.2 ssd
    Corsair rm750x 80+ gold
    Gtx1050ti

    Welcome to Tom's!
    I am going to refer you to our general troubleshooting thread:
    http://www.tomshardware.com/forum/261145-31-perform-steps-posting-post-boot-video-problems
    Work through the list.WORK!, not just read!
    If you still have issues, come back here with the results of EACH step in the list and we will try to help.
    Since we can neither see nor touch your PC, the answers to the questions in the list give us information to eliminate possible problems and common errors. Help us to help you!
Ask a new question