Solved

New hard drive shows up in bios with size but not in device manager or disk managment

Hi, I got a new 2TB WD blue today and it hasn't been going great would be a good way to put it. While the drive shows up in bios with it's actual size, it doesn't show up in disk management or device manager. WD lifeguard diagnostics is able to see the drive but it shows up with 0MB of storage, any tests (quick and extended) result in an immediate pass, presumably because there is nothing there to test according to the program. Attempting an erase (full or partial) results in an error. I've tried just about anything, I assume the drive is just busted, but thought I'd ask here anyway.

EDIT: Additionally, I also just now tested the other hdd I just got (same model but only 1TB) and it works, so unless there's a random miracle or something I'm pretty sure that 2TB is just doa. Worth noting that the 2TB hard drive makes very strange noises for a few minutes when it's hooked up while the 1TB one that works makes zero noise. No clue why that is exactly. Same cable, sata port etc as well.
2 answers Last reply Best Answer
More about hard drive shows bios size device manager disk managment
  1. Best answer
    Yes if your hearing noises from your HD (other than "spinning") the it probably is DOA, any sort click or rubbing/scraping noise is not good, you should RMA it.
  2. ikaz said:
    Yes if your hearing noises from your HD (other than "spinning") the it probably is DOA, any sort click or rubbing/scraping noise is not good, you should RMA it.


    Yeah, I figured. Just for reference, here's short audio of the noises it makes.
Ask a new question

Read More

BIOS Western Digital Hard Drives Device Manager