Display on monitor black after insert new Grahpic card (GPU)

I had an old GPU (GTX760 Phantom 2048M). The Graphic card is still working but freezes sometimes in games (Maybe cooling problem) but that is not the case!
I have a new graphic card gpu that i have got from my brother, and it still works on his PC. The GPU is a AMD Radeon hd 7970. I have all the powersupply that works for my specs. I even bought a new PSU because i only had two 6 pins for the GPU. So i thought in the beginning the GPU didnt get enough power, because i used 6-8Pins adapter for the new GPU. So i bought new PSU that has 8 pins and 6 pins.
When i plugged everything in my monitor... it still showed black screen on my monitor.
I have a motherboard: Maximus VII
Everything works as soon as i plug my old GPU into the motherboard. But as soon as i change the GPU to the other one, my monitor just shows black, and not even showing ''No signal''.

My motherboard has no VGA or DVI, means no internal GPU.
I have tried many things searching on the internet. I have tried to disable my other GTX gpu, and i have tried to uninstall the drivers from it... And i have tried to download the drivers my AMD gpu, while having my other GPU inserted... Still shows black screen when turning my pc on....
Just to let you know, everything works in my PC! And btw, i use a DVI to VGA adapter for my monitor, and that works for my old GPU.

Specs:
System: Windows 10 64-bit
Motherboard: Maximus VIII
Prosessor CPU: Intel(R) Core(TM) i5-7600K CPU @ 3.80GHz 3.80GHz
GPU: AMD Radeon HD 7970 -Drivers already installed
Rams: 8.00GB

Please help asap! I am running out of options...
3 answers Last reply
More about display monitor black insert grahpic card gpu
  1. What concerns me is you seem to understand that the HD 7970 requires a good bit of power, but you don't say which power supply you bought. So I can't help but suspect you bought a cheap power supply, because you assumed that if it has the connectors then it's good enough. It might not be good enough.

    The other thing is the "I tried to disable my other GTX", um, the Nvidia card should not be in your system if you're trying to use the AMD card. Uninstall the Nvidia drivers, then shut down, then remove the Nvidia card, then install the AMD card, then boot up using the generic drivers Windows includes, with the monitor connected to the AMD card.
  2. dontlistentome said:
    What concerns me is you seem to understand that the HD 7970 requires a good bit of power, but you don't say which power supply you bought. So I can't help but suspect you bought a cheap power supply, because you assumed that if it has the connectors then it's good enough. It might not be good enough.

    The other thing is the "I tried to disable my other GTX", um, the Nvidia card should not be in your system if you're trying to use the AMD card. Uninstall the Nvidia drivers, then shut down, then remove the Nvidia card, then install the AMD card, then boot up using the generic drivers Windows includes, with the monitor connected to the AMD card.


    Thanks for the reply.
    I bought the PSU called: EPS-750W (Gaming Power Supply) from Inter-tech Energon
    1x ATX 20+4pin
    1x P4/EPS 12V 4+4pin
    6x DVD/HDD Molex 4pin
    6x SATA
    2x FDD
    1x PCIe 6pin
    1x PCIe 6+2pin

    and for the other answer. I meant that i removed the new GPU and inserted the old one, to be able to uninstall all drivers from the old GPU and then went into the device manager and selected ''Disable'', as people recommended it. As i did that the monitor was still on, but the screen went big and the icons big(Was running on the generic drivers microsoft includes). So uninstall is already tried. I also tried to install the new GPU's drivers to be sure that thing was secured, before plugging in the new GPU.

    Thanks again for the reply
  3. Problem solved. To all those people having this problem, and cant figure out whats wrong.

    I had a monitor running VGA. My AMD GPU aswell as my old GPU runs with DVI cable, so i had a VGA to DVI adaptor on the old GPU and worked, and that ruind the connection to my monitor with the new GPU.
    Lesson: Always run with cables without adaptors!!!
    Thanks
Ask a new question

Read More

AMD not turning on Black screen Displays Geforce Nvidia GPUs Graphics Cards Monitors