Custom Loop High Temps

New custom loop and my temps are problem. Fx-8350 idle 29c and after playing 10min black ops 4 temps are hitting 70c. My old 120mm AIO did better job! 240mm rad, alphacool solo eisbear block+pump both copper and reservoir. Case have 3 intake fans, 1 exhaust and 2 fans top on rad, fans are cheap chinese rgb fans (so not very powerful). It is possible maybe I put too much paste? Hole block bottom is covered with paste. Or fans are too weak for pushing air?
3 answers Last reply
More about custom loop high temps
  1. What radiator are you using? If its a high fin count then you will want some good static pressure fans and or run your fans in a push/pull config if you have room.
  2. tonumeister said:
    New custom loop and my temps are problem. Fx-8350 idle 29c and after playing 10min black ops 4 temps are hitting 70c. My old 120mm AIO did better job! 240mm rad, alphacool solo eisbear block+pump both copper and reservoir. Case have 3 intake fans, 1 exhaust and 2 fans top on rad, fans are cheap chinese rgb fans (so not very powerful). It is possible maybe I put too much paste? Hole block bottom is covered with paste. Or fans are too weak for pushing air?


    What parts are you using?
  3. Radiator is from ebay "full copper" atleast its heavy so maybe its really copper. Solo eisbear is my pump and reservoir is pretty old that I was having laying around. Tubing is 13/10mm flex with Nanoxia CF1 Cooling Fluid Pro liquid in it. Idle temps are ok but when I trey like cinebench its starts "skyrocket" like 1c more every 2 sec. FX overlocked 4.5ghz atm. My old AIO can handle same 4.5 with lower temps...
Ask a new question

Read More

Custom loop