Bios not detecting any sata drives

So i had to get a new psu, which is working fine, but when i was installing new psu i unplugged the sata cables for my hdd, ssd and disk drive. I plugged them all back in of course but only my ssd (boot drive) and disk drive where registering, i was able to launch windows from bios and login to my acc etc but my files from my hdd were obviously missing, when i tried to launch it prompted me to load disk into the disk drive which it had labelled D: drive, previously the name of my hdd

so, i turned of my pc and tried a new cable in a new sata port on my mobo, but when i restarted my pc, all the drives were now missing.

when both hhd and ssd are unplugged and i boot pc it askes me to install a device to boot from or insert a disk to boot from etc

when either hdd or ssd or both are plugged in i get a message saying "the current BIOS setting do not fully support the boot device. Click OK to enter the BIOS setup. Adjust CSM settings to enable the boot device."

I have tried different CSM settings but still no dice :'(

Mobo asus sabertooth z77 bios v 2104
old intel ssd like 114gb or sommit
western digital 1tb black hdd
No answers Last reply
More about bios detecting sata drives
Ask a new question

Read More

SATA Hard Drives Disk Drive