How do I get 100Mbps???

I've worked with 10Mbps networks for some time, however, I recently connected two PCs at home (observing cat5 regs), but can't seem to get it working at 100Mbps, only 10. My cards are 10/100, but there's no option in the driver or wherever.

I benchmarked the connection and it gave 9.3Mbps, and I just can't figure it out :(

Thanks :)
5 answers Last reply
More about 100mbps
  1. How did you network these PCs?? cross cable? OR a HUB?
  2. What cable were you using for the 10Mbps connection ? And what network cards are they ? Most if not all 10/100 cards I've come across have the option in the drivers to select the speed and duplex ?

    If you're using a single cable to connect the two machines, you need to cross the TX+,TX- and RX+,RX- wires in the cable. If you're using a hub or a switch they you only need to following pin config:

    TX+ 1 <-----------> 1
    TX- 2 <-----------> 2
    RX+ 3 <-----------> 3
    RX- 6 <-----------> 6

    Hope this help :)
  3. You probably already know this but in case you didnt know or forgot, there's a difference between MB/sec and Mb/sec. Spelling it outs its megabits (Mb) and Megabytes (MB). A byte is made up of 8 bits and therefore 8x smaller, so if your benchmark reads in MBps the maximum for (100) full-duplex would be exactly 12.5MBps which wouldnt be too far away from your figure... this would be reasonable if your using a software based card instead of a hardware based (aka: Win-NIC) (basically saying whether it has its own processor or it uses the CPU to do all its work for it). If it has CPU do all work it will slow down transfers a little bit.
    But maybe u knew this already or maybe not, but to my understanding NICs are usually set up to an automatic mode where is selects speed as it sees necessary, if ur unhappy with speed there SHOULD be an option to set this manually if you right click on "Network Neighborhood," select properties, and select your NIC, select properties, select the advanced tab, select "link speed/duplex mode," and then press arrow key and scroll down to select "100 full," if this option is not there there are a few possible reasons.
    You might be using wrong driver for this NIC, an old one that doesnt use 10/100 options-- I have one of these for example, and it doesnt allow selection, the advanced tab is just simply not there. Or your NIC is fundamentally configured to run in an automatic mode on the actual piece of hardware itself--something I have yet to see, but something I wouldnt rule out.

    I hope I helped with something rather than just wasting ur time reading this really long message... Stephen :)
  4. If you are using a cross over cable they it will be maxed out to 10mbps. Also in your network properties check to make sure that it is either set to autosense the speed or force it to 100mbps.
  5. Using a crossover cable does NOT have anything to do with limiting your speed. Assuming that the NICs are set to autosense or forced to 100mbps as you said, you will be able to achieve that speed crossover cable or not. ( I had two pc's connected via crossover cables for a long time and never experienced this 10mbps limit)
Ask a new question

Read More

PCS Connection Networking