Sign in with
Sign up | Sign in
Your question

Can't run DirectX 10 Games

Last response: in Video Games
Share
August 10, 2008 3:30:54 AM

Hey guys

I just build a new desktop but every time when I try to run some fancy game it just pop up this message :xxxxx.exe has stopped working; A problem caused the program to stop working correctly blah blah blah.

So far I've tried Crysis and STALKER, neither of them works, but some good old games seem to be working fine: Sims 2, Command and Conquer 3...

I've tried dxdiag, everything seems to be fine. I even tried to run the system on single graphic card and 2G memory, none of them works

My system:
CPU Intel 9450
Motherboard ASUS RAMPAGE FORMULA LGA 775 Intel X48 ATX
Graphic Card ATI 4850x2 Crossfired
Memory G.SKILL 4GB (2 x 2GB) 240-Pin DDR2 SDRAM DDR2 1066 (PC2 8500)
System Vista Home Premium 64-bit

Please help me

More about : run directx games

August 10, 2008 1:19:50 PM

do you have the latest ATI drivers? since crossfire might have issues... it does not sound like a hardware issue.... and are you sure it is only in dx10? have you tried running crysis in dx9 mode?
August 10, 2008 7:04:40 PM

Make sure you have sp1 installed and all the updates with vista also
Related resources
August 11, 2008 1:30:01 AM

stalker isn't dx10 so that isn't a problem
!