Sign in with
Sign up | Sign in
Your question

BF2 - Catalyst 8.7 vsync problem fix.

Tags:
  • PC gaming
  • Video Games
Last response: in Video Games
Share
August 11, 2008 4:23:25 PM

I bought a 4850 couple of months ago. The card is amazing, but I couldn't make it to force Vsync in BF2. That was really annoying as I hate screen tearing and always play with Vsync enabled.
I did a bit of research on the net and it looks like a lot of ppl have the same problem. I've found a little trick to make it work:


I. BEFORE starting BF2:

1. go to CCC > Digital Panel > Attributes to make sure that both boxes under DVI Settings tab are unchecked.

2. go to CCC > Display Options and set the refresh rate you want to game at under 3D Refresh Rate Overdrive tab. In my case it's 75MHz.

II. Start the game:

1. press Alt+Ctrl+Del to go to the desktop.

2. go to CCC > Digital Panel > Attributes and check Reduce DVI frequency on high-resolution displays box under DVI Settings tab.

3. go to CCC > Display Options and change the refresh rate to a different one that your monitor supports, I set it to 60MHz.

4. Click "OK". Close CCC and Windows Task Manager.

5. Go back to the game and enjoy. Go through step I. when you finished playing in BF2.







More about : bf2 catalyst vsync problem fix

August 17, 2008 6:55:25 PM

Nice post. Hopefully this will help some people out. It seems weird to me that you would need to Vsync BF2 with a 4850. You should be getting like 100+FPS or something insanely over 60FPS. Is your monitor 1680? What kind of FPS do you get with you don't vsync it?

August 17, 2008 8:19:14 PM

I hate screen tearing. Games look so nicer with vsync on. I am actually surprised that ppl don't use this option as it has no impact on performance (except rather obvious fps cap) with today's hardware. I did a few benchies when I got my 4850 and I can remember that average fps with vsync on/off was very close. I'll post a graph once I find it on my hdd to prove it.
My monitor is 1280x1024@75Hz.
There is a cap in BF2 limiting fps to 100, I was getting 60-100 with vsync off.
Now I'm getting sweet 75 fps all the time with all settings maxed out and AA set to 2x.
April 2, 2009 5:24:04 PM

Hey Andy, i also recently had the same issue with my Vsync. I found an alternative fix. You can leave all your display options the way you want them to be set up, i leave mine on default, I just change my 3d options to enable Vsync and triple buffering. I have an LCD monitor that only supports 60hz with a DVI connection (digital). It looks great, but i could only seem to get vsync to work when i first started windows. If i was playing bf2 and minimized the game and the went to full screen my vsync would stop working. I then installed ATI tray tools but still had the same issue. Detemined to fix it i kept looking, and when i went to start menu ->all programs ->catalist control center, i saw there was an icon that said restart runtime. I clicked it loaded bf2 and hard to believe but it worked. As long as your vsync is enabled in tray tools and or CCC you should be able to get it to work by restarting runtime. I even made a desktop shortcut to this icon and put it right beside my bf2 icon. I click restart runtime, then click on my BF2 icon, and it works every time. also if i minimize my game to check something on the web i click this icon before entering full screen again, like i said works like a charm. Now that my screen doesnt tear my accuracy improved by 75% and game play is awesome.

Rob (guitarslaverob86)

ATI HD3870 1gb
AMD athlon 6000+ 3Ghz dual core
ASUS M3A78-EM motherboard
2 gb ram
XP home edition
!