The most illusive PSP Problem?

I bought a SanDisk 8gb Memory Stick Micro (Mark 2) today at my local computer store (original packaging) for the purpose of using it for my PSP. It came with a Memory Stick Pro Duo adapter (required to fit into the PSP memory stick slot). I put the Micro Memory Stick into the adapter, then into the PSP and formatted it using the PSP - which was successful. Next I connected the PSP to my computer via an intec USB cable. The psp was detected as a device as drive F:. I tried to open this drive but got the message "The disk in drive F: is not formatted. Would you like to format it now?".

I've tried formatting the stick again, re-inserting the stick and restarting both my computer and the psp, but nothing helped.
I've also seen this problem on many forums but no one can seem to offer a definitive solution.

I hope the helpful people at Tom's can help me out as they always have :)

Staying hopeful,
Maximu5
1 answer Last reply
More about illusive problem
  1. I just returned it and got an 8gb Sony Memory Stick Pro Duo Mark 2 for about $15 more. It's working fine so far.
Ask a new question

Read More

Handheld Gaming PlayStation Computers Memory Video Games