Sign in with
Sign up | Sign in
Your question

Worryingly lower FPS than expected in Supreme Commander.

Last response: in Video Games
Share
August 29, 2008 8:28:30 PM

Recently bought a new rig:

Asus P5Q Pro P45
4Gb RAM
Vista Premium 64bit
ATI HD 4870
Intel q6600 @ 2.4ghz


Im getting around 25 FPS in a skirmish in Supreme Commander. Generally dips to a low of about 10. Having based my choice of system, to a degree on the reviews of this site, (See http://www.tomshardware.co.uk/radeon-hd-4870,review-310...) Any one have any idea as to why such low FPS?

My ATI drivers are up to date, as it Vista.
August 29, 2008 9:17:21 PM

"a skirmish" could be many things - how many AI's are there? how far into the game is this?
August 29, 2008 10:10:30 PM

Admitadely there are 4 AIs, on an 80x80 map. Still, early on into the skirmish I was expecting a better framerate.
Related resources
August 30, 2008 12:15:52 AM

*Having run the SupCom benchmark test, I average out at 36 FPS, much lower than alot of tests seem to suggest it should be.
August 30, 2008 10:34:13 AM

*bump

Again, some help with this issue would be much appreciated.
August 30, 2008 1:19:30 PM

RTS can be laggy when there are multiple players & growing # of units. Just update your software & os.

What you don't know is what kind of modes the games were running in in the benchmarks. I'd say they would try to "cheat" and minimize the action so as to get a highest FPS possible. In reality, the FPS is always lower than the benchmarks.
August 30, 2008 6:41:34 PM

True; but this was run off of the SupCom official benchmark, built into the game. http://www.techarp.com/showarticle.aspx?artno=493 that was the guide i was basing my resutls off of.

Generally my avg FPS comapred to there cards and processors, is roughly half, somthing that surprises me given my system spec.
August 30, 2008 8:11:00 PM

Try turning off some unneeded running processes
September 1, 2008 2:15:29 PM

SamODJ said:
Recently bought a new rig:

Asus P5Q Pro P45
4Gb RAM
Vista Premium 64bit
ATI HD 4870
Intel q6600 @ 2.4ghz


Im getting around 25 FPS in a skirmish in Supreme Commander. Generally dips to a low of about 10. Having based my choice of system, to a degree on the reviews of this site, (See http://www.tomshardware.co.uk/radeon-hd-4870,review-310...) Any one have any idea as to why such low FPS?

My ATI drivers are up to date, as it Vista.


No, nothings wrong with your system or video card, it's your CPU were the bottleneck is. I play Supreme Commander Forged Alliance and the AI spams loads of tech 1 and 2 units. I have a E6400 @ 3.04Ghz and I played against 2 A.I opponents and after about half an hour the game slowed down as the the AI just sent countless tanks and bots to my base.

Each of those units has an A.I tree that it follows and what path is chooses is formulated by some complicated mathematical formulae, give the amount of work the CPU has to do it's no wonder your Computer buckles under the strain.

In future limit the maximum number of units each side can have.
Anonymous
August 12, 2009 2:33:01 PM

If got an FPS of 10 also and im running on a q9200 2.3, anyone a solution for this problem ?
August 12, 2009 4:26:01 PM

im not sure what my exact fps are but it never chops or lags at all on my setup @ 3.8. you guys need to bump up your clock speeds and it will all be fixed man - this is also on the biggest map with all AI's and max unit caps.
Anonymous
August 13, 2009 8:14:58 PM

I think my processor is not the problem it should be run pretty okay, i gues my nvidia 8500 1024 mb with a speed of like 450 mhz dont know exaclty, will kill my supcom fa. Can anyone tells me wich kind of video card does supcom fa runs the best on ?? realy looking forward for an answer.
!