Why can I run every game but Spore locks up my computer?

Well I recently got a new computer, its about 3 weeks old now and I've had pretty much no problems at all. I can run Crysis at high settings very easily, every other game works perfectly as well too. The only game that gives me problems is spore. I can play sometimes for 2 minutes, sometimes for maybe half an hour or so, until it freezes and completely locks up my computer. The sound will start to stutter, and then the display usually becomes pixelated, sometimes it just turns black. There is no way out of this once it happens, I must restart my computer via the power button. There has been maybe twice where I've been able to have it playing for the majority of the game, until I reach space and it did it again. Maybe just a coincidence though, I'm not sure.

For reference, here's a picture of what it usually looks like when it freezes: http://img512.imageshack.us/my.php?image=p1010341mv8.jpg

Specs:
Intel Core 2 Duo E8500 3.16GHZ
Radeon HD 4870
4 GB Ram DDR2
Windows Vista 32 bit running DirectX 10

It's definitely not a heating issue, everything is running at about 50 - 55 degrees Celcius, I've tried installing the patch, it will freeze with or without the patch. I don't understand why it's just this game and none of my other games have this problem.
9 answers Last reply
More about game spore locks computer
  1. I would be tempted to say memory, heat, or a bad GPU, but a working Crysis throws a wrench into that theory...

    Run memtest86, just to rule out RAM. Post both GFX and CPU while gaming, just for us to rule that out too.
  2. Sorry I kinda suck at things like this. I've downloaded memtest from http://www.memtest86.com/, now what do I do? I don't know how to get it to run. And what do you want me to post about my GFX and CPU and how do I do it? Thanks for your patience with me.
  3. What PSU? :bounce: Make & model. Did you download ISO image? Burn it to a CD and boot from it.

    Mike.
  4. Well I mount the image using daemon tools, and when I click on boot, it says: "the file is invalid for use as the following: Security catalog".

    My PSU is the antec TPQ 850.
  5. I've got the exact same problem. Only with me, the freeze comes after 2 or 3 minutes every time. I get the exact same pixelated screen as you.

    My specs:

    E6700 2.66 Ghz
    4 GB RAM
    Radeon 4870 512 MB
    Silverstone 550 W PSU
    Windows Vista Home Premium

    Anybody got any ideas here? I can't find a solution anywhere and EA support is not much help.

    My graphics card occasionally runs a bit hot (60 - 65 C) but I can run graphically intensive games such as Crysis and Far Cry 2 no problem. But Spore always crashes and hangs.
  6. That is funny but not at the same time....Spore brining a system to it's knees! What ATI driver version are you running? Are there any patches to spore?
  7. Quote:
    Well I mount the image using daemon tools, and when I click on boot, it says: "the file is invalid for use as the following: Security catalog".

    You need CD burning software, which will burn the ISO image to a CD to make a bootable CD!

    Mike.
  8. Memtest works in windows. Not to be confused with Memtest86. Might be a little easier to use for you.

    http://hcidesign.com/memtest/
  9. Is this a pirated version of Spore you are having trouble with?
Ask a new question

Read More

PC gaming Computers Games Video Games