Sign in with
Sign up | Sign in
Your question

Far Cry 2 on HD4870

Last response: in Video Games
Share
November 7, 2008 2:31:37 PM

hi,
Just got FC2 to my PC (Q6600@3.6, 2GB RAM and Radeon 4870) and it stutters. It's really annoying, I installed 8.10 and the hotfix but the game still slows down when I just walk around. I tried ultra high very high and high (even though this system should be capable for something like 40FPS on ultra high) but to no use... what can be the problem? is it fixable?
PS. using vista 64 ('cuz I had 4GB of ram but one was RMAed), running in 1680x1050 and w/ no AA.

More about : cry hd4870

November 7, 2008 4:50:50 PM

I am having the same problem, I have the 1gb 4870, q6600 @3GHz, 4 gigs, vista x64....It is a driver issue, I play the game at the same resolution, ultra high setting but I use 4xAA.

The frames never drop below 40 but the stuttering happens usually when driving and sometimes when i'm deep in the forest and there are tons of shadows everywhere.

There is another hotfix that just came out I think a week ago for the 8.10's that has fixed the problem for some people. I am going to try it later when i get home from work. If not I'll wait for the 8.11's to see.

The link to the hotfix

http://support.ati.com/ics/support/default.asp?deptID=8...

November 7, 2008 8:18:23 PM

I don't have much issues with FC2 after the hotfix. However, with other games I find that I have this issue. In TF2 there will be times where I'd totally freeze for a few seconds. I've checked my ping (stable at 30ms) and the FPS is stable (min of 60). This also happens with Bully (PC edition) sometimes too. I did not OC the card and I've tested my processor to be stable via Orthos testing for about 3-4 hours. I've got 4 GB of ram and I'm on XP. Anyone got any ideas?
Related resources
Anonymous
November 7, 2008 11:52:13 PM

It could be your HDD...

but at 1920 by 1200 I play at max (no aa) and turn the shadows to medium... theres no visual difference between the levels... except for the draw distance (could be considered visual difference... i mean quality though... and it doesn't bother me the drawing shadows) and i get about 60 fps average with the default benchmark run... then turn the shadows back to very high... and i get 24 fps average...

short story is... turn down shadows... long story is... you may have another issue as you should be getting considerably better frames then me at a lower resolution with the same card
November 7, 2008 11:59:37 PM

I never thought about the HDD being the problem...maybe a simple defrag will fix the stuttering.
November 8, 2008 12:07:31 AM

I doubt fragmentation of files will cause severe stuttering. My HDD has been defragmented monthly and I'm still having those issues and I highly doubt that turning up the shadows will cause the card to go on its knees. The bandwidth it provides is more than enough for 90% of today's games. The Duncia engine is better programed so it does run smoother than crysis and shouldn't have these issues. I didn't notice much lag in far cry2 unless I'm saving, but that's normal.
November 9, 2008 2:39:07 PM

I found a way to get some improvement but not complete (we'll have to wait for catalyst 8.11). I read about something that when v sync is enabled you are limited to certain f/r (something like: 60, 30,15...) so if your card can't get 60 it has to work in 30 (ie: no 50-40), but if you enable third buffer you can, can't link to the article because it's in hebrew... but a simple google will find it (look for v sync and third buffer).
November 10, 2008 11:14:44 AM

I get this too. It is bad especially when driving and double bad when driving through jungle areas. Ultra high shadow settings really drop FPS so I wouldn't try to go any higher than V.High for that.

Go through CCC 3D settings and make sure you set options to use application settings so you aren't running AA through CCC. I found that it doesn't do AA at all but you still get performance hits.

Also try using both vsync in combination with the console trick to limit FPS. Hit the ~ key and then type "gfx_maxfps 58" I can usually get a pretty smooth performance on 2xAA at V.High settings this way.


*Edit: If you haven't already, maybe tweaking vista would help too. Don't run Aero and turn off the indexing on your HDDs. Are you completely uninstalling the old drivers? Using add/remove programs to uninstall, deleting all ATI files, uninstalling your video card, and then installing just the hotfix? I tried to just install the hotfix over the old drivers and it didn't work at all.
November 10, 2008 7:20:23 PM

-not your hard drive; hard drive's really only affect loading times and regular stuttering is not hard drive related
-experiment with settings
-ensure your drivers are up to date for your motherboard, audio, and graphics card

-this game's running great on my similar but lower-speced system:
XP SP3, 2GB @400MHz, X2-4800+, HD3870

If you do a lot of gaming you might even consider dual-booting to XP 32-bit.

Another important thing to do is to use a program like Acronis True Image and make a backup of your Windows (usually C-Drive). I periodically restore things.

I'm willing to bet that the game would run better on XP based on my extensive testing of both Vista 32-bit and Vista 64-bit. I'd still recommend Vista 64-bit to lots of people though.

**Before doing anything, get the AMD Fusion tool, install it, reboot and run it to close unneeded applications. It is possible you are running out of RAM but I don't know enough about your system to tell. The AMD Fusion tool primarily frees up RAM but I've seen issues with other applications causing issues.
November 10, 2008 11:26:45 PM

I was just playing around with this tonight. If I don't cap the frame rates I get a lot of what looks like frame skipping. Give it a shot, it works really well for my 4870.

It has to be the drivers. In my game, people have red ears and wood pallets are psychedelic purple. I got this after the latest hotfix that ATI posted. The drivers are not quite up to par yet I would say.
!