Wireless router behind a wired router

Archived from groups: alt.internet.wireless (More info?)

For several reasons, I would like to set up my linksys wireless router
behind my linksys wired router, which is behind my cable modem..

Both boxes are ok, in that I can use either one behind the cable modem
properly.
But, when I put the wireless router behind the other router, I can't see the
net.

What am I missing?

--
KC6ETE Dave's Engineering Page, www.dvanhorn.org
Microcontroller Consultant, specializing in Atmel AVR
10 answers Last reply
More about wireless router wired router
  1. Archived from groups: alt.internet.wireless (More info?)

    Are the routers connected via their LAN ports or via a LAN port to WAN port
    connection?

    If the former, you may need a crossover cable between them. Also, you need
    to turn off the wireless router's DHCP server and also assign it a fixed IP
    address in the subnet of the wired router that is outside of the range that
    the wired router is set to assign (i.e. if the wired router is at
    192.168.1.1 and assigns addresses starting with 192.168.1.100 then the
    wireless router should be set to a fixed address like 192.168.1.2).

    If the latter, everything should work as long as both routers are set to
    obtain their IP addresses via DHCP and are set to operate as DHCP servers
    (usually the default configuration). You may run into problems with
    applications that use UPnP since they may only open an incoming port on the
    wireless router and not on the wired router (the one closest to the cable
    modem) unless the wireless router also uses UPnP to instruct the wired
    router.

    -Yves

    "Dave VanHorn" <dvanhorn@cedar.net> wrote in message
    news:yqKdnQPftv3Uv6zcRVn-pQ@comcast.com...
    >
    >
    > For several reasons, I would like to set up my linksys wireless router
    > behind my linksys wired router, which is behind my cable modem..
    >
    > Both boxes are ok, in that I can use either one behind the cable modem
    > properly.
    > But, when I put the wireless router behind the other router, I can't see
    > the net.
    >
    > What am I missing?
    >
    > --
    > KC6ETE Dave's Engineering Page, www.dvanhorn.org
    > Microcontroller Consultant, specializing in Atmel AVR
    >
    >
  2. Archived from groups: alt.internet.wireless (More info?)

    Does this drawing show what you're trying to do?

    Cable Modem
    |
    |
    Wired Router
    |
    |
    Wireless Router
    | | |
    | | |
    C1 C2 C3

    If so, remember that the Wireless router "sees" the Wired Router on the WAN
    side.

    I did this and created two IP ranges.

    For the Wired router, have 192.168.1.1
    For the wireless, I have 192.168.2.1

    The wireless "WAN" address needs to an address on the wired "LAN".

    I gave mine a static IP of 192.168.1.100, and told the Wireless to start
    DHCP at 192.168.1.108 (I have a couple of other devices with static IPs)

    That should do it. Note that I actually have my wireless router closest to
    the
    cable modem and my wired router behind it.

    HTH
  3. Archived from groups: alt.internet.wireless (More info?)

    "Dave VanHorn" <dvanhorn@cedar.net> wrote in message
    news:yqKdnQPftv3Uv6zcRVn-pQ@comcast.com...
    >
    >
    > For several reasons, I would like to set up my linksys wireless router
    > behind my linksys wired router, which is behind my cable modem..
    >
    > Both boxes are ok, in that I can use either one behind the cable modem
    > properly.
    > But, when I put the wireless router behind the other router, I can't see
    the
    > net.
    >
    > What am I missing?
    >
    > --
    > KC6ETE Dave's Engineering Page, www.dvanhorn.org
    > Microcontroller Consultant, specializing in Atmel AVR

    Some people use one of the routers as just an access point, and don't use
    the router portion of that device. But I have two routers arranged exactly
    as you've described, and it works for me. Devices on the middle LAN can't
    see the devices on the LAN farthest from the cable modem, but all computers
    can reach the Internet. Did you assign different subnet addresses to your
    two LANs?

    Ron Bandes, CCNP, CTT+, etc.
  4. Archived from groups: alt.internet.wireless (More info?)

    "Dave VanHorn" <dvanhorn@cedar.net> wrote in message
    news:yqKdnQPftv3Uv6zcRVn-pQ@comcast.com...
    >
    >
    > For several reasons, I would like to set up my linksys wireless router
    > behind my linksys wired router, which is behind my cable modem..
    >
    > Both boxes are ok, in that I can use either one behind the cable modem
    > properly.
    > But, when I put the wireless router behind the other router, I can't see
    the
    > net.
    >
    > What am I missing?

    http://www.linksys.com/support/top10faqs/wrt54g/Connecting%20two%20WRT54G%20routers%20together.asp

    Duane :)
  5. Archived from groups: alt.internet.wireless (More info?)

    Can C4 and C5 see the Internet? If so, then the Wired router is set up
    correctly.

    The DNS entries on the wireless router need to be the same as on the wired
    router.

    I use cox, so I have my router closest to the cable modem to use DHCP on the
    WAN
    (Get IP automatically).

    On my farthest router (your Wireless router), I have the WAN set to use a
    static IP, but I
    entered the same DNS IP addresses cox gave me. I think that might fix it
    for you.


    "Dave VanHorn" <dvanhorn@cedar.net> wrote in message
    news:mfWdnQADIIfpuK_cRVn-tA@comcast.com...
    >
    > > Does this drawing show what you're trying to do?
    >
    > Almost, this is more or less right.
    >
    > > Cable Modem
    > > |
    > > |
    > > Wired Router
    > > | | |------------C5
    > > | |---------------C4
    > > |
    > > Wireless Router
    > > | | |
    > > | | |
    > > C1 C2 C3
  6. Archived from groups: alt.internet.wireless (More info?)

    > Are the routers connected via their LAN ports or via a LAN port to WAN
    > port connection?

    Tried both..

    > If the former, you may need a crossover cable between them.

    I get a link light on both ends, in the LAN port, and in the "Uplink" port
    next to port 4 on the wireless box. The uplink port also shows as 100mbit,
    which would be preferable.

    > Also, you need to turn off the wireless router's DHCP server and also
    > assign it a fixed IP address in the subnet of the wired router that is
    > outside of the range that the wired router is set to assign (i.e. if the
    > wired router is at 192.168.1.1 and assigns addresses starting with
    > 192.168.1.100 then the wireless router should be set to a fixed address
    > like 192.168.1.2).

    Yup.

    > If the latter, everything should work as long as both routers are set to
    > obtain their IP addresses via DHCP and are set to operate as DHCP servers
    > (usually the default configuration).

    Umm. Isn't the second router's DHCP supposed to be off per above?

    > You may run into problems with applications that use UPnP since they may
    > only open an incoming port on the wireless router and not on the wired
    > router (the one closest to the cable modem) unless the wireless router
    > also uses UPnP to instruct the wired router.

    I don't anticipate needing that.
    --
    KC6ETE Dave's Engineering Page, www.dvanhorn.org
    Microcontroller Consultant, specializing in Atmel AVR
  7. Archived from groups: alt.internet.wireless (More info?)

    No. As far as I know, DHCP is for the LAN ports only and is not passed on
    through the WAN ports. Thus, if you connect
    modem->router1wan->router1lan->router2wan you need to enable DHCP on both
    routers in order for devices connected to router2lan to obtain IP addresses.

    -Yves

    "Dave VanHorn" <dvanhorn@cedar.net> wrote in message
    news:drSdnUkiYPCBu6_cRVn-gw@comcast.com...
    >> Are the routers connected via their LAN ports or via a LAN port to WAN
    >> port connection?
    >
    > Tried both..
    >
    >> If the former, you may need a crossover cable between them.
    >
    > I get a link light on both ends, in the LAN port, and in the "Uplink" port
    > next to port 4 on the wireless box. The uplink port also shows as
    > 100mbit, which would be preferable.
    >
    >> Also, you need to turn off the wireless router's DHCP server and also
    >> assign it a fixed IP address in the subnet of the wired router that is
    >> outside of the range that the wired router is set to assign (i.e. if the
    >> wired router is at 192.168.1.1 and assigns addresses starting with
    >> 192.168.1.100 then the wireless router should be set to a fixed address
    >> like 192.168.1.2).
    >
    > Yup.
    >
    >> If the latter, everything should work as long as both routers are set to
    >> obtain their IP addresses via DHCP and are set to operate as DHCP servers
    >> (usually the default configuration).
    >
    > Umm. Isn't the second router's DHCP supposed to be off per above?
    >
    >> You may run into problems with applications that use UPnP since they may
    >> only open an incoming port on the wireless router and not on the wired
    >> router (the one closest to the cable modem) unless the wireless router
    >> also uses UPnP to instruct the wired router.
    >
    > I don't anticipate needing that.
    > --
    > KC6ETE Dave's Engineering Page, www.dvanhorn.org
    > Microcontroller Consultant, specializing in Atmel AVR
    >
    >
    >
  8. Archived from groups: alt.internet.wireless (More info?)

    > Some people use one of the routers as just an access point, and don't use
    > the router portion of that device. But I have two routers arranged
    > exactly
    > as you've described, and it works for me. Devices on the middle LAN can't
    > see the devices on the LAN farthest from the cable modem, but all
    > computers
    > can reach the Internet. Did you assign different subnet addresses to your
    > two LANs?

    Nope, should I? If so, then what?
    I've never used the subnet features, I've always just left them in default.

    --
    KC6ETE Dave's Engineering Page, www.dvanhorn.org
    Microcontroller Consultant, specializing in Atmel AVR
  9. Archived from groups: alt.internet.wireless (More info?)

    > On my farthest router (your Wireless router), I have the WAN set to use a
    > static IP, but I entered the same DNS IP addresses cox gave me. I think
    > that might fix it
    > for you.

    Well, after walking through it all again, it's working..
    Damifino why, I guess I should swing the chicken clockwise next time.

    I'm documenting all my settings now, in case of a reset.

    --
    KC6ETE Dave's Engineering Page, www.dvanhorn.org
    Microcontroller Consultant, specializing in Atmel AVR
  10. Archived from groups: alt.internet.wireless (More info?)

    > No. As far as I know, DHCP is for the LAN ports only and is not passed on
    > through the WAN ports. Thus, if you connect
    > modem->router1wan->router1lan->router2wan you need to enable DHCP on both
    > routers in order for devices connected to router2lan to obtain IP
    > addresses.
    >

    Well, it's working now, with DHCP off on the wireless box.
    My test PC is browsing just fine, AND the PCs on the "inside" can see the
    ones on the wireless router. Cool!

    Thanks for the help guys, there's just so many ways to get it a little bit
    wrong.


    --
    KC6ETE Dave's Engineering Page, www.dvanhorn.org
    Microcontroller Consultant, specializing in Atmel AVR
Ask a new question

Read More

Wireless Router Routers Modem Linksys Cable Wireless Networking