A7N8X Have Bad Memory?

My computer reboots itself in windows and drops out of programs. Is my memory bad? I have pc2700 ram. Running memtest says mem is bad and needs replaced when I have mem frequency chosen by SPD (166 freq). When set to auto it sets freq at 133 and memtest doesn't find any errors. I tried moving the 2 sticks of ram to different slots with same results. I have 2 sticks of Crucial totaling 512. Athlon XP2100. No overclocking. Even though my processor is 133 the memory should still work at 166 right? Thanks for any help or ideas.
9 answers Last reply
More about a7n8x memory
  1. My friend had the same problem with pc2700 ram and a similar intel board. Basically flash your bios and if that doesn't work then you will have to just run your memory synchroneously with your cpu at 133 fsb. It's kindof a waste of pc2700 memory but that fixed his problems so it might work for you too.

    To err is human... to really screw things up you need a computer!
  2. If your memory is reporting errors at it's rated speed, you probably do have at least one strip of bad memory there. Ram usually carries a 1 year warranty, so unless it's out of warranty you should be able to get it replaced free.

    It's unlikely that Bios or software updates will help you if there's a reported memory error.... Just take it back and get it replaced.


    ---> <b>Press ALT-F4 for IQ test</b><---
  3. Also a good suggestion, try running a memtest.

    To err is human... to really screw things up you need a computer!
  4. Well I'm wondering if there is a problem with the motherboard being picky about its ram at higher speeds? The ram is new and I tried each stick separately and each one had errors at 333 but none at 266. It seems to me it would be rare to get 2 bad sticks of ram from Crucial? I am waiting for an e-mail reply from Crucial. Seems to me lots of people are having trouble with random reboots. I'm actually hoping its a problem with the ram because that would be an easier fix than having a problem with the motherboard.
  5. or it could be just plain DDR333 compatibility issue
  6. IF you are getting errors at the memory's rated speed there are 2 possibilities:

    1) you have bad ram
    2) you have a bad motherboard

    Given all the problems I'm seeing with A7N8X boards, I'd say it's a coin toss... Is there another machine --one not using A7N8X-- you can stuff that memory into for testing? If it tests ok on a different machine, you know it's the motherboard. If it tests bad on a different machine you know it's the ram.


    ---> <b>Press ALT-F4 for IQ test</b><---
  7. I did put the memory into a MSI K7N420 Pro and it ran good with memtest. I don't think it was running at 333 though? I couldn't find anything in the bios that I could change to that speed for the memory. Is there any programs that tell you what speed your memory is running at? I'm getting to the point where I feel like returning everything.
  8. Last week I received my brand new ASUS A7N8X Deluxe along with my AXP 1700+ and a couple of Winbond DDR400 256MB Memory modules.

    Installed everything, fired up windows install, drivers loading all is well until all of a sudden it hangs.

    Uh oh.

    I've run memtest86, and as expected a bunch of errors came out, apparently from the second stick.

    I take out the second stick, run memtest, all is well. I replace the stick that passed the test with the other one, run memtest86 and all is well. That one really had me stumped.

    I put them both together again, and voilla, errors again.

    I then tested some combinations of single/dual sticks in each slot, apparently memory slots 2 and 3 are causing these errors. 2 sticks or even a single stick in one of these slots would cause errors in memtest86.

    RMAd the board, waiting for replacement :/
  9. The A7N8X is very picky about using Dual Channel DDR. It's highly recommended you purchase a matched set tested for DualDDR. For example Corsair provides the XMS Twin Sets.
Ask a new question

Read More

Motherboards RAM Memory Computer