Sign in with
Sign up | Sign in
Your question

Downloaded The Orange Box off Steam and Half Life 2 doesn't work

Last response: in Video Games
Share
January 2, 2009 10:06:13 AM

Hey all,

I downloaded The Orange Box off Steam and everything works fine apart form Half Life 2 and Half Life 2 : Lost Coast. Does anyone know why this might be? I am running 64-bit vista. When I load the games it simply enters a blurred screen and says 64-bit mode activated. Then nothing happens......

Thanks in advance Peaks,
January 2, 2009 10:29:35 AM

Hi Peaks

I had the same problem.

Go into your games list inside Steam, find the HalfLife2 entry, then right-click and choose Properties.

Then click the Launch Options button and enter the following

-32bit

Then launch HalfLife2 and you should be fine.

You should also find you need to do the same with Lost Coast.

The 64-bit versions of those two are borked at the mo, and Valve are working on it.

Cheers, hope it helps
Dave
January 2, 2009 11:06:50 AM

Yes that worked perfectly thanks dave. Any ideas when valve are gonna fix this problem. I mean The Orange Box has been out a while now its not like them to take this long with stuff!
Related resources
January 2, 2009 11:41:37 AM

Glad that worked out for ya :D 

Well, Valve are working on it, as I write no doubt.

They are constantly improving their games. There were no 64-bit versions of the games (or source engine) when the Orange Box was released. The only reason that the 64-bit versions now exist (and were working up until a patch a few weeks ago) is because Valve wanted to bring performance enhancements to those with 64-bit OS. Like when they added HDR to Counter Strike:Source. They didn't have to, we had already bought the game, but they just wanted to give us a better experience.

And don't worry, their track-record is second-to-one. It will be fixed, and the 32-bit versions are still outstanding.

Good luck with the games, they all absolutely rock. Especially Portal ;) 
November 23, 2009 2:03:32 PM

I have the very same problem, but your solution doesn't work for me. When I open the launch options it says that these are for advanced users only (idk if it always says that).
When I enter "-32bit" anyway and click OK, nothing seems to happen. When I launch the game, it still freezes before properly starting.
!