Sign in with
Sign up | Sign in
Your question
Closed

"Error 1935" when Installing Applications. Please Help!

Last response: in Windows 7
Share
August 25, 2010 4:43:54 AM

Hi all,

1- I was trying to install my Microsoft Flight Simulator X and I got the "Error 1935" at the end when it was "Publishing Product information", it then rolled the action back and I got this exact error massage:

Error 1935.An error ocurred during the installation of assembly
'Microsoft.MSXML2,publicKeyToken="6bd6b9abf345378f",version="4.1.
0.0",type="win32",processorArchitecture="x86"'.Please refer to Help
and Support for more information.

2- So I looked up what "Error 1935" was and found this site(link below) which says, "This error occurs during the system update stage of the installation when the Microsoft XML Parser 4 installs."

http://resources.arcgis.com/content/kbase?fa=articleSho...

3- I then went to this site(link below) to update my Microsoft XML.

http://www.microsoft.com/downloads/details.aspx?FamilyI...

4- But when I start installing Microsoft MSXML 4.0 SP2 Parser and SDK it gets stuck at "Publishing Product Information" part. In about 10-20 minutes it rolls back the action and says in ended prematurely because of an error, and that nothing has changed and you need to rerun it again at a later time.

5- I found this form(again, link below) that explains why the Microsoft MSXML 4.0 SP2 might not be installing.

http://social.answers.microsoft.com/Forums/en-US/w7prog...

Here is what the link says for me to do:

Click Start
Click All Programs
Click Accessories and right click on the Command Prompt.
Select the Security Tab and choose "Run as Administrator"
Click on Command Prompt
Type SFC /Scannow.
This will scan and fix any corrupted operating system files.

6- I did exactly what the instructions said, but after starting the Command Prompt I got this massage, "Windows Resource Protection could not start the repair service". So yet again I looked up what this was and found this right away(link below).

http://www.winhelponline.com/blog/fix-for-error-windows...

I did what it says in this link also, but it was already set to manual. I reset it again to manual and Command Prompt still had the same error.

I have also tried uninstalling Advast and booting up in my Windows cd and Starting up only the core system 32 files and Command Prompt and starting in safe mod to try and all with no success.

I have Windows 7 Pro 64bit that was a upgraded from Windows XP Home. And a cd that I can use to boot from with my Win 7 pro 64bit on it.

Not sure where else I can go with this. I am wanting to get this MSXML 4.0 working for more than just installing applications, because I am having problems with it with other applications, minor ones though. And just to get in fixed in and for itself.

Any ideas are appreciated.
August 25, 2010 5:24:44 PM

I prefer not using third party registry cleaners, but I guess I don't have much of an option, or do I?
Score
0
Related resources
August 26, 2010 12:27:29 AM

I downloaded the top link and ran it. I got 928 error's detected by it.

Then I download the second one and tried to run it, but it isn't compatible with windows 7.

Then I tried the last one Registry booster. Got 1276 registry errors :(  1186 of them in system related errors and 90 in user related errors. But it only allows me to fix 15 of them without buying the program, also annoying.

I'll run use the top and post what I find.
Score
0
August 26, 2010 2:35:09 AM

I one of them, but it only fixes about 10 errors then you have to buy it to fix the rest.
Score
0
January 19, 2012 6:24:10 AM

Following are the various ways you can implement to fix error 1935

1. Reinstall Microsoft .NET Framework
2. Perform a Full Virus Scan
3. Full Scan your Registry
4. Reregister Windows Installer
5. Check System Files for Corruption
6. Clean the System Junk

For optimum results, use a System Cleaner application; or follow the instructions given below:

1. Click Start, point to All Programs | Accessories | System Tools | System Cleaner.
2. Select your system drive where you selected to install the product.
3. Press ENTER or click OK.
4. Follow the on screen instructions.
You can also get some help from this article error 1935 windows 7.
Hope it fix your problem.
Score
0
January 26, 2012 6:13:52 AM

A computer with Microsoft .NET Framework installed may show error 1935. This generally occurs while the MSI files are trying to install various policy files on your computer during the setup operations.

Following are the various ways you can implement to Fix Error 1935

1. Reinstall Microsoft .NET Framework
2. Perform a Full Virus Scan
3. Full Scan your Registry
4. Re-register Windows Installer
5. Check System Files for Corruption
6. Clean the System Junk
I am sure this will solve your problems regarding Error 1935
Score
0
a b \ Driver
a b $ Windows 7
January 26, 2012 8:15:32 AM

This topic has been closed by Nikorr
Score
0
!