Sign in with
Sign up | Sign in
Your question

Graphic flicker on campaign map in Medieval 2: Total War

Last response: in Video Games
Share
January 16, 2009 11:04:45 AM

Hey! When I play Medieval 2: Total War the graphic flickers on the campaign map, but it's just the shadows of the settlements and the buildings and such that flicker, not the caracters and soldiers. And I don't have any graphic problems on the battle map.
I have the ATI HD 4870X2 graphic card, a quad core 2.4 GHz and 4 GB ram.
Does anyone know how I can fix this?? I appreciate any help! Thanks!
January 16, 2009 12:05:23 PM

upgrade to the later graphics drivers,

i had the same probs years ago with the command and conquer series, and the updated drivers fixed the issues.

if the driver upgrade doesnt help, then try some of the older drivers to see if that helps.
January 16, 2009 5:54:42 PM

Thorgrim said:
Hey! When I play Medieval 2: Total War the graphic flickers on the campaign map, but it's just the shadows of the settlements and the buildings and such that flicker, not the caracters and soldiers. And I don't have any graphic problems on the battle map.
I have the ATI HD 4870X2 graphic card, a quad core 2.4 GHz and 4 GB ram.
Does anyone know how I can fix this?? I appreciate any help! Thanks!


I have a 8800GT and I'm getting flickers in that game as well but I'm also getting flickers in other games like The Withcer. I hope to god that my video card isn't artifacting and breaking down I have the worst luck with video cards and I don't even overclock them.
March 16, 2009 10:56:08 PM

I am also getting the very same flickering in Medieval 2: Total War as you Thorgrim.

I have a core i7 920, ATI HD4870X2, 6GB 1600 corsair dominator ram and Vista 64bit.

I am running the latest ATI catalyst 9.2 drivers and I believe it is some sort of anti-aliasing bug in the new driver for that game. I have not figured out exactly what setting is doing it, but I do have all settings in CCC panel set to use application settings.

I am finding a simple reboot gets rid of the flickering on the Medieval 2: Total War map and then it only seems to come back if I load the game up and have been using windows for a bit i.e. a clean start of the game after a fresh reboot seems to get rid of the annoying flickering. Also at all times playing the game their are no graphical errors on the battle map. they always seem to be on the campaign map only.

!