Sign in with
Sign up | Sign in
Your question

BF2142 not working

Tags:
  • PC gaming
  • Connection
  • Windows Vista
  • Servers
  • Video Games
Last response: in Video Games
Share
January 21, 2009 1:11:54 AM

i run vista 64bit and whenever i try to connect to a server on BF2142 it closes and says it stopped working.
how do i fix this?

More about : bf2142 working

January 21, 2009 12:24:11 PM

i run vista 32 bit and get the same problem :( 
January 22, 2009 1:24:11 AM

SOLUTION FOUND

Well if your like me, then your game crashes after every time you click connect to a server. Well if you have an X-FI card, there's your problem. NOTE: it is very important to do it in this order

1. First of all, if you have vista, navigate to control panel-Hardware and sound-View hardware and devices. You can get here with XP/Classicview, but im not sure how becuase i run vista

2. Go down to sound, video and game controllers and open that.

3. Disable Creative SB X-Fi (a box may pop up, just click OK) keep the Device manager window open

4. Start up BF2142, and go to audio settings

5. Go to audio renderer and select Creative X-Fi

6. Alt tab, and reenable your Creative SB X-Fi driver

7. You should be set to play the game now

Note: I believe that steps 5 and 6 may be interchangeable with each other

Note: This may also work for BF2, but is not yet tested

-Tioga060
Related resources
Can't find your answer ? Ask !
January 22, 2009 11:24:53 AM

i have that card and it stopped working when i put it in, never thought of it :( 
January 22, 2009 1:41:43 PM

Those darn X-fi cards. Seems like they cause a lot of conflicts. They are great when they work but sheesh. I wish I would have went with an ASUS Xonar instead. I can't recall one conflict with a xonar.
!