Closed

Direct3DDevice9::Present failed: Driver internal error?

Hi guys, i get this Dirext3DDevice error when i am playing Call of Duty World at War. I have a AMD Phenom 9950 Quad Core with 4gb of ram, and a ATI Radeon 4670 1gb DDR3 video card. Now i can play Call of Duty fine when i am not running any other games in the background. I play Silkroad Online, i have a bot for it so i can run multiclient (run more than 1 person at a time, like run 2 games at once). I run 1 Silkroad client and call of duty and it works fine, but whenever i have 2 Silkroad clients open and i launch call of duty it loads to the main menu and i join a server and like 40% through the loading bar it freezes and i get the Direct3DDevice Error. Anyone have any fixes or having the same problem? Also my friend can run 2 silkroad clients and call of duty with a slower computer than mine, he has a AMD 5400+ with a ATI Radeon 3650 512mb DDR3?

Thanks guys, hopefully someone knows something i don't. :)

Link to Error: http://s688.photobucket.com/albums/vv246/moe2o56/?action=view&current=DirectXError.jpg
20 answers Last reply
More about direct3ddevice9 present failed driver internal error
  1. Does anyone have any clue about this at all???
  2. You have a very specific problem and that you are attempting to run 3 games at once.
  3. Aye, do not think you will find many with experience of Silkroad here....its certainly the first time ive heard of it.

    Coupla things i can suggest - you dont mention that you have installed the latest version of DirectX so if thats the case try that.
    If that dont work then open your apps at the min resolution 800 x 600 and then once launced turn them up. Sorry its more of a workaround, would need to know more about Silkroad to be of any use.
  4. ohhh silkroad = MMO kinda game and you are botting in it. /finishes coffee >.<
    Have you tried running Silkroad at min settings while its running in the background?
  5. Ya i tried reinstalling DirectX and that didnt help at all, im going to try and run silkroad at minimum settings and give it a try :)
  6. ok well i tried 1024x768 resolution and that didn't work, so then i tried 800x600 resolution, i minimized the games then run cod and it wouldn't load so i hit ctrl+alt+del and it came up and my catalyst control center was open and it gave me the VPU Error saying my video card crashed???
  7. What PSU do you have? It might be crashing under load due to being underpowered. (Doesnt explain the Direct3D error though..)
    Other than that i can only suggest you compare drivers with your mate and check your temps.
  8. i got a 750 Watt Ultra PSU.
  9. Ok well lets check the version number of your Direct X. Sometimes an update doesnt update.

    Start > Run > type "dxdiag" and hit enter
    Allow the app to load and the version number will appear in the bottom right...will be 5.xx.xxxx.xxxx

    Failing that the only other thing could be rolling back CCC to something that works...you may have to go back quite a few versions so check what yur mate is on as well.
  10. So can someone help me figure this problem out??? pr2thej my dxdiag says my directX version is 4.09.0000.0904.
  11. moe2o56 my directX version is the same as yours, have you figured out how to fix it yet?

    I just downloaded the new 1.4 patch for cod and i get the "Direct3DDevice9: :Present failed: Driver internal error" error message aswell.

    Just crashes and shuts down CoD everytime one of the new maps load, but all the older original ones are fine? HELP PLEASE =[
  12. Me too ive got the same fault message. New map loads say 10% then black screen. Full crash and get the dreaded error message. All the other maps run great.

    I fully formatted HD and reinstalled windows xp pro edition, All drivers are updated. Still the same issue with COD WAW. Patches installed correctly.

    Please help as this is just getting me down.

    :cry:
  13. same error for me with the version 1.4 . with the other patches it was running great.i don't know really what to do

    help me
  14. Im still trying to resolve the issue. Activision support are doing all they can to help but they seem to be in the dark as to why this is happening. I have uninstalled cod waw again and deleted the game folder. Now im reinstalling and just updateing using patch 2 and 2-4. NOT 3 as it seems the new patch is culmative. Maybe this may work. I will post again once I have completed install and tested the game. Should be in the next 2 hours.

    Until then fingers crossed.

    paperello64 can you give system specs please as it may be a hardware issue. If your GFX card and direct x are the same as mine then it may explain the reason.

    Thanks and any other input is welcome. Lets all beat this issue together.
  15. NO joy on the reinstall. Still the same. I have spoken with a friend and he is lending me a different graphics card. So when I get it which looks like next week now I will update you again as to the outcome.
  16. I also have same issue with Radeon 4870 1gb by Asus

    Same error but only on 1 map newvillers since 1.4 patch installed, all other maps run fine except once in a while i get booted off map, but restart COD5 and wa-la, but not Newvillers, this map gives me direct3DDevice9 error all the time and kills the game. My DirectX version is5.03.2600.5512, and i loaded latest ATI drivers because same thing occured under ASUS drivers.

    Funny how its only one map, I too have deleted the map folder for that map, and all maps and the whole game but no go.
    MWAD - "Man What A Drag"

    Gunther

    :gun:
  17. I have the same problem, the dreaded direct 3d driver failure but it happens on any map. I run a 7950 gtx card with 512 and a 2.66 dual core with 4 megs ram.

    The times that it happens seems to be when in direct combat and hitting too many keys at one time?

    I hope someone comes up with a solution, but for now I just reboot and it starts direct 3d running again. COD 5 is the only program I'm running when this happens. Did this since the newest update was installed for COD 5.
  18. I just started recieving this error as well while playing Call of Duty Modern Warfare 2 (Multiplayer). I know it's very long but here is my DxDiag.txt file. If you're just wondering the version it's DirectX 11 and I was running the game at the min. for video settings (i.e. lowest resolution). I deleted almost everything I didn't think was needed as it's quite long (and didn't seem likely related). I'll also note that I'm using RivaTuner as well. I am not over/underclocking though... just using them to keep my cards cooler. The 2 cards run between 45 to 60 degrees C.

    ------------------
    System Information
    ------------------
    Time of this report: 1/25/2010, 16:23:12
    Machine name: DELL-HEATER
    Operating System: Windows Vista™ Home Premium (6.0, Build 6002) Service Pack 2 (6002.vistasp2_gdr.090803-2339)
    Language: English (Regional Setting: English)
    System Manufacturer: Dell Inc.
    System Model: Dell XPS720
    BIOS: Phoenix ROM BIOS PLUS Version 1.10 A06
    Processor: Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz (4 CPUs), ~2.4GHz
    Memory: 2044MB RAM
    Page File: 1803MB used, 3241MB available
    Windows Dir: C:\Windows
    DirectX Version: DirectX 11
    DX Setup Parameters: Not found
    DxDiag Version: 7.00.6002.18107 32bit Unicode

    ------------
    DxDiag Notes
    ------------
    Display Tab 1: No problems found.
    Sound Tab 1: No problems found.
    Sound Tab 2: No problems found.
    Input Tab: No problems found.

    --------------------
    DirectX Debug Levels
    --------------------
    Direct3D: 0/4 (retail)
    DirectDraw: 0/4 (retail)
    DirectInput: 0/5 (retail)
    DirectMusic: 0/5 (retail)
    DirectPlay: 0/9 (retail)
    DirectSound: 0/5 (retail)
    DirectShow: 0/6 (retail)

    ---------------
    Display Devices
    ---------------
    Card name: NVIDIA GeForce 8600 GTS
    Manufacturer: NVIDIA
    Chip type: GeForce 8600 GTS
    DAC type: Integrated RAMDAC
    Device Key: Enum\PCI\VEN_10DE&DEV_0400&SUBSYS_043810DE&REV_A1
    Display Memory: 1009 MB
    Dedicated Memory: 243 MB
    Shared Memory: 765 MB
    Current Mode: 1920 x 1200 (32 bit) (60Hz)
    Monitor: Dell 2407WFP-HC (Digital)
    Driver Name: nvd3dum.dll,nvwgf2um.dll,nvwgf2um.dll
    Driver Version: 8.17.0011.9621 (English)
    DDI Version: 10
    BGRA Supported: Yes
    Driver Attributes: Final Retail
    Driver Date/Size: 1/11/2010 21:03:33, 9388648 bytes
    WHQL Logo'd: Yes
    WHQL Date Stamp:
    Device Identifier: {D7B71E3E-4740-11CF-FB56-33241FC2C535}
    Vendor ID: 0x10DE
    Device ID: 0x0400
    SubSys ID: 0x043810DE
    Revision ID: 0x00A1
    Revision ID: 0x00A1
    Video Accel: ModeMPEG2_A ModeMPEG2_C ModeVC1_C ModeWMV9_C

    DDraw Status: Enabled
    D3D Status: Enabled
    AGP Status: Enabled

    --------------
    System Devices
    --------------
    Name: AGEIA PhysX 100 Series PCI Card
    Device ID: PCI\VEN_1971&DEV_1011&SUBSYS_00011043&REV_00\4&25DB9FF8&0&2878
    Driver: C:\Windows\system32\DRIVERS\physX32.sys, 1.01.0001.0015 (English), 2/29/2008 10:18:38, 120960 bytes
  19. Hope I'm not too late to help someone. I had the exact same problem. direct3ddevice9 present failed


    I'm pretty sure in most cases it's a hardware problem.

    I narrowed down the error to the MotherBoard by switching all components one at a time. Then I started researching the Motherboard. I have an eVGA 790i nforce MB. After reading and re-reading everything I could get my hands on I finally found a guy that knew what he was talking about.

    On some of these boards, you can only have 2 sticks of memory above 13000 FSB. I had 4. The memory slots are different colors on these boards and the faster memory is color coded. Check you MB manual on RAM and read it carefully.

    Once I took out the extra 2 sticks, essentially leaving on 2 2GB sticks in the memory slots that were color coded for them, the problem went away. I don't put the colors here cause when I changed my Wife's computer DDR2 to DDR3 ASUS P5KC I discovered the same problem but the slots were color coded differently. On that mb it does not recognize more than 2GB of RAM for the xp 32bit systems whether it be ddr2 or ddr3. And, you can't mix the two. Either 2gb ddr2 or 2gb ddr3. I had 4GB in hers and when I looked at it with HWINFO, sure enough it only recognized 3GB. Then they go on to say they recommend less than 3GB. So that leaves 2GB actual cause I've never seen any sticks that are 1.5 gb apiece. Heh.

    So, check your motherboard manuals or read them online and see what it says about the ram installations.

    In my case, I at first only crashed in COD4 once in awhile and it gradually got more often until it crashed immediately. Then Win7 crashed occasionally... steadily getting worse. Once I put in the correct amount of RAM all problems went away and I'm overclocked nicely now.
  20. This topic has been closed by Mousemonkey
Ask a new question

Read More

PC gaming Call of Duty Video Games