Sign in with
Sign up | Sign in
Your question

Configuring RAID 0 with Soyo Dragon Plus

Last response: in Motherboards
Share
March 31, 2003 10:27:48 PM

I have a Soyo Dragon Plus! (KT266A chipset) and I'm trying to configure a RAID 0 array with two new Seagate Barracuda 7200.7 (40 GB) HDs (using onboard Promise controller). I was able to create the array without problems, but I just can't make it bootable. The manual says that to make an array bootable I just have to enter my RAID BIOS (Promise Fasttrak100 Lite) and select option <3>, "Define array"; Well, what is strange is that for me menu option <3> is "View array configuration", I was able to create my array only by using option <1>, "Auto config";
I think that the manual is a bit nonsense, because its shows a picture of promise's BIOS menu exactly as mine, with option 3 as "View configuration"; I know that this may sound strange, but I tried everything until now and I can't see a way to make my array bootable. I followed all manual recomendations (selected SCSI as first boot device, set boot order to SCSI/ATA-RAID, set RAID jumper, etc...) and searched Internet, without success;

Any help appreciated, thanks!
April 1, 2003 1:47:55 AM

Maybe you should clarify what you meant by can't make the array bootable.
Did you mean you have installed Windows on the array but it won't boot? Have you installed the RAID driver during Windows installation?
April 1, 2003 2:44:27 PM

I mean that I cannot make the array bootable, ie, I want to be able to install Windows and Linux on it. Until now I wasn't able to install even Windows, because it complains that "there 's no hard drive installed", although I loaded promise's drivers in the beginning of the install. If I boot from another device (another HD), the array works fine, just like any other HD, my only problem is making it bootable.
Related resources
April 2, 2003 2:58:34 AM

What Windows version are you trying to install? Assuming it's WinXP. So have you prepared a floppy that contains the RAID driver beforehand? Did you boot off the WinXP installation CD and then press F6 key when prompted at the beginning to install the driver from floppy?
April 2, 2003 4:55:32 AM

Well it might seem like a stupid suggestion, but I've done RAID disk arrays on UNIX (It's been a while) but I think (I'm not saying windows is the same) you have to have the array on the first bootable device. So when you boot up in windows (What does your BIOS say your first bootable drive is? Is it the one with the array on it? If it's not, you might want to go into the BIOS and switch the first bootable device to the one you got the array drivers on and stuff. Well of course you got more than one device. If you have the array installed on the first bootable device, I'm not sure what's wrong.

Brassmonk
April 2, 2003 11:28:57 AM

Quote:
Until now I wasn't able to install even Windows, because it complains that "there 's no hard drive installed", although I loaded promise's drivers in the beginning of the install.

This is your problem right here. The fact that the drive is bootable or not wouldn't have any effect on this error message. Something is going wrong during the "press F6 to load third party drivers" install phase. Does it work successfully, i.e. does it offer you like 4 choices, and do you select the 1st one? Then does it later ask you to insert the diskette with the software?

<i>It's always the one thing you never suspected.</i>
April 2, 2003 2:34:19 PM

Yes, I'm trying to install Win XP and I inserted a floppy with my controller drivers, but Win XP complains that "there's no hard drive installed". I read that this is because my array is not marked as bootable, and my problem is just that I can't make it bootable, because my controller BIOS has no "define array menu". This is really stupid, but there isn't an option to make my array bootable, although my manual states that I have no select "define array" and mark it as bootable (other BIOS settings are Ok);
I'm beginning to suspect that this is some kind of bug with my controller, as I found no mention to such a problem in Internet, and Soyo didn't answer my question.

Thanks for your reply.
April 3, 2003 2:11:36 AM

The error message means WinXP can't recognize your RAID array so Windows won't start the installation on the array.

Like jlanka said, after you've pressed F6, did it offer you like 4 choices of RAID version to select? Did it ask you to insert the floppy that contains the driver?

I think the problem is with your floppy. Did you copy the driver file and other required files to the correct directory on the floppy?

BTW, to make a RAID array bootable, just set the boot order in main BIOS to have SCSI/ATA-RAID as the first boot device. That's all you need to do and nothing else.

However, to be in the safe side, I suggest you first set the boot order to something like "CD-ROM -> Floppy ->...". Then boot off the WinXP CD. Press F6 when you see the prompt and install the driver from floppy. After WinXP has performed the partition/format and copied all the files to your array, it will ask you to reboot. Now you should change the boot order to "SCSI/RAID -> ..." and let Windows complete the rest of the installation.
April 4, 2003 2:52:24 PM

Problem solved! I downgraded my BIOS version to the one that came with my board (promise BIOS went back to version 1.30) and when I recreated my array and rebooted my array was automatically marked as bootable (the 'define array' menu is still not appearing); So I used the drivers that came with my CD and all went Ok, Windows recognized it without problems! So, the newer BIOSes seem not to work, its a shame.
Thanks for all replies.
April 4, 2003 5:20:19 PM

Glad to hear that you got it solved.
April 4, 2003 6:07:38 PM

You see... the Dragon + is an amazing board! ;) 



To err is human... to really screw things up you need a computer!
!