A7N8X Deluxe BIOS Update not recognizing as ASUS M

Greetings!

I am trying to update my ASUS A7N8X Deluxe to the new BIOS that is out. When I try using ASUSUpdate I get an error and it tells me that no ASUS MB is recognized or found. I then tried updating it by the ALT + F2 during boot up method. When I get to the screen that asks me to enter the BIOS file name I can't enter any info (like the keyboard is unplugged). I tried reinstalling the ASUSUpdate from the CD that came with the MB but it to tells me there is no ASUS MB so it won't install!

I am running WinXP Home with an Athlon 1.4 Tbird, Gainward GeForce 3 w/ 64mb, 512mb of DDR RAM. I am currently using the AN8D1002 BIOS and have successfully updated the BIOS before using the ASUSUpdate and the ALT + F2 methods with no problems.

What happened? Any suggestions on how this can be fixed????

Thanks
4 answers Last reply
More about a7n8x deluxe bios update recognizing asus
  1. I would use the Award flash utility that's marked as specific to the A7N8X from Asus's site...

    <A HREF="http://www.asus.com/support/download/selectftp.aspx?l1_id=1&l2_id=10&l3_id=23&m_id=1&f_name=awdflash.zip~zaqwedc" target="_new">http://www.asus.com/support/download/selectftp.aspx?l1_id=1&l2_id=10&l3_id=23&m_id=1&f_name=awdflash.zip~zaqwedc</A>

    Second...is there a particular reason you "have" to flash the BIOS?

    If you look at the reasons for the update...you may not actually "need" this update...

    And like the old saying says...if it ain't broke...don't fix it.

    Continuously flashing your BIOS to the "latest and greatest" isn't always a good thing...

    If you don't need to fix a problem...leave it alone...

    That's just IMHO though...

    Aliu
  2. OK,

    You may be right about not needing to upgrade to every new BIOS. But.... There still is something causing the ASUSUpdate to tell me that I do not have a ASUS MB as my MB! I am more concerned with that than anything else! Could this be a sign of other problems to come? Maybe another BIOS comes out in 6 months to fix a problem that I am having. Then I would need to upgrade!
  3. To be quite honest...I've never used an onboard bios flash utility...I've only ever used a boot from disk method...so I wouldn't know about the onboard use...

    Like I said...the link I posted is to the BIOS flash utility that Asus says is A7N8X DELUXE specific...also...if you look some of those BIOS versions are PCB specific...which means if you don't have that particular PCB...you don't need to flash it..

    Now..I don't know if all A7N8X Deluxe models are PCB 1.03,1.04 or PCB 1.06 (with all other PCB revisions being A7N8X standard)..I'm just going by what I can see..

    But it would seem to me..there are A7N8X Deluxe models that are 1.01,1.02,1.03, and 1.05 as well as the others mentioned...

    BTW, not to be sarcastic (seriously I'm not trying to be) PCB stands for Printed Circuit Board..and the number is the revision that PCB print is on..

    Now you should be able to tell what PCB version you have by looking at the MB itself..and there should be a 1.xx somewhere on it..if it's not one of the ones listed...that BIOS isn't necessary..and may be why your getting this error...

    The only other thing I can think...is you have a bad BIOS chip..but that's probably not it..

    Good luck..hope this helps...

    Aliu
  4. I think you are trying to flash to the latest BIOS for mobo rev 2.0. Have you try flashing BIOS before using the rev 1.x BIOS. If you also failed that then you should ask for technical support from ASUS because failure of BIOS updating may results in unrecoverable damage. Make sure you check yourmobo rev no. first.

    You never know how stupid you are until you have done something stupid enough for you to realize it.
    <A HREF="http://www.anandtech.com/mysystemrig.html?id=22996" target="_new">My System Rig</A>
Ask a new question

Read More

Motherboards Asus BIOS