Sign in with
Sign up | Sign in
Your question
Solved

Call of duty world at war surround problem

Last response: in Video Games
Share
February 25, 2009 2:11:41 PM

when i get to the sound settings i cant change the audio setup to surround, it says:

To change speaker config you need to change the
default playback device in your windows sound settings, and restart the
game.

i checked this, my sound card is default
its a **** viaEnvy24 sound card i got for bout 10 euros :p 

and btw i have XP sp3
February 26, 2009 11:00:36 AM

CoD WaW automatically uses whatever speaker settings the computer is set to use (through the control panel).

Make sure your default speaker setup within windows is set to 5.1 (or 7.1, or whatever your using), and thats what the game will automatically output too. If the sound setting in game says your running stereo, thats likely what windows is set to use.
February 26, 2009 1:39:45 PM

There is actually a problem with the latest patch that they released for WaW, i believe its 1.2

Anyways, when you install that there is absolutely no sound, so you have to go in and change your output settings to the lowest possible configuration =(
Related resources
February 26, 2009 8:03:01 PM

checked everything, windows default is set to 5.1, in the sound card control panel is set to 5.1, and the surround is fine actually, played movies, even played other games with it, latest Dead Space, everything is fine

even tried to force 5.1 in the config file of W@W, it goes back to stereo sound.

guess im gon have to wait for the 1.3 patch

thanx for ur input guys, much appreciated :) 
peace

Best solution

February 27, 2009 2:59:38 AM
Share

rexx said:
checked everything, windows default is set to 5.1, in the sound card control panel is set to 5.1, and the surround is fine actually, played movies, even played other games with it, latest Dead Space, everything is fine

even tried to force 5.1 in the config file of W@W, it goes back to stereo sound.

guess im gon have to wait for the 1.3 patch

thanx for ur input guys, much appreciated :) 
peace

You don't have to wait to get sound working on COD:5, you just have to lower your sound settings.

Right click on the little speaker icon, and go to playback devices (this is if you have vista, I'm pretty sure XP doesn't have this problem).

Right click the speakers you are using, and go to properties.

Click the advanced tab.

Then, you have to select the 16bit, 44100 Hz (CD quality) setting. That should make sound work until 1.3 comes out (sometime this month i believe.

It's annoying >.< but better than having no sound at all.
February 27, 2009 10:22:46 AM

^^ no the sound is working, i just dont like it in stereo :)  i didnt buy the surround for nothin now have i :) 

same problem with f.e.a.r. 2 sound is in stereo, just noticed today :/  maybe its the soundcard i dunno....
February 27, 2009 3:00:12 PM

Do you have a config utility that came with the card?

I have a totally different set up, but unless I send a test tone to one of the rear speakers before launching the game, I only get stereo in game.

Once I've sent a test tone, I get surround sound....
February 27, 2009 8:41:00 PM

^^everything is double checked and set to surround
its just in the game the option to set output type is greyd out and is set to stereo, cant change that
Anonymous
June 7, 2009 8:38:28 PM

rexx said:
^^everything is double checked and set to surround
its just in the game the option to set output type is greyd out and is set to stereo, cant change that



I have the same problem. All is set correctly in Vista, and I get surround sound in other apps.
June 13, 2009 12:42:57 AM

Hi,I have a somewhat different problem.
The sound works great but if i die the sound dissapears.
I don't know what to do,I searched for fixes but they don't work.
I have XP with SP3 and have the 1.4 patch for my CoD:World at War
Thank you for your time.
August 14, 2009 3:04:54 AM

Hi, I had this problem too. Running Vista Ultimate x64, with X-Fi Fatal1ty PCI-E. I had my speakers set to quadraphonic, since that is what I actually have. Works fine for every other app, except CoD:WaW.

Searched for a way to get it to work in Alchemy, no go.
Found this forum.
Lowered KHz, no go.
Tried forcing the sound in the console, no go.

While playing around in the CoD console, however, I noticed there were two settings: snd_force71 and snd_force51, but there was no snd_force41. Light bulb goes on.

I go to back to the control panel and set the speakers for 5.1 sound. Have not tried this before, so I was expecting to be disappointed since I don't actually have a 5.1 setup. No separate subwoofer or center channel speaker in my possession. However, you can tell Windows which speakers you actually have, and it will compensate by downmixing. So I clear the subwoofer and center channel speakers. Quadraphonic 5.1, or 5.1 minus 1.1? Whatever. Either way, it should be exactly the same as running in quadraphonic, like I was before.

But... CoD:WaW now works with proper surround. Seems a bit silly to have 5.1 channels downmixed to four and have it work rather than just output four channels, but whatever. Silly programmers.
August 17, 2009 11:00:46 PM

I've tried all suggestions and no 5.1 sound.
October 14, 2009 3:18:45 PM

tjernagel said:
I've tried all suggestions and no 5.1 sound.


Same here...and I've done EVERYthing EVERY forum has told me to do. I'm at my wit's end! Were you ever able to get your sound working??
November 21, 2009 1:21:15 PM

Syndil said:
Hi, I had this problem too. Running Vista Ultimate x64, with X-Fi Fatal1ty PCI-E. I had my speakers set to quadraphonic, since that is what I actually have. Works fine for every other app, except CoD:WaW.

Searched for a way to get it to work in Alchemy, no go.
Found this forum.
Lowered KHz, no go.
Tried forcing the sound in the console, no go.

While playing around in the CoD console, however, I noticed there were two settings: snd_force71 and snd_force51, but there was no snd_force41. Light bulb goes on.

I go to back to the control panel and set the speakers for 5.1 sound. Have not tried this before, so I was expecting to be disappointed since I don't actually have a 5.1 setup. No separate subwoofer or center channel speaker in my possession. However, you can tell Windows which speakers you actually have, and it will compensate by downmixing. So I clear the subwoofer and center channel speakers. Quadraphonic 5.1, or 5.1 minus 1.1? Whatever. Either way, it should be exactly the same as running in quadraphonic, like I was before.

But... CoD:WaW now works with proper surround. Seems a bit silly to have 5.1 channels downmixed to four and have it work rather than just output four channels, but whatever. Silly programmers.


Hi, I have tried using this console command, but it informs me that the command is write protected. I know this because I used Shift + ¬ to open the full console, and when I type "snd_force51 "1", it tells me it is write protected. Did you find a way to get past this, or better still remove the write protection.
I am the same as everyone else here, have tried editing the config.cfg files and messing about with my audio drivers, only to find it is still determined my PC only has 2 speakers, when infact it has 6 :/ 
Thanks
!