Sign in with
Sign up | Sign in
Your question

Does morphix/knoppix read nt/xp?

Last response: in Linux/Free BSD
Share
July 24, 2004 3:50:32 AM

I found out about knoppix from an article on Tom's that said Knoppix could read and would soon be able to write to an NT partition. I couldn't get Knoppix to download so I tried STD and Morphix. Morphix works great on the XP computers we have at work but when I try to read the HD I get an error about permissions or something. Someone suggested loging in as Root or SU but that did not seem to help.

Any ideas?

Give me fuel, give me fire, give me that which I desire.

More about : morphix knoppix read

July 25, 2004 8:42:40 PM

If going as superuser didn't work then there are possibly a few things:

1. The drive isn't mounted (ready to read).
2. No ntfs support in that kernel.

It's probably just number 1 and that's easy to fix. At a command prompt type:

dmesg |less

and scroll through the output until it gets to the info about the hard drives. Find what device your windows drive is. It should be something like /dev/hda1 or the like. Then go into your /mnt directory as root and type this:

mkdir xp

This will make a folder called xp in your /mnt directory. To manually mount the drive type:

mount -t ntfs /dev/hda1 /mnt/xp

and you will then be able to cd to your xp drive and read the files. To cut some of this out you can edit your /etc/fstab file to include most of this information.

The other possibility is that there isn't any ntfs read support in your kernel. To see if you have this or not, type:

lsmod

at a command line and see if ntfs is in the list. If not, it's fixable but this is a slightly more involved process. For starters do the following as root:

cd /usr/src/linux
make menuconfig

Then search through the menus until you find the filesystems part of the tree. I think the ntfs support is under pseudofilesystems, although it may be under something else. SELECT IT TO BE COMPILED AS A MODULE by highlighting the selection and hitting <M>. Then exit the menuconfig program and type:

make modules_install
modprobe ntfs
lsmod

You should see the ntfs module loaded in the lsmod list command. To autoload it at boot (if it doesn't already), edit your /etc/modules.autoload.d/kernel-2.6 file and just add in ntfs.

s signature has been formatted to fit your scr
July 25, 2004 10:13:00 PM

Thanks, that was exactly the info I was looking for.

Since my original post I found the original flavor of Knoppix 3.4 from a fast site (florida). Last time I tried the download speeds were so slow that the download would take like 100 hours. Got it from florida in about an hour.

Anyway Knoppix is reading XP/NT while Morphix is not. I'll use your suggestions to find out why when I go back to work Tuesday.

Give me fuel, give me fire, give me that which I desire.
!