Sign in with
Sign up | Sign in
Your question
Closed

Empire Total War has stopped Working

Last response: in Video Games
Share
March 6, 2009 6:27:11 AM

I just got Empire Total War and Installed it and played the game for 5 hours then it just shuts down and says it has stopped working. Now it happens more and more often. I had the same problem with World in Conflict but now that works fine. What is going on?

System

Core 2 Quad Q9550 2.83 Ghz
6 GB Ram
9800 GT
March 6, 2009 7:10:20 AM

card is always at 45 and its very cool in the case
Related resources
March 6, 2009 7:14:38 PM

the total war series of games, although brilliant, can often be notoriously difficult to install, run and then kept running. I personally own 3 of the games and can currently only get 1 to run on my pc. mtw1 doesn't like my modern graphics card and mtw2 gold installed after a few problems and played a few times but then refused to recognise the dvd's. So that just leaves me with rome, which installed ok and seems to play well enough. The game series also seem highly susceptible to any processes and programs that may be running in the background, so it is probably best to run minimal system processes when playing any of these games (that may also help to diagnose what the problem might be). You have my sympathies.

ps. my problems were encountered on a pc with xp (a proven and reliable operating system), so if you are using vista that may complicate matters even more.
March 7, 2009 10:37:02 AM

david_uk109 says
ps. my problems were encountered on a pc with xp (a proven and reliable operating system), so if you are using vista that may complicate matters even more.
--------------------------------------------------------------------------------------------------------------------------------------------------------
I would have to agree.
There seems to be some truth in this, I myself had no problems with ROME TOTAL WAR with XP but when I got vista now and again the game would say it as stoppped working and I would have to run the game again.
March 7, 2009 9:07:26 PM

I have figured out why Empire stopped working on my pc. it's because of steam. for some reason when steam was online it would close my games. So i just went offline and it works. sorry david i don't know how that could be the solution to rome as i don't think it uses steam. it's the same problem i have with my other online strategy games like COH or WIC. Weird.
March 9, 2009 8:21:21 AM

I been getting loads of issues with steam lately related to flashplayer, updated flash and steam stopped misbehaving as much. i.e games just stopping etc.
March 13, 2009 12:02:48 AM

I have a brand new Dell M1530 laptop which runs on Vista. I have plenty of ram and the best graphic card and everything else Dell had to offer 2 months ago. I played Total War for about 13 hours total. Now I am on Move 69 and the game just stops working. Says it has encountered a problem and shuts down. I have tried everything I can think of and nothing works. I changed the settings to low and put steam on offline mode and it still happens. Even downloaded the game and and the update and still the same problem. Really getting annoyed...... Any suggestions would be greatly appreciated.
March 14, 2009 2:53:28 PM

It has gotten to the point that everyone of my saves are corrupt at this point. I can not even start a new Grand Campaign. As soon as I select it the game shuts down and that is the end. I hope they come out with a patch to fix this in the near future. From what I have found everyone is having he same problem. No wonder I tend to stick with console gaming!!! this is ridiculous
March 14, 2009 4:55:00 PM

I have not got this game but there seems to be something related to when the steam will do its first update in your game that stops it from working again, 90% of people are having this problem who purchased this game and they all say it is steam related, some are trying to run steam as a admin to try and cure this problem, others are deleating steam alltogether, theres one report that he as not had any problems if he isnt saving the game after each move < but this seems pointless to me.
March 16, 2009 4:43:27 PM

ericeagle92 said:
I have figured out why Empire stopped working on my pc. it's because of steam. for some reason when steam was online it would close my games. So i just went offline and it works. sorry david i don't know how that could be the solution to rome as i don't think it uses steam. it's the same problem i have with my other online strategy games like COH or WIC. Weird.



I had been looking forward to the Empire total war for ages.... Got it on release date, and my computer couldn't handle it. I've been intending to upgrade anyhow so I ordered a new Dell with a great graphics card and decent speed and all. The game still doesn't work correctly. I can do battles, but not the main campaign, which is what I really want. I get the error message- Empire Total War has stopped working, a problem caused the program to stop working correctly..etc. Any suggestions? Also, I have tried to contact support, No luck there, is there any way to get an actual response out of them???? Anyone??
March 17, 2009 12:17:55 AM

Angelique8478 said:
I had been looking forward to the Empire total war for ages.... Got it on release date, and my computer couldn't handle it. I've been intending to upgrade anyhow so I ordered a new Dell with a great graphics card and decent speed and all. The game still doesn't work correctly. I can do battles, but not the main campaign, which is what I really want. I get the error message- Empire Total War has stopped working, a problem caused the program to stop working correctly..etc. Any suggestions? Also, I have tried to contact support, No luck there, is there any way to get an actual response out of them???? Anyone??


Well other than trying to play offline, I heard people complain that there game shuts down either because there PSU sucks (unlikely in ur case) or their PC gets to hot. u should try and download realtemp to see what the temps are and make sure their not to high.

http://www.techpowerup.com/downloads/1325/Real_Temp_3.0...

My friend had a problem with heat and now that he moved his computer somewhere better it gets air and works fine. Hope this helped!
March 17, 2009 1:03:47 PM

Eric how do you play offline? I go offline and it wont start because it needs steam to launch
March 17, 2009 1:15:49 PM

And I have the CD BTW

Also I didnt even play it for 5 hours, I got the same problem you did on the first time i tried to open the game. I have the specs, but I try to open it, screen goes white, there is a "17th century cursor" and it says Empire has stopped working
March 24, 2009 5:48:39 AM

tangon08 said:
It has gotten to the point that everyone of my saves are corrupt at this point. I can not even start a new Grand Campaign. As soon as I select it the game shuts down and that is the end. I hope they come out with a patch to fix this in the near future. From what I have found everyone is having he same problem. No wonder I tend to stick with console gaming!!! this is ridiculous


i found out why that part of the game isnt working....try loading a new game from the tutorials....then go to the menu during the game and change the game play settings to 1 hr battle times...then exit and try to load grand campaign...it should work...i just tried it and no problems...i think u change the length of battles once u start the grand campaign...let me kno if it works for u...
March 24, 2009 3:04:22 PM

Hey, I was wondering I have a computer now of course and I run the demo *If everything is not on low it laggs like hell lol*

Since Iam not at home I am not 100% sure of my PC, but I do know this and I know it only barly meets the mini.-

1GB Of ram *oh god i know*
Nivdia 7300 EL
2.79 GHz

Thats about so far all I know, I know it has to be my ram card and my video card, but I want to buy a new PC, anyone have an idea because what I do is I compare this game to a computer that can handle it, I would like medium - high+ if possible for a nice price.

:bounce: 

Also if I buy a new computer and it can handle this game it can handle anything :p 

***Keep playing the demo on very low, looks crappy but love the game!***

Anyone have an idea of a price on a good computer, thanks for reading this sorry if I am in the wrong section I just saw this and read was glad.
March 24, 2009 3:10:03 PM

assuming you had the basics (monitor keys mouse speakers hdd os) then you are talking about £450 or whatever the mickey mouse money equivalent is for something to run Empire Total War reasonably well. Thats based on an AMD 720 platform with 4gb of ram and a 48xx series card, with a basic case and PSU like Anteq 300 and low range Corsair.

Honestly its easier for you to give us a budget to work with.
March 24, 2009 6:06:20 PM

pr2thej said:
assuming you had the basics (monitor keys mouse speakers hdd os) then you are talking about £450 or whatever the mickey mouse money equivalent is for something to run Empire Total War reasonably well. Thats based on an AMD 720 platform with 4gb of ram and a 48xx series card, with a basic case and PSU like Anteq 300 and low range Corsair.

Honestly its easier for you to give us a budget to work with.


I resent that. Its monopoly money.
March 24, 2009 7:24:19 PM

I have a nice computer. I could play Empire Total War. I was *SO* looking forward to playing it, in fact. But I found out that it requires steam, and I will never, ever again have anything to do with steam. It is not surprising to hear that it just screws things up.

When you support internet copywright protection schemes like steam, and horrible DRMs found in the likes of Bioshock, etc with your money, you are just hassling yourself and supporting the death of PC gaming anyway.
March 24, 2009 8:50:21 PM

Well the budget hmm, Iam not 100% sure, Iam just slowly saving money *Dont have a job, in school only 15 XD* lol

I know my parents wont pay for it, so I was thinking of saving my money slowly, would take a long time but, really this computer I want to buy or a new one, is not just for Empire, its also something I want for myself like "ya thats my PC" lol since this computer is my older brother and meh....

Instead if upgrading his RAM card and video card I told myself *Just save your money* I spend a lot on online games like item mail anyways..

So hmm, price range not sure
March 24, 2009 10:14:12 PM

snyderm said:
I have a nice computer. I could play Empire Total War. I was *SO* looking forward to playing it, in fact. But I found out that it requires steam, and I will never, ever again have anything to do with steam. It is not surprising to hear that it just screws things up.

When you support internet copywright protection schemes like steam, and horrible DRMs found in the likes of Bioshock, etc with your money, you are just hassling yourself and supporting the death of PC gaming anyway.



Sorry...whats wrong with Steam again?
Ease of use? Instant gaming? Damn good prices? Excellent selection? Auto updates? Modding Community? Easy online play?


Yea stick it to the Man....man!!
March 24, 2009 10:54:54 PM

pr2thej, so have any good PCs in your mind?
March 25, 2009 2:32:18 AM

hmm my yahoo email says some one replayed but I do not see anyone lol nor a 2nd page, so this is a test reply XD
March 25, 2009 8:57:27 AM

ummmm thats a really tricky one mate. Clearly you wont be able to invest in what i posted above if you are still at school.
Realistically you will need to spend a good £100 minimum to get a decent experience...Thats dependant on your motherboard not needing an upgrade though which it may well do to get a sane amount of RAM in there.

Whats your motherboard and PSU mate? (PSU for a GPU suggestion)
March 25, 2009 2:32:19 PM

Thats something I will have to check and get back to you!
When you said (E100) there was a funny lookin E next to it I am taking it means 1000, and yea I was thinking of getting a summer job over the summer, and ill let you know about that motherbroad soon ^^
March 25, 2009 2:37:11 PM

Now I know PSU means Power Supply Information, where would I find this information at about my PC? *still a noob*

BTW, I was doing some reasearch, and found that a Nivdia 9800 TL or LE or whatever lol, seems like a nice video card :) 

*editing was not working lol sorry for so many damn post..*
March 25, 2009 2:37:26 PM

Now I know PSU means Power Supply Information, where would I find this information at about my PC? *still a noob*

BTW, I was doing some reasearch, and found that a Nivdia 9800 TL or LE or whatever lol, seems like a nice video card :) 

*editing was not working lol sorry for so many damn post..*
March 25, 2009 3:31:09 PM

Well save hijacking this thread further i would suggest you make a new one, as its quite a bit of help you need i think.
£ funny looking E? Thats the good old british pound matey!!
March 25, 2009 9:03:53 PM

lol XD and I will, sorry guys
Anonymous
March 30, 2009 5:38:22 PM

kronick said:
i found out why that part of the game isnt working....try loading a new game from the tutorials....then go to the menu during the game and change the game play settings to 1 hr battle times...then exit and try to load grand campaign...it should work...i just tried it and no problems...i think u change the length of battles once u start the grand campaign...let me kno if it works for u...





omg i love you!
I tried this and it actually worked! I had battle time limit on 2hrs and changed it to 1 hr and it worked. When on the "start new campaign" menu it doesn't give you the option of making battles 2hrs long, only 1 hr, think that has something to do with it.
April 14, 2009 10:15:35 PM

happy85 said:
And I have the CD BTW

Also I didnt even play it for 5 hours, I got the same problem you did on the first time i tried to open the game. I have the specs, but I try to open it, screen goes white, there is a "17th century cursor" and it says Empire has stopped working



Same here.

I found this on Y!A and it might help you with offline gaming. I don't know, since I have not tried it myself.

http://answers.yahoo.com/question/index;_ylt=AlJPnlGJ4ar65yhCyjdfRcEjzKIX;_ylv=3?qid=20090307112733AA90Ctb
April 18, 2009 10:59:31 AM

happy85 said:
And I have the CD BTW

Also I didnt even play it for 5 hours, I got the same problem you did on the first time i tried to open the game. I have the specs, but I try to open it, screen goes white, there is a "17th century cursor" and it says Empire has stopped working


I have the same problem. When i installed ETW in the very first time, everything was ok. After installation i have run the game about 3 times for setting up the graphic options, then i exit. After it i wanted to start the game again, but windows said "Empire has stopped working". After a while it even wasn't saying any error, and just didn't started. I reinstalled it, but still same problem. Then i uninstalled, and instaled again, but stil f*** problem! I dont have any idea how to fix this damn problem... Please help me!
April 18, 2009 11:07:09 PM

PROBLEM SOLVED!

Maybe it would help you all.

1) Uninstall ETW (NOT reinstall)
2) Uninstall Steam
3) Restart your PC
4) Insert DVD1 and click "Install ETW" (Steam will be automatically installed after this)
5) Wait until the installation is complete
6) After installation, run the game from steam

I'm so happy it's working now... :)  Hope it will in your PC too.
April 18, 2009 11:19:51 PM

I *used* to have this problem lastest patch fixed it through I persome its bad coding on my PC it slows down alot sometimes and I need to restart the PC for it to come back alive again
Anonymous
June 8, 2009 3:43:21 PM

snyderm said:
I have a nice computer. I could play Empire Total War. I was *SO* looking forward to playing it, in fact. But I found out that it requires steam, and I will never, ever again have anything to do with steam. It is not surprising to hear that it just screws things up.

When you support internet copywright protection schemes like steam, and horrible DRMs found in the likes of Bioshock, etc with your money, you are just hassling yourself and supporting the death of PC gaming anyway.



Yeah or encouraging piracy of the game, because you don't have to deal with all the ridiculous errors and compatibility problems that are linked to the antipiracy software. There's an irony for you, lol.
July 6, 2009 2:21:09 AM

kronick said:
i found out why that part of the game isnt working....try loading a new game from the tutorials....then go to the menu during the game and change the game play settings to 1 hr battle times...then exit and try to load grand campaign...it should work...i just tried it and no problems...i think u change the length of battles once u start the grand campaign...let me kno if it works for u...



It worked for me! I've been having this problem for the longest time. I started a campaign but could not start another until I tried this. Changed the battle time limit to 1 hour and now I can start other campaigns. Somehow the word needs to get to the gamemaker to fix this bug. I don't know how to contact them but i'm sure many other customers are having the same problem and it must be driving them crazy trying to figure it out.
July 18, 2009 7:55:01 PM

well since all the new patches that just came out you shouldnt have to worry about it anymore. I can set the time limit to whatever i want know with no problems. i suggest everyone who hasnt tried this to do so, it should work for all who have the game.
July 18, 2009 11:26:05 PM

happy85 said:
And I have the CD BTW

Also I didnt even play it for 5 hours, I got the same problem you did on the first time i tried to open the game. I have the specs, but I try to open it, screen goes white, there is a "17th century cursor" and it says Empire has stopped working



Thats exactly what happened to me have you figured out how to fix it yet
June 24, 2010 11:44:34 PM

This topic has been closed by Mousemonkey
!