Win7 Can't awake from Sleep with usb Keyboard/Mouse

I have a laptop that is now running Win7 32 Home Premium(I upgraded from Win xp). I am using an external keyboard and mouse, as I am using it as a HTPC hooked up to a TV and want the laptop display closed and laptop tucked away. I have all the power options in Win7 set to put it to sleep, but there is no option I can find to have it wake up from sleep other than the power button on the laptop which is not accessible if lid is closed.

Some have said you need to go to the mouse/keyboard driver itself(HID Device) in device manager, and there should be a power management tab on the driver/device options, but my usb options do not have this tab. I also went to the Bios to configure power options and there are not options to configure power states(such as S3 S5 etc). I can get the laptop to go to sleep with the sleep button on a usb keyboard, but once it is asleep, it will not wake up from any command from the mouse/keyboard. I believe its because the USB ports are not being powered while in sleep mode, so it will not see a wake command - As I said before my USB port options do not have any power management settings. I also plugged in an MCE remote which has a sleep button, and same thing- it puts it to sleep, but will not wake it up. My goal is to just use an MCE remote for all commands -as I am running Windows Media Center.

Any thoughts on the problem, or is there another utility I can run to simulate sleep and allow me to wake up the Laptop via external keyboards or remotes.

Thanks,
11 answers Last reply
More about win7 awake sleep keyboard mouse
  1. In control Panel /Device manager/Universal serial port controllers,There is a list of USB ROOT HUB. If you right click /Properties on each of these you will see a tab saying Power Management. From there you can check the box to allow the device to wake up the computer from sleep
  2. The power management tab is there under USB Root Hub, but unfortunately, the wake computer from sleep option is dimmed and can't be selected. I checked my other 2 Win7 systems(where wake from sleep works) and they are all dimmed as well under USB Root Hub so I don't think this is the right option. under HID-Compliant Mouse there should be a power management tab(Its there on my other systems) but there isn't on this system and the driver is an old 2006 Microsoft driver that can't be updated(says its the latest one. There has to be a registry setting which is causing this.
  3. So I needed the opposite -- I have a laptop, where I want the laptop to sleep when I close the lid. Unfortunately, the mouse is external, so it continues to move even when the lid closes.

    Here's the option you need in Win 7

    Start -> Control Panel
    Click Mouse
    Select Hardware tab
    Click Properties
    Click Change Settings
    Select Power Management tab

    Select or Unselect "Allow this device to wake the computer"

    Should be all set!

    ~~ Mark


    http://www.marksatterfield.com
  4. Guitar1969 said:
    The power management tab is there under USB Root Hub, but unfortunately, the wake computer from sleep option is dimmed and can't be selected. I checked my other 2 Win7 systems(where wake from sleep works) and they are all dimmed as well under USB Root Hub so I don't think this is the right option. under HID-Compliant Mouse there should be a power management tab(Its there on my other systems) but there isn't on this system and the driver is an old 2006 Microsoft driver that can't be updated(says its the latest one. There has to be a registry setting which is causing this.


    Did you ever find a solution to this? I'm having the same problem...both solutions here not working...
  5. whitejames said:
    Did you ever find a solution to this? I'm having the same problem...both solutions here not working...



    What were the results when you used this process?


    Start -> Control Panel
    Click Mouse
    Select Hardware tab
    Click Properties
    Click Change Settings
    Select Power Management tab

    Select "Allow this device to wake the computer"


    http://www.marksatterfield.com
  6. it was grayed out, not clickable
  7. I had same issue. But there was another HID mouse and keyboard device that I had to enable "allow this device to wake this computer". Enabling this on my Logitech HID-compliant device on the list didn't do it. It worked even with my computer allowing the USB Root Hubs to power off, so I'm not sure that is necessary in all cases.
  8. Guitar1969 said:
    The power management tab is there under USB Root Hub, but unfortunately, the wake computer from sleep option is dimmed and can't be selected. I checked my other 2 Win7 systems(where wake from sleep works) and they are all dimmed as well under USB Root Hub so I don't think this is the right option. under HID-Compliant Mouse there should be a power management tab(Its there on my other systems) but there isn't on this system and the driver is an old 2006 Microsoft driver that can't be updated(says its the latest one. There has to be a registry setting which is causing this.



    Look under your keyboard and mouse in disk management for the "allow to wake", not under usb root hub.
  9. Thanks for the replies all. For my case, I thought for sure I enabled wake with USB in BIOS but when I double checked it was NOT enabled. SO after enabling, these wake boxes/options were no longer grayed out and I can now wake with the external keyboard. -Thanks
  10. whitejames said:
    Thanks for the replies all. For my case, I thought for sure I enabled wake with USB in BIOS but when I double checked it was NOT enabled. SO after enabling, these wake boxes/options were no longer grayed out and I can now wake with the external keyboard. -Thanks


    Nice. Maybe you can post your computer type/brand and where the item is in your BIOS to help other people out?

    Thanks!

    http://www.marksatterfield.com
  11. I was having this same problem. Didn't see the option for the remote I was using. So I went to "device manager" / "Universal serial bus contollers". And pulled up the properties on the generic usb hub and usb root hubs. Under the Power managment tab I unchecked the "allow the computer to turn off this device to save power" for all hubs shown. And that kept the computer from cutting power to my remote when it went to sleep. Then I noticed that my remote also showed up under the Universal serial bus contollers section. When I checked there the power managment tab was there. Note I needed to have "allow the computer to turn off this device to save power" checked for the remote in order for it to ungrey the "allow this device to wake the computer" and allow me to check it. And now it works like a charm. Laptop hidden behind tv. One press of the sleep button on my remote and everything goes down for a nap. One more press and everything is back like I left it. And since I'm using the VGA out from my laptop my tv auto turns off and on so I can now do what I need with one remote.
Ask a new question

Read More

Configuration Laptops Mice Power Keyboards Windows 7