Sign in with
Sign up | Sign in
Your question

Problem Relocating Documents folder to second hard drive in Windows 7

Tags:
  • Configuration
  • Windows 7
Last response: in Windows 7
Share
August 26, 2010 11:11:06 PM

Could someone please help me out with this strange problem?

Ok, I had changed the location of the Documents folder, along with Videos, Pictures, and Music by following the instructions below for each:


From Windows Explorer on the left side from within Libraries, I double clicked on Documents which is located under c:\Users\<username>. I right-clicked on the folder and selected Properties.

I switched to the Location tab and clicked the Move button below the default path.

I browsed to the new location (D:\My Documents), click on it, pressed Select Folder, and then hit OK.

To confirm the change, I clicked Yes to move documents to the new location.

I then confirmed the new locations of each folder by right clicking each and selecting Properties. Everything checked out fine.


Here's where the problem comes in. I first checked to see how much space I had in each drive (C: (my Primary) and D: (my Secondary)). Next, I created a text file and wrote a bunch of characters in it and saved it in the new location on the D: drive. For some reason it only takes memory/space from the C: drive. So I restarted my computer for the heck of it and tried the same thing, but it happened again.

I don't know if this helps, but both my Sata WD hard drives show up as Primary drives. I didn't have an option to change this from within my bios on my Gigabyte motherboard. I read that I wouldn't need a jumper if I was using Sata, so I really don't know.


I searched the web for two days straight and couldn't find any information on it other than what I tried above.

I'd greatly appreciate any help I could get!

More about : problem relocating documents folder hard drive windows

a b $ Windows 7
August 27, 2010 1:06:09 AM

Look up "Customize a library" in Windows help.
Quote W7 Help,
"To change a library's default save location
A library's default save location determines where an item will be stored when it's copied, moved, or saved to the library.

Open the library you'd like to change.

In the library pane (above the file list), next to Includes, click Locations.

In the Library Locations dialog box, right-click a library location that's not currently the default save location, click Set as default save location, and then click OK."
end quote.

It would appear that you have included D: in the location rather then make it the default save location. So try again following the Help instructions in W7.
m
0
l
August 27, 2010 3:41:14 AM

Jonmor68 said:
Look up "Customize a library" in Windows help.
Quote W7 Help,
"To change a library's default save location
A library's default save location determines where an item will be stored when it's copied, moved, or saved to the library.

Open the library you'd like to change.

In the library pane (above the file list), next to Includes, click Locations.

In the Library Locations dialog box, right-click a library location that's not currently the default save location, click Set as default save location, and then click OK."
end quote.

It would appear that you have included D: in the location rather then make it the default save location. So try again following the Help instructions in W7.




I wish it was that easy, but I'm afraid that wasn't it. I even tried to save a new folder with a couple files in it to my secondary hd, then I would add it (not move it) to the library, yet, the same thing happens, and yes, the D: drive was still the default location. Once someting is added to the library, even though it shows that it is physically in my D: drive, it will still only take up space on my C: drive. Not sure what that's all about. Thank you for your input though.
m
0
l
Related resources
a b $ Windows 7
August 27, 2010 5:16:51 AM

"even though it shows that it is physically in my D: drive, it will still only take up space on my C: drive"
That does not make any sense. How are you ariving at this conclusion?
If it's saving it to d: and it's visable on d: then that's where it is.
The sata drives are all master.
m
0
l
August 27, 2010 6:08:15 PM

Jonmor68 said:
"even though it shows that it is physically in my D: drive, it will still only take up space on my C: drive"
That does not make any sense. How are you ariving at this conclusion?
If it's saving it to d: and it's visable on d: then that's where it is.
The sata drives are all master.



I opened My Computer, then checked the properties of Drive C: & D: and wrote down the present bytes being used on each.

Then I would create a file and save it in the Documents folder, which is definitely in the D: drive (I confirmed this by opening up the Libraries folder, clicked on Documents under Libraries on the left of the screen, then in the library pane (above the file list), next to Includes, I clicked Locations. There it had shown Documents as being in the D: drive and set as the default save location.).

Now I would go back to My Computer and check the properties of Drive C: & D: again to find the bytes being used on each, but the C: drive is the only one which has bytes being used.

I just tried something different, and now I'm really confused! I just saved a document directly into my 2nd hard drive without adding anything to the Libraries folder, and wouldn't you know it, it's still taking the memory from my C: drive even though it shows that it clearly saved it to the D: drive.
m
0
l
August 27, 2010 11:36:27 PM

Problem resolved. I reformatted the 2nd hard drive and tried everything again and it worked perfectly!

Thank you for all your help Jonmor68, it was greatly appreciated!
m
0
l
a b $ Windows 7
August 28, 2010 1:11:58 AM

Thanks for posting back and letting us know it's solved.
m
0
l
April 15, 2011 9:18:27 PM

I have this same problem. My main drive is a 64gb SSD and i recently did the same and moved the location of all the documents folders and they moved location fine but they still report to take up space on the C drive. I can confirm that it is as mentioned above but if you look at the properties of my user folder it says its 20gb if i go into that folder and select all (with hidden files shown) then it says less than 500mb. the problem is that although the data has gone windows 7 is still saying that i have 20gb sat on my C drive that simply isnt there. I figured maybe there was a pointer somewhere and it was counting the 20gb thats now sat on the other drive but still thats useless to me because even though its moved the data windows wont free up the C drive space for other stuff.

Any ideas. My other drive is a 3tb partition split accross 5 physical drives that also hold 2 other partitions. So a reformat just isnt an option for me without a massive headache.
m
0
l
!