Sign in with
Sign up | Sign in
Your question

TF2: plays Valve Logo, then it crashes to desktop, wtf?

Tags:
  • PC gaming
  • Desktops
  • Valve
  • Google
  • Video Games
Last response: in Video Games
Share
March 31, 2009 9:41:03 AM

Sigh.. even the almighty Google hasn't answered my prayers...

Just what exactly is wrong?


Other Valve Source games launch just fine, but noooooo... not TF2... COME ON! it's the same freakin' engine, what's going on here?

Ok, it goes like this

I click on it in Steam, it launches, plays Valve Logo, then it crashes to desktop with no traces... no error code, no nothing... GRRRR....


I feel like i'm gonna anally explode out of my rectum in ANGER if i cannot find a solution! Damn you Google for being useless!

For your info, i'm using Vista 64, Geforce drivers 181.22

More about : tf2 plays valve logo crashes desktop wtf

March 31, 2009 11:49:03 AM

try verifying the local cache IIRC something like this: open up steam->games. right click on TF2->properties->local files-> verify game cache. might take a while just let it run.

have you tweaked any of the graphics settings? restore to defaults.

updated Directx? check to see if there are any updates for vista.
March 31, 2009 7:35:43 PM

did cache run, it was fine, vista was updated already, why Directx10? oh, is there a launch command for Directx9?
Related resources
April 1, 2009 7:53:49 AM

As I don't run Vista I dont't know much about the Dx9/Dx10 in vista. IIRC Tf2 is a DirectX9 game.

check out these urls :
Valve TF2 forum

Have you look at the event logs? Start->control panel->Admin tools->event viewer. or whatever the equivalent is in vista? post any error messages relating to "HL2.exe" or anything that specifically mentions TF2.
April 1, 2009 8:12:41 AM

here is some more information I found:
Quote:
Boot up steam, go to your games, right click TF2 > Properties > Set Launch Options

No video - add the following line: -novid

Now, another cool little tweak you can use it -heapsize basically it uses the amount of ram you tell it too use. When using this tewak, it's recommended to use half your ram rather then all.
The easiest way to get a rough estimate on how much ram you have.. would be going into the start menu, right clicking "My Computer" and going to Properties.
If you can't find it there, then I suggest downloading cpuZ and run that. Once it's done, click the "Memory" tab. It's also a nice way to find out what else you have in your system. Another way, is opening your run tool and typing in dxdiag.exe

Once you've found out how much ram you have in your system, multiply that number by 1024 and then divide that by 2.

So, if you have 1024mb of ram, you're heapsize should be: 524288.
I have 3072mb of ram. my heapsize is: 1572864, in the image it's less because I used 2048mb.

Fyi, heapsize is also addable in the AutoExec.cfg.
mem_max_heapsize 512 For a half a gig.
- Warning! Chief_runningwater was having problems with this. You may as well.
Now, directX levels. These can be put into either your about config, or directly into the area we just added our heapsize.

There are a few different settings here.

-dxlevel 96-99 = Directx 9.0 (Maxed Quality)
-dxlevel 95 = Directx 9.0 (Higher Quality)
-dxlevel 90 = Directx 9.0
-dxlevel 81 = Directx 8.1 (Medium Quality)
-dxlevel 80 = Directx 8.0 (S'medium Quality)
-dxlevel 70 = Directx 7.0 (Lower Quality)


Here are some random tricks for the advanced menu.

By adding -noborder you remove the borders from the window if you're playing in windowed mode.
If you have a Nvidia Graphics card, by putting in -gl is forces Open GL mode. For ATI card, put -d3d

If you know your monitors refresh rate, you can set your games maximum refresh rate to match your monitor by adding a simple command line -refresh # My monitors refresh rate would be 60. So, I input -refresh 60

By adding -console to the command line, you can help increase your start-up time. Rather then the background being the main focus of loading, your console is. Which, is no doubt simpler.
-novid also helps speed up your load time.

-32bit enables 32bit mode. This is mainly for 64bit users.
Posted By: M_oo_P
Vista Ultimate 64 bit (3.40 Duel core 4 gs ram 8800) with the -32bit start code on Css, Video stress tested, improved about 20 FPS very good.
-width [resolution width] this sets a custom resolution width. -height [resolution width] this sets your resolution height. So, for example.. my desktop resolution is 1680x1050. So, I input -width 1680 -height 1050, this sets a custom resolution.

-windowed enables window mode. Works well with -noboder and -width/-height explained above.

"My" autoexec.cfg has these settings within it's mighty lines.

cl_forcepreload 1 //Forces Textures to load before hand.
cl_updaterate 67 //Keeps your rates up to date!
cl_cmdrate 67 //Helps keep rates steady.
mat_picmip -10 // Explained Above
mat_dxlevel 98 //Enables dx10 support or at least improved quality and sometimes frame rate..
mat_specular 1 //Enables specular lighting


Hope this helps
April 1, 2009 10:49:57 AM

are u sure that's all the possible fixes? 32-bit solution might work... but why "heapsize" to begin with?
April 1, 2009 10:57:01 AM

holy sweet jesus! it finally works!

the -dxlevel 95 trick did it for me! It's not like the Source engine games was built with DX10 anyway.
April 1, 2009 11:02:04 AM

Don't know about heapsize as this informartion I snagged from fpsbanana! I run TF2 as is, no tweaks. It's worth seeing if you can update the directx9 on your PC to the latest version. It's not something that's done as part of Microsoft Update (probably worthwhile creating a system restore point before messing about with directx).

DX9 - March 2009.
April 1, 2009 2:59:06 PM

nah, i'm fine with my -directx95 fix, thanks though.

At least all my Steam games work now, they used to have issues, like black screens, etc., that were fixed by the -windowed command...

Thank god for Tom's Hardware!
!