LAN for 2 computers, XP Pro and XP Home

Archived from groups: microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.newusers (More info?)

Two computers, network thru router, one with xp pro the other with xp home.

I can set sharing for a folder on each machine for Everyone (pro) and I
guess everyone (home) since I have no choice but share all or nothing with
everyone on the network.

Both computers are in a same name workgroup. Each have one user account
(admin).

From the home machine I can connect to the pro machine but I can not do the
opposite for some strange reason.

What is the trick to connect from pro to home xp machines? I have no problem
connecting the same two pieces of hardware if my pro machine is booted with
w2k partition.

Thanks.

ColBlip.
E-mail: colonel.blip@nospampleasebigfoot.com
7 answers Last reply
More about computers home
  1. Archived from groups: microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.newusers (More info?)

    On Mon, 14 Mar 2005 16:04:54 -0600, "ColBlip"
    <colonel.blip@nospampleasebigfoot.com> wrote:

    >Two computers, network thru router, one with xp pro the other with xp home.
    >
    >I can set sharing for a folder on each machine for Everyone (pro) and I
    >guess everyone (home) since I have no choice but share all or nothing with
    >everyone on the network.
    >
    >Both computers are in a same name workgroup. Each have one user account
    >(admin).
    >
    >From the home machine I can connect to the pro machine but I can not do the
    >opposite for some strange reason.
    >
    >What is the trick to connect from pro to home xp machines? I have no problem
    >connecting the same two pieces of hardware if my pro machine is booted with
    >w2k partition.
    >
    >Thanks.
    >
    >ColBlip.
    >E-mail: colonel.blip@nospampleasebigfoot.com

    On any XP Pro computer, check to see if Simple File Sharing (Control Panel -
    Folder Options - View - Advanced settings) is enabled or disabled. With XP Pro,
    you need to have SFS enabled.

    On XP Home, and on XP Pro with Simple File Sharing enabled, make sure that the
    Guest account is enabled, on each computer. Enable Guest, with Start - Run -
    "cmd", then type "net user guest /active:yes" in the command window. Ensure
    that the password for Guest is blank, with Start - Run - "control
    userpasswords2"; select Guest, click Reset Password, click OK without entering a
    new password.

    On XP Pro, if you're going to use Guest authentication, check your Local
    Security Policy (Control Panel - Administrative Tools) - User Rights Assignment,
    on the XP Pro computer, and look at "Deny access to this computer from the
    network". Make sure Guest is not in the list. Look at "Access this computer
    from the network", and make sure that Everyone is in this list.

    Do any of the computers have a software firewall (ICF / WF, or third party)? If
    so, you need to configure them for file sharing. Firewall configurations are a
    very common cause of (network) browser, and file sharing, problems.

    --
    Cheers,
    Chuck
    Paranoia comes from experience - and is not necessarily a bad thing.
    My email is AT DOT
    actual address pchuck sonic net.
  2. Archived from groups: microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.newusers (More info?)

    Hello, Chuck!
    You wrote on 14 Mar 2005 16:43:06 -0600:

    C> On Mon, 14 Mar 2005 16:04:54 -0600, "ColBlip"
    C> <colonel.blip@nospampleasebigfoot.com> wrote:

    ??>> Two computers, network thru router, one with xp pro the other with xp
    ??>> home.
    ??>>
    ??>> I can set sharing for a folder on each machine for Everyone (pro) and
    ??>> I guess everyone (home) since I have no choice but share all or
    ??>> nothing with everyone on the network.
    ??>>
    ??>> Both computers are in a same name workgroup. Each have one user
    ??>> account (admin).
    ??>>
    ??>> From the home machine I can connect to the pro machine but I can not
    ??>> do the opposite for some strange reason.
    ??>>
    ??>> What is the trick to connect from pro to home xp machines? I have no
    ??>> problem connecting the same two pieces of hardware if my pro machine
    ??>> is booted with w2k partition.
    ??>>
    ??>> Thanks.
    ??>>
    ??>> ColBlip.
    ??>> E-mail: colonel.blip@nospampleasebigfoot.com

    C> On any XP Pro computer, check to see if Simple File Sharing (Control
    C> Panel - Folder Options - View - Advanced settings) is enabled or
    C> disabled. With XP Pro, you need to have SFS enabled.

    C> On XP Home, and on XP Pro with Simple File Sharing enabled, make sure
    C> that the Guest account is enabled, on each computer. Enable Guest, with
    C> Start - Run - "cmd", then type "net user guest /active:yes" in the
    C> command window. Ensure that the password for Guest is blank, with Start
    C> - Run - "control userpasswords2"; select Guest, click Reset Password,
    C> click OK without entering a new password.

    C> On XP Pro, if you're going to use Guest authentication, check your Local
    C> Security Policy (Control Panel - Administrative Tools) - User Rights
    C> Assignment, on the XP Pro computer, and look at "Deny access to this
    C> computer from the network". Make sure Guest is not in the list. Look
    C> at "Access this computer from the network", and make sure that Everyone
    C> is in this list.

    C> Do any of the computers have a software firewall (ICF / WF, or third
    C> party)? If so, you need to configure them for file sharing. Firewall
    C> configurations are a very common cause of (network) browser, and file
    C> sharing, problems.

    Ok, did all of this and still have no problem with xp home seeing xp pro,
    but pro can not see xp home. Keep getting error message - network path
    \\name\share can not be found. I've checked name and share name and that is
    not the problem. My xp pro ip is trusted but I even s/d the firewall just to
    make sure.

    Thanks.

    ColBlip.
    E-mail: colonel.blip@nospampleasebigfoot.com
  3. Archived from groups: microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.newusers (More info?)

    On Mon, 14 Mar 2005 17:30:21 -0600, "ColBlip"
    <colonel.blip@nospampleasebigfoot.com> wrote:

    >Hello, Chuck!
    >You wrote on 14 Mar 2005 16:43:06 -0600:
    >
    > C> On Mon, 14 Mar 2005 16:04:54 -0600, "ColBlip"
    > C> <colonel.blip@nospampleasebigfoot.com> wrote:
    >
    > ??>> Two computers, network thru router, one with xp pro the other with xp
    > ??>> home.
    > ??>>
    > ??>> I can set sharing for a folder on each machine for Everyone (pro) and
    > ??>> I guess everyone (home) since I have no choice but share all or
    > ??>> nothing with everyone on the network.
    > ??>>
    > ??>> Both computers are in a same name workgroup. Each have one user
    > ??>> account (admin).
    > ??>>
    > ??>> From the home machine I can connect to the pro machine but I can not
    > ??>> do the opposite for some strange reason.
    > ??>>
    > ??>> What is the trick to connect from pro to home xp machines? I have no
    > ??>> problem connecting the same two pieces of hardware if my pro machine
    > ??>> is booted with w2k partition.
    > ??>>
    > ??>> Thanks.
    > ??>>
    > ??>> ColBlip.
    > ??>> E-mail: colonel.blip@nospampleasebigfoot.com
    >
    > C> On any XP Pro computer, check to see if Simple File Sharing (Control
    > C> Panel - Folder Options - View - Advanced settings) is enabled or
    > C> disabled. With XP Pro, you need to have SFS enabled.
    >
    > C> On XP Home, and on XP Pro with Simple File Sharing enabled, make sure
    > C> that the Guest account is enabled, on each computer. Enable Guest, with
    > C> Start - Run - "cmd", then type "net user guest /active:yes" in the
    > C> command window. Ensure that the password for Guest is blank, with Start
    > C> - Run - "control userpasswords2"; select Guest, click Reset Password,
    > C> click OK without entering a new password.
    >
    > C> On XP Pro, if you're going to use Guest authentication, check your Local
    > C> Security Policy (Control Panel - Administrative Tools) - User Rights
    > C> Assignment, on the XP Pro computer, and look at "Deny access to this
    > C> computer from the network". Make sure Guest is not in the list. Look
    > C> at "Access this computer from the network", and make sure that Everyone
    > C> is in this list.
    >
    > C> Do any of the computers have a software firewall (ICF / WF, or third
    > C> party)? If so, you need to configure them for file sharing. Firewall
    > C> configurations are a very common cause of (network) browser, and file
    > C> sharing, problems.
    >
    >Ok, did all of this and still have no problem with xp home seeing xp pro,
    >but pro can not see xp home. Keep getting error message - network path
    >\\name\share can not be found. I've checked name and share name and that is
    >not the problem. My xp pro ip is trusted but I even s/d the firewall just to
    >make sure.

    OK, if it's "can't see one computer from the other" then that's something else.

    Check for a browser conflict between the two computers. I"m not talking about
    Internet Explorer here. The browser is the program that allows any computer to
    see any other computer on the LAN. With a 2 computer LAN, only 1 computer
    should run the browser.

    Make sure the browser service is running on only 1 of the WinXP computers.
    Control Panel - Administrative Tools - Services. Verify that the Computer
    Browser, and the TCP/IP NetBIOS Helper, services both show with Status =
    Started. Disable the browser service (only the browser service) on the other.

    After checking / disabling / enabling as above, power all computers off to reset
    the browser settings on each. Once ALL computers have been powered off, power
    them back on.

    The Microsoft Browstat program will show us what browsers (I'm not talking about
    Internet Explorer here) you have in your domain / workgroup, at any time.
    http://support.microsoft.com/?id=188305

    You can download Browstat from either:
    <http://www.dynawell.com/reskit/microsoft/win2000/browstat.zip>
    <http://rescomp.stanford.edu/staff/manual/rcc/tools/browstat.zip>

    Browstat is very small (40K), and needs no install. Just unzip the downloaded
    file, copy browstat.exe to any folder in the Path, and run it from a command
    window, by "browstat status". Make sure all computers list the same master
    browser.
    For more information about the browser subsystem (very intricate), see:
    http://support.microsoft.com/?id=188001
    http://support.microsoft.com/?id=188305
    http://support.microsoft.com/?id=231312
    <http://www.microsoft.com/technet/prodtechnol/winntas/deploy/prodspecs/ntbrowse.mspx>
    <http://www.microsoft.com/technet/archive/win95/w95brows.mspx>

    The browser requires anonymous access, so look at registry key
    [HKLM\System\CurrentControlSet\Control\Lsa], value restrictanonymous, on both
    computers.
    <http://www.microsoft.com/windows2000/techinfo/reskit/en-us/default.asp?url=/windows2000/techinfo/reskit/en-us/regentry/46688.asp>
    <http://www.jsifaq.com/subf/tip2600/rh2625.htm>
    http://support.microsoft.com/?id=246261
    http://support.microsoft.com/?id=296403

    The above articles refer to Windows 2000. Remember WinXP is NT V5.1, and Win2K
    is NT V5.0.

    Have you used the Registry Editor before? If not, it's a scary tool, but it's
    pretty simple once you get used to it. Here are a couple articles that might
    help:
    <http://www.microsoft.com/windowsxp/home/using/productdoc/en/default.asp?url=/windowsxp/home/using/productdoc/en/tools_regeditors.asp>
    <http://www.annoyances.org/exec/show/registry>

    Just remember to backup the key (create a registry patch) for
    [HKLM\System\CurrentControlSet\Control\Lsa] before making any changes, if
    appropriate.

    From the Annoyances article:
    You can create a Registry patch by opening the Registry Editor, selecting a
    branch, and choosing Export from the File menu. Then, specify a filename, and
    press OK. You can then view the Registry patch file by opening it in Notepad
    (right-click on it and select Edit). Again, just double-click on a Registry
    patch file (or use Import in the Registry Editor's File menu) to apply it to the
    registry.

    --
    Cheers,
    Chuck
    Paranoia comes from experience - and is not necessarily a bad thing.
    My email is AT DOT
    actual address pchuck sonic net.
  4. Archived from groups: microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.newusers (More info?)

    Hello, ColBlip!
    You wrote to Chuck on Mon, 14 Mar 2005 17:30:21 -0600:

    C> Hello, Chuck!
    C> You wrote on 14 Mar 2005 16:43:06 -0600:

    C>> On Mon, 14 Mar 2005 16:04:54 -0600, "ColBlip"
    C>> <colonel.blip@nospampleasebigfoot.com> wrote:

    ??>>> Two computers, network thru router, one with xp pro the other with xp
    ??>>> home.
    ??>>>
    ??>>> I can set sharing for a folder on each machine for Everyone (pro) and
    ??>>> I guess everyone (home) since I have no choice but share all or
    ??>>> nothing with everyone on the network.
    ??>>>
    ??>>> Both computers are in a same name workgroup. Each have one user
    ??>>> account (admin).
    ??>>>
    ??>>> From the home machine I can connect to the pro machine but I can not
    ??>>> do the opposite for some strange reason.
    ??>>>
    ??>>> What is the trick to connect from pro to home xp machines? I have no
    ??>>> problem connecting the same two pieces of hardware if my pro machine
    ??>>> is booted with w2k partition.
    ??>>>
    ??>>> Thanks.
    ??>>>
    ??>>> ColBlip.
    ??>>> E-mail: colonel.blip@nospampleasebigfoot.com

    C>> On any XP Pro computer, check to see if Simple File Sharing (Control
    C>> Panel - Folder Options - View - Advanced settings) is enabled or
    C>> disabled. With XP Pro, you need to have SFS enabled.

    C>> On XP Home, and on XP Pro with Simple File Sharing enabled, make sure
    C>> that the Guest account is enabled, on each computer. Enable Guest,
    C>> with Start - Run - "cmd", then type "net user guest /active:yes" in the
    C>> command window. Ensure that the password for Guest is blank, with
    C>> Start - Run - "control userpasswords2"; select Guest, click Reset
    C>> Password, click OK without entering a new password.

    C>> On XP Pro, if you're going to use Guest authentication, check your
    C>> Local Security Policy (Control Panel - Administrative Tools) - User
    C>> Rights Assignment, on the XP Pro computer, and look at "Deny access to
    C>> this computer from the network". Make sure Guest is not in the list.
    C>> Look at "Access this computer from the network", and make sure that
    C>> Everyone is in this list.

    C>> Do any of the computers have a software firewall (ICF / WF, or third
    C>> party)? If so, you need to configure them for file sharing. Firewall
    C>> configurations are a very common cause of (network) browser, and file
    C>> sharing, problems.

    C> Ok, did all of this and still have no problem with xp home seeing xp
    C> pro, but pro can not see xp home. Keep getting error message - network
    C> path \\name\share can not be found. I've checked name and share name and
    C> that is not the problem. My xp pro ip is trusted but I even s/d the
    C> firewall just to make sure.

    C> Thanks.

    C> ColBlip.
    C> E-mail: colonel.blip@nospampleasebigfoot.com

    Finally got it to work. Not sure of all of the reasons. Didn't have to make
    any changes to xp pro SFS (unchecked) nor turn Guest on. I did have to get
    xp home FW to trust my IP and I did have to turn on guest for the home. But
    in the final analysis, only way I ever got connection was to also change
    computer name (don't see why I needed to) and/or reboot.

    Thanks.

    ColBlip.
    E-mail: colonel.blip@nospampleasebigfoot.com
  5. Archived from groups: microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.newusers (More info?)

    On Mon, 14 Mar 2005 18:45:10 -0600, "ColBlip"
    <colonel.blip@nospampleasebigfoot.com> wrote:

    >Hello, ColBlip!
    >You wrote to Chuck on Mon, 14 Mar 2005 17:30:21 -0600:
    >
    > C> Hello, Chuck!
    > C> You wrote on 14 Mar 2005 16:43:06 -0600:
    >
    > C>> On Mon, 14 Mar 2005 16:04:54 -0600, "ColBlip"
    > C>> <colonel.blip@nospampleasebigfoot.com> wrote:
    >
    > ??>>> Two computers, network thru router, one with xp pro the other with xp
    > ??>>> home.
    > ??>>>
    > ??>>> I can set sharing for a folder on each machine for Everyone (pro) and
    > ??>>> I guess everyone (home) since I have no choice but share all or
    > ??>>> nothing with everyone on the network.
    > ??>>>
    > ??>>> Both computers are in a same name workgroup. Each have one user
    > ??>>> account (admin).
    > ??>>>
    > ??>>> From the home machine I can connect to the pro machine but I can not
    > ??>>> do the opposite for some strange reason.
    > ??>>>
    > ??>>> What is the trick to connect from pro to home xp machines? I have no
    > ??>>> problem connecting the same two pieces of hardware if my pro machine
    > ??>>> is booted with w2k partition.
    > ??>>>
    > ??>>> Thanks.
    > ??>>>
    > ??>>> ColBlip.
    > ??>>> E-mail: colonel.blip@nospampleasebigfoot.com
    >
    > C>> On any XP Pro computer, check to see if Simple File Sharing (Control
    > C>> Panel - Folder Options - View - Advanced settings) is enabled or
    > C>> disabled. With XP Pro, you need to have SFS enabled.
    >
    > C>> On XP Home, and on XP Pro with Simple File Sharing enabled, make sure
    > C>> that the Guest account is enabled, on each computer. Enable Guest,
    > C>> with Start - Run - "cmd", then type "net user guest /active:yes" in the
    > C>> command window. Ensure that the password for Guest is blank, with
    > C>> Start - Run - "control userpasswords2"; select Guest, click Reset
    > C>> Password, click OK without entering a new password.
    >
    > C>> On XP Pro, if you're going to use Guest authentication, check your
    > C>> Local Security Policy (Control Panel - Administrative Tools) - User
    > C>> Rights Assignment, on the XP Pro computer, and look at "Deny access to
    > C>> this computer from the network". Make sure Guest is not in the list.
    > C>> Look at "Access this computer from the network", and make sure that
    > C>> Everyone is in this list.
    >
    > C>> Do any of the computers have a software firewall (ICF / WF, or third
    > C>> party)? If so, you need to configure them for file sharing. Firewall
    > C>> configurations are a very common cause of (network) browser, and file
    > C>> sharing, problems.
    >
    > C> Ok, did all of this and still have no problem with xp home seeing xp
    > C> pro, but pro can not see xp home. Keep getting error message - network
    > C> path \\name\share can not be found. I've checked name and share name and
    > C> that is not the problem. My xp pro ip is trusted but I even s/d the
    > C> firewall just to make sure.
    >
    > C> Thanks.
    >
    > C> ColBlip.
    > C> E-mail: colonel.blip@nospampleasebigfoot.com
    >
    >Finally got it to work. Not sure of all of the reasons. Didn't have to make
    >any changes to xp pro SFS (unchecked) nor turn Guest on. I did have to get
    >xp home FW to trust my IP and I did have to turn on guest for the home. But
    >in the final analysis, only way I ever got connection was to also change
    >computer name (don't see why I needed to) and/or reboot.

    Huh. Well, if you ever figure out any details, we'd appreciate hearing from
    you.

    --
    Cheers,
    Chuck
    Paranoia comes from experience - and is not necessarily a bad thing.
    My email is AT DOT
    actual address pchuck sonic net.
  6. Archived from groups: microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.newusers (More info?)

    Hello, Chuck!
    You wrote on 14 Mar 2005 18:57:04 -0600:

    C> On Mon, 14 Mar 2005 18:45:10 -0600, "ColBlip"
    C> <colonel.blip@nospampleasebigfoot.com> wrote:

    C> Huh. Well, if you ever figure out any details, we'd appreciate hearing
    C> from you.

    I wish I knew exactly what the problem was. One thing that seems to confuse
    things is that changes would not have an impact until I rebooted (CAD, not
    log off/on). This seems a bit squirrelly to me.

    While I am on the subject, what I would like to be able to do on my home
    machine is make access user specific. My wife is using the xp home so her
    computer is "Wife". I would like my share to only accept her and no one
    else, and require a p/w. All I can find under permissions are accounts for
    my xp pro machine, "Me". Surely there is a way to do this. Since we are
    hooked ot inet (thru NAT router as well as s/w firewall so relatively safe,
    I like belts and suspenders and even ropes.

    Thanks.

    Colonel Blip.
    E-mail: colonel.blip@removethespambigfoot.com
  7. Archived from groups: microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.newusers (More info?)

    On Mon, 14 Mar 2005 20:23:59 -0600, "Colonel Blip"
    <colonel.blip@removethespambigfoot.com> wrote:

    >Hello, Chuck!
    >You wrote on 14 Mar 2005 18:57:04 -0600:
    >
    > C> On Mon, 14 Mar 2005 18:45:10 -0600, "ColBlip"
    > C> <colonel.blip@nospampleasebigfoot.com> wrote:
    >
    > C> Huh. Well, if you ever figure out any details, we'd appreciate hearing
    > C> from you.
    >
    >I wish I knew exactly what the problem was. One thing that seems to confuse
    >things is that changes would not have an impact until I rebooted (CAD, not
    >log off/on). This seems a bit squirrelly to me.
    >
    >While I am on the subject, what I would like to be able to do on my home
    >machine is make access user specific. My wife is using the xp home so her
    >computer is "Wife". I would like my share to only accept her and no one
    >else, and require a p/w. All I can find under permissions are accounts for
    >my xp pro machine, "Me". Surely there is a way to do this. Since we are
    >hooked ot inet (thru NAT router as well as s/w firewall so relatively safe,
    >I like belts and suspenders and even ropes.

    On your XP Pro computer, check to see if Simple File Sharing (Control Panel -
    Folder Options - View - Advanced settings) is enabled or disabled. With XP Pro,
    you need to have SFS disabled, to require her account for access.

    On XP Pro with SFS disabled, check the Local Security Policies (Control Panel -
    Administrative Tools). Under Local Policies - Security Options, look at
    "Network access: Sharing and security model", and ensure it's set to "Classic -
    local users authenticate as themselves".

    On XP Pro with SFS disabled, setup and use a common non-Guest account on both
    computers, with an identical, non-blank password on both computers.

    Are you intending to access her computer from yours? If so, you can't disable
    the Guest account on yours - you have to have it enabled on both computers, with
    identical (or nil) password. :(

    Her computer, if XP Home, will remain open to everybody, if to anybody. :((

    --
    Cheers,
    Chuck
    Paranoia comes from experience - and is not necessarily a bad thing.
    My email is AT DOT
    actual address pchuck sonic net.
Ask a new question

Read More

Computers Microsoft Windows XP