Connect 2 PCs

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

Hi

I am trying to link 2 PCs (no domain) via Ethernet cable so I assigned fixed
IP address to both of them as follows:

Computer 1
IP Address 10.0.0.1
Subnet Mask: 255.255.255.0
Default gateway: 10.0.0.1

Prffered DNS Server:10.0.0.1

Computer 2
IP Address 10.0.0.2
Subnet Mask: 255.255.255.0
Default gateway: 10.0.0.2

Prffered DNS Server:10.0.0.2

But I still can't view shared folder in any of them

Can that be related to the Workgroup?

Any suggestions?

Shmuel Shulman
6 answers Last reply
More about connect
  1. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    u need a crossover cat5 cable


    S Shulman wrote:
    > Hi
    >
    > I am trying to link 2 PCs (no domain) via Ethernet cable so I assigned fixed
    > IP address to both of them as follows:
    >
    > Computer 1
    > IP Address 10.0.0.1
    > Subnet Mask: 255.255.255.0
    > Default gateway: 10.0.0.1
    >
    > Prffered DNS Server:10.0.0.1
    >
    > Computer 2
    > IP Address 10.0.0.2
    > Subnet Mask: 255.255.255.0
    > Default gateway: 10.0.0.2
    >
    > Prffered DNS Server:10.0.0.2
    >
    > But I still can't view shared folder in any of them
    >
    > Can that be related to the Workgroup?
    >
    > Any suggestions?
    >
    > Shmuel Shulman
    >
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    "S Shulman" <smshulman@hotmail.com> wrote in message
    news:e7fsWAaKFHA.1812@TK2MSFTNGP15.phx.gbl...
    > Hi
    >
    > I am trying to link 2 PCs (no domain) via Ethernet cable so I assigned
    > fixed IP address to both of them as follows:
    >
    > Computer 1
    > IP Address 10.0.0.1
    > Subnet Mask: 255.255.255.0
    > Default gateway: 10.0.0.1
    >
    > Prffered DNS Server:10.0.0.1
    >
    > Computer 2
    > IP Address 10.0.0.2
    > Subnet Mask: 255.255.255.0
    > Default gateway: 10.0.0.2
    >
    > Prffered DNS Server:10.0.0.2
    >
    > But I still can't view shared folder in any of them
    >
    > Can that be related to the Workgroup?
    >
    > Any suggestions?
    >
    > Shmuel Shulman
    >
    >
    >


    So did you connect the 2 computers to hub, switch, or router? Or did
    you connect them directly together (i.e., from NIC port of one computer
    to the NIC port of other), in which case you need a special cable called
    a cross-over cable? If you connect them using a cross-over cable and
    using all NIC ports, just how are you connecting them to the Internet,
    if at all?

    You obviously are NOT running a DNS server to resolve IP names to IP
    addresses regardless of your DNS settings. That means you cannot use IP
    names to find your hosts. You need to find your hosts by their
    workgroup names. Do you have the "Client for Microsoft Networks"
    installed on your LAN connectoid? Is the "Computer Browser" NT service
    running? If you do have them connected to a router, does the router
    permit connections between intranetwork hosts?

    --
    ____________________________________________________________
    Post your replies to the newsgroup. Share with others.
    E-mail reply: Remove "NIXTHIS" and add "#VS811" to Subject.
    ____________________________________________________________
  3. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    Google | Straight through cable | Cross over cable

    CAT5 is rated to 100M
    CAT5e is rated to 350M
    CAT6 and CAT6e is rated to 550M or 1000M depending on your source
    CAT7 is supposedly rated to 700M or presumably 1000M

    The following websites to be helpful in explaining the differences and the
    benefits.

    http://www.broadbandutopia.com/caandcaco.html
    http://www.lanshack.com/cat5e-tutorial.asp
    http://www.theheadwaters.com/cables/faq.htm#1

    You will find much more info at:
    http://mvp.support.microsoft.com/
    =======================================
    Regards, Gary 'Doc' Adams in Louisiana @ 314.479.8201

    LsuEdu@msn.comREMOVE
    http://computerteachers.digital-mall-online.com/
    ~ Read to Learn - Write to Think ~
    =======================================

    "S Shulman" <smshulman@hotmail.com> wrote in message
    news:e7fsWAaKFHA.1812@TK2MSFTNGP15.phx.gbl...
    > Hi
    >
    > I am trying to link 2 PCs (no domain) via Ethernet cable so I assigned
    fixed
    > IP address to both of them as follows:
    >
    > Computer 1
    > IP Address 10.0.0.1
    > Subnet Mask: 255.255.255.0
    > Default gateway: 10.0.0.1
    >
    > Prffered DNS Server:10.0.0.1
    >
    > Computer 2
    > IP Address 10.0.0.2
    > Subnet Mask: 255.255.255.0
    > Default gateway: 10.0.0.2
    >
    > Prffered DNS Server:10.0.0.2
    >
    > But I still can't view shared folder in any of them
    >
    > Can that be related to the Workgroup?
    >
    > Any suggestions?
    >
    > Shmuel Shulman
    >
    >
    >
  4. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    Thanks for you reply,
    I connects them using crossed Ethernet cable. I get the internet via the
    USB port (connected to a cable modem) which is a different LAN I want to
    note that when I enable the LAN between the 2 computers the internet
    connection doesn't work I also tried to bridge them but it didn't help
    I must admit that I didn't understand everything you have written but if
    there is a specific problem please restate it and will look into it.

    Thank you in advance,
    Shmuel Shulman

    "Vanguard" <use_ReplyTo_header> wrote in message
    news:%23SX9yWbKFHA.3500@TK2MSFTNGP14.phx.gbl...
    > "S Shulman" <smshulman@hotmail.com> wrote in message
    > news:e7fsWAaKFHA.1812@TK2MSFTNGP15.phx.gbl...
    >> Hi
    >>
    >> I am trying to link 2 PCs (no domain) via Ethernet cable so I assigned
    >> fixed IP address to both of them as follows:
    >>
    >> Computer 1
    >> IP Address 10.0.0.1
    >> Subnet Mask: 255.255.255.0
    >> Default gateway: 10.0.0.1
    >>
    >> Prffered DNS Server:10.0.0.1
    >>
    >> Computer 2
    >> IP Address 10.0.0.2
    >> Subnet Mask: 255.255.255.0
    >> Default gateway: 10.0.0.2
    >>
    >> Prffered DNS Server:10.0.0.2
    >>
    >> But I still can't view shared folder in any of them
    >>
    >> Can that be related to the Workgroup?
    >>
    >> Any suggestions?
    >>
    >> Shmuel Shulman
    >>
    >>
    >>
    >
    >
    > So did you connect the 2 computers to hub, switch, or router? Or did you
    > connect them directly together (i.e., from NIC port of one computer to the
    > NIC port of other), in which case you need a special cable called a
    > cross-over cable? If you connect them using a cross-over cable and using
    > all NIC ports, just how are you connecting them to the Internet, if at
    > all?
    >
    > You obviously are NOT running a DNS server to resolve IP names to IP
    > addresses regardless of your DNS settings. That means you cannot use IP
    > names to find your hosts. You need to find your hosts by their workgroup
    > names. Do you have the "Client for Microsoft Networks" installed on your
    > LAN connectoid? Is the "Computer Browser" NT service running? If you do
    > have them connected to a router, does the router permit connections
    > between intranetwork hosts?
    >
    > --
    > ____________________________________________________________
    > Post your replies to the newsgroup. Share with others.
    > E-mail reply: Remove "NIXTHIS" and add "#VS811" to Subject.
    > ____________________________________________________________
    >
  5. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    "S Shulman" <smshulman@hotmail.com> wrote in message
    news:eMZY6LjKFHA.3064@TK2MSFTNGP12.phx.gbl...
    > Thanks for you reply,
    > I connects them using crossed Ethernet cable. I get the internet via
    > the USB port (connected to a cable modem) which is a different LAN I
    > want to note that when I enable the LAN between the 2 computers the
    > internet connection doesn't work I also tried to bridge them but it
    > didn't help
    > I must admit that I didn't understand everything you have written but
    > if there is a specific problem please restate it and will look into
    > it.
    >
    > Thank you in advance,
    > Shmuel Shulman
    >
    > "Vanguard" <use_ReplyTo_header> wrote in message
    > news:%23SX9yWbKFHA.3500@TK2MSFTNGP14.phx.gbl...
    >> "S Shulman" <smshulman@hotmail.com> wrote in message
    >> news:e7fsWAaKFHA.1812@TK2MSFTNGP15.phx.gbl...
    >>> Hi
    >>>
    >>> I am trying to link 2 PCs (no domain) via Ethernet cable so I
    >>> assigned fixed IP address to both of them as follows:
    >>>
    >>> Computer 1
    >>> IP Address 10.0.0.1
    >>> Subnet Mask: 255.255.255.0
    >>> Default gateway: 10.0.0.1
    >>>
    >>> Prffered DNS Server:10.0.0.1
    >>>
    >>> Computer 2
    >>> IP Address 10.0.0.2
    >>> Subnet Mask: 255.255.255.0
    >>> Default gateway: 10.0.0.2
    >>>
    >>> Prffered DNS Server:10.0.0.2
    >>>
    >>> But I still can't view shared folder in any of them
    >>>
    >>> Can that be related to the Workgroup?
    >>>
    >>> Any suggestions?
    >>>
    >>> Shmuel Shulman
    >>>
    >>>
    >>>
    >>
    >>
    >> So did you connect the 2 computers to hub, switch, or router? Or did
    >> you connect them directly together (i.e., from NIC port of one
    >> computer to the NIC port of other), in which case you need a special
    >> cable called a cross-over cable? If you connect them using a
    >> cross-over cable and using all NIC ports, just how are you connecting
    >> them to the Internet, if at all?
    >>
    >> You obviously are NOT running a DNS server to resolve IP names to IP
    >> addresses regardless of your DNS settings. That means you cannot use
    >> IP names to find your hosts. You need to find your hosts by their
    >> workgroup names. Do you have the "Client for Microsoft Networks"
    >> installed on your LAN connectoid? Is the "Computer Browser" NT
    >> service running? If you do have them connected to a router, does the
    >> router permit connections between intranetwork hosts?
    >>
    >> --
    >> ____________________________________________________________
    >> Post your replies to the newsgroup. Share with others.
    >> E-mail reply: Remove "NIXTHIS" and add "#VS811" to Subject.
    >> ____________________________________________________________
    >>
    >
    >


    You already mentioned defining a bridge between your network
    card/controller and your USB ported network device (to the Internet).
    Defining a bridge does not necessarily give you Internet connectivity.
    A bridge is just a host with two network interfaces connecting two
    network segments. Some host running a DHCP server must assign them IP
    address unless you want to use static IP addresses (which your ISP won't
    support unless you pay them extra). Presumably one network segment is
    between your other host (bridged host) and the host running the bridge
    between the network card and the USB ported network device (bridging
    host, or bridge), and the other side of the bridge presumably connects
    to your cable/DSL modem. Okay, but how are you going to get an IP
    address assigned to the bridged host (the one that is NOT running the
    bridge driver) from your ISP to let it connect to the Internet? You
    have a private network that your ISP won't touch. Right now you are
    using static IP addresses. That is almost guaranteed to block access to
    your ISP. It's okay for connections between your own intranetwork hosts
    but your ISP won't know about those hosts because your ISP didn't assign
    them their IP addresses. You currently have a *private* network.

    Your ISP's DHCP server could assign your bridging host an IP address
    (but that's not how you have it configured) but it can't reach the
    bridged host. You only show one of your network interfaces defined on
    the bridging host and with a private IP address, too. Presumably that
    is for the NIC connected to the other host. What about the IP config
    for the network device attached to your USB bus? What is its IP config?
    From what I can tell, you have a static and private IP address defined
    for the NIC on your bridged host and you have a static and private IP
    address defined for the NIC on your bridging host (which connects back
    to your bridged host), so that is your private network that your ISP
    can't reach. You don't mention what is the IP config of your USB ported
    network device included in the bridge. Even if it were configured to
    use DHCP to get an IP address from your ISP, only that side of your
    bridging host would get that IP address. Your bridged host could
    connect to your bridging host, your bridging host can connect to your
    bridged host and to the Internet, but your bridging host can't get to
    the Internet. You need to use address translation to let other hosts
    share the single IP address that your ISP allocates to your account,
    unless you want to pay them for their "home networking" solution to
    allocate you two, or more, dynamically assigned IP addresses. Bridging
    does not provide for network address translation (NAT) as would a NAT
    router to which you connect both your hosts or by using ICS (Internet
    Connection Sharing) on the bridging host.

    Presumably your hardware setup is:

    Bridged host: NIC port goes to bridging host, static IP address.
    Bridging host: NIC post goes to bridged host, static IP address.
    Bridging host: USB port goes to network device (cable/DSL modem),
    unknown IP addressing mode.

    When you run "ipconfig /all" on each of your hosts, what does it report
    (copy and paste into your reply)?

    Rather than define a bridge between the NIC port and USB ported device,
    you need to use ICS to allow bridged hosts to share the IP address
    allocated by your ISP to the WAN-side of your bridging host. ICS acts
    as the local DHCP server to assign IP addresses to each of your
    intranetwork hosts (i.e., the LAN-side of your bridging host and to each
    of your other hosts). Your ISP allocates the single IP address to the
    USB ported device on the WAN-side of your bridging host. Then all your
    hosts get to share the single IP address from your ISP.

    For now, delete the simple bridge and use the Network Connection Wizard
    (rundll32.exe hnetwiz.dll HomeNetWizardRunDll) to load ICS and configure
    your hosts. Do the bridging host first with the 2 network interfaces
    and then do the bridged hosts. Go through "Start -> Help and Support"
    to get more info on ICS, or use
    http://www.google.com/search?q=%2B"Windows+XP"+%2BICS+%2Bsetup+%2Binstructions
    to find help articles. After installing ICS on the bridging host, the
    bridging host has to be up for any bridged hosts to use it to connect to
    the Internet (i.e., if the ICS host disconnects, they all disconnect).
    If the bridge is down, no one gets to cross. That is why it is much
    easier to use a NAT router and connect all your hosts to it. It must be
    a *NAT* router to provide its own DHCP server which assigns each of your
    intranetwork hosts their IP addresses and your ISP assigns your single
    allocated IP address to your router; i.e., the DHCP server in the NAT
    router handles all the LAN-side hosts while your ISP's DHCP server
    handles the WAN-side of your NAT router. You only need one network
    interface per host, like a NIC, so you don't bother with defining
    bridging, simple or NAT, and you can power off or reboot one host
    without affecting connectivity for the other hosts. ICS is a cheap
    (because it is included in Windows) but a nuisancesome solution. A NAT
    router is easy but costs money (and many come with a rudimentary
    firewall).

    I am presuming that your ISP allocates only one IP address to your
    account. That means you have to share it amongst all the hosts in your
    private network. You can't do that by assigning private IP addresses
    within your private network which is only is usable by your own private
    hosts. Your ISP has to know where to deliver the packets coming back
    from wherever you connect. It only has one IP address to send to. ICS
    or a NAT router will permit sharing of that single IP address across all
    your hosts. Otherwise, pay your ISP to have them allocate more IP
    addresses to your account (but you'll have to configure each host to use
    DHCP instead of static addressing). Or pay them even more to have them
    assign a static IP address to each of your hosts. ICS or a NAT router
    is far cheaper.

    --
    ____________________________________________________________
    Post your replies to the newsgroup. Share with others.
    E-mail reply: Remove "NIXTHIS" and add "#VS811" to Subject.
    ____________________________________________________________
  6. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    "S Shulman" <smshulman@hotmail.com> wrote in message
    news:eMZY6LjKFHA.3064@TK2MSFTNGP12.phx.gbl...
    > Thanks for you reply,
    > I connects them using crossed Ethernet cable. I get the internet via
    > the USB port (connected to a cable modem) which is a different LAN I
    > want to note that when I enable the LAN between the 2 computers the
    > internet connection doesn't work I also tried to bridge them but it
    > didn't help
    > I must admit that I didn't understand everything you have written but
    > if there is a specific problem please restate it and will look into
    > it.


    Getting back to why you can't view a shared folder within your private
    network, I had mentioned checking that the Computer Browser service is
    running and if you have the "Client for Microsoft Networks" protocol
    bound to your LAN connectoid.

    For the Computer Browser service, run services.msc to load the Services
    applet to make sure "Computer Browser" is set to Automatic (i.e., loads
    on Windows startup) and is currently running. To check that you have
    the "Client for Microsoft Networks" protocol bound to your LAN
    connectoid, right-click on that connectoid (your "LAN" connection in the
    Network control panel applet), and check Properties. You probably also
    need to enable File and Printer sharing. A personal software firewall
    on your hosts or other security software could be blocking the ports
    used for file sharing. If those components have been bound (i.e.,
    installed) to your LAN connectoid, try temporarily disabling your
    software firewall. If that doesn't work, check if you are running other
    security software that could interfere (many will block file & print
    sharing rather than simply tell the user how to unbind that component
    from their connectoid). The software firewall on the bridging host
    should block file & print sharing for external connections but not
    within your private network, but since you have multiple network
    interfaces on that bridging host (one for the NIC and the other for the
    USB ported device), you need to make sure the software firewall is only
    blocking file & print services on that external network interface (i.e.,
    the USB ported device).

    You also need to ensure each computer has a unique MAC (media access
    control) address assigned to it. Run "ipconfig /all" on both hosts and
    make sure the MAC (physical) addresses are different. Similary, you
    need to use a DIFFERENT hostname for each host. If both were named,
    say, "desktopPC" then how would the hosts know where to deliver their
    packets? If you use their static IP address then you could connect to
    them but most users use the hostnames. Make sure each host has a
    different hostname. That is also shown in the "ipconfig /all" output.
Ask a new question

Read More

IP Address Default Gateway DNS Server PCS Windows XP