Sign in with
Sign up | Sign in
Your question

My fs9 does not open even when i insert disc 4 Can you help

Last response: in Windows 7
Share
August 27, 2010 8:06:12 PM

my fs2004 does not open windows7 even with cd 4 inserted Can you please help

More about : fs9 open insert disc

a c 246 $ Windows 7
August 27, 2010 8:26:18 PM

Did you upgrade to Windows 7 from an earlier version? If so, uninstall the game. Run a registry cleaner, like CCleaner. Then restart. When the system is back up, reinstall the game.

If not an upgrade (was a clean install), I suggest doing the same. However, when you installed FS2004, did you get any error messages?
m
0
l
November 27, 2012 11:53:56 PM

I think there is a conflict with MS Flight Sim both 9 and X and Google Chrome web browser. I have noticed this on both Vista and Win 7 systems with 32 and 64 operating systems (tried to run on three computer systems with Chrome installed). I went step by step software installation on a clean system and ran into where the sims do no open past the open screen for 9 and X after I installed Google Chrome web browser. BTW I have Firefox and Explorer installed with no problem. Not sure if this works because I have not tried it yet, if you have Chrome installed, uninstall it. Not sure if the registry keeps some remnant around to cause problems, but I am going to try a removal soon and see what happens if it will allow FS to start again. For now I am doing a clean operating system install without installing Chrome and all is fine.
m
0
l
!