Sign in with
Sign up | Sign in
Your question
Closed

Windows 7 internet troubleshooting

Last response: in Windows 7
Share
January 24, 2009 12:55:44 PM

I just upgraded vista to beta 7, and everything went fine, except that I can't connect to the internet now. Now I can ping google and yahoo, but not microsoft.com. Sites I can ping still won't load in any browser. Rather, it says the site is found and then has the moving "working" cursor indefinitely. Never seems to time-out either. I've tried chrome, FF, and IE.

Any suggestions for troubleshooting steps? Already tried the windows suggestions.
a b $ Windows 7
January 24, 2009 8:20:51 PM

use http://72.14.205.100/ in any web browser address bar. Does that bring up the Google website?

will http://207.46.232.182/ bring up the Microsoft website in a browser?

If yes, you have a DNS (Domain Name Server) issue with your internet connection. Check and see how your Vista internet connection was configured for DNS, or check with your ISP.

If no - post the settings/properties you are using for your internet connection.
January 25, 2009 12:09:18 AM

Thanks for the response. I had tried troubleshooting the DNS issue, and pinging web addresses worked well as IPs or URLs. Neither worked in the browser.

I've since figured out that it was zonealarm causing the problem. It was turned off during upgrade and I had removed it from startup and stopped all processes... so, I'm not sure why, but everything worked after I uninstalled it completely.
Related resources
June 23, 2009 7:35:38 AM

I also have a problem with the internet connection in win 7, though this problem appear only couple of days ago. I've disabled both firewalls (Windows and Nod32), but still no internet connection. At the same time, internet works just fine in XP (I have both systems installed).
Could anyone give me a hint on this issue?
thanks.
June 23, 2009 9:42:30 AM

Try disabling all the addon in internet explorer. Might work
August 21, 2009 2:00:55 PM

Internet connection problems with Windows 7

Each time we restart our computers (7 different notebooks connecting from different locations with different LAN configurations and different ISP) they are all unable to connect to LAN and/or the internet.

We have tried several solutions suggested by MS and blogs, but the only working one is the following -kinda convoluted- one:
1) The correct LAN configuration is "Obtain an IP address automatically". But, after a restart, we must modify this provisionally, and change the LAN connection properties placing the last IP number leased by DHCP before turning off the computers.
The previous action will let you browse your local net, but you will not be able to navigate the internet.
2) You need to let the system "Obtain an IP address automatically", but it will not do so, no matter how deep you explore into Windows, after replacing the LAN tab to "Obtain an IP address automatically" ang going through all the necessary movements in CMD with ipconfig, and so on...
3) For the moment, it seems the only solution is to run iExplorer and let Windows start the diagnose of the connection problems. If you completed step one (otherwise this solution will not work), the diagnose will say what we know: 'DHCP is not enabled for "Local Area Connection"'.
4) Click on "Try this repairs as an administrator" (no matter if you are logged in as an administrator, Windows 7 will not recognize you as one) and "Apply this fix". It will fix the problem. Now close the troubleshooter and start browsing.

Note that, in our case, all the computers are quite capable to connect to internet -without major problems- using wireless. For that matter, it is a PITA to see Windows 7 connecting to a very slow and far away WiFi (we must turn off the WiFi radio of the computers to push Windows to find the LAN instead) , when it has a patch cord directly plugged to a gigabit fiber connection...

Peter (MCSE, MCPS, MCSA, MCSAM, MCNPS) tecnologia AT doctor.com
August 27, 2009 11:54:45 PM

Scotteq said:
Try going through the WIN 7 INTERNET TROUBLESHOOTING GUIDE


Just read it. We did most of those ideas already.
Neveretheless, tried using the guide step by step. Does not work. Regretfully the only solution for us, if we turn off the computers with Windows 7, is the explained ir our previous post...

Many thanks
August 27, 2009 11:58:02 PM

Are you sure you are using valid copies of the RC or RTM and not something full of malware? The issue you are reporting sounds like the type of thing a lot of trojan loaders do to attempt site redirection.
Anonymous
a b $ Windows 7
September 12, 2009 1:13:52 PM

hofbei said:
Internet connection problems with Windows 7

Each time we restart our computers (7 different notebooks connecting from different locations with different LAN configurations and different ISP) they are all unable to connect to LAN and/or the internet.

We have tried several solutions suggested by MS and blogs, but the only working one is the following -kinda convoluted- one:
1) The correct LAN configuration is "Obtain an IP address automatically". But, after a restart, we must modify this provisionally, and change the LAN connection properties placing the last IP number leased by DHCP before turning off the computers.
The previous action will let you browse your local net, but you will not be able to navigate the internet.
2) You need to let the system "Obtain an IP address automatically", but it will not do so, no matter how deep you explore into Windows, after replacing the LAN tab to "Obtain an IP address automatically" ang going through all the necessary movements in CMD with ipconfig, and so on...
3) For the moment, it seems the only solution is to run iExplorer and let Windows start the diagnose of the connection problems. If you completed step one (otherwise this solution will not work), the diagnose will say what we know: 'DHCP is not enabled for "Local Area Connection"'.
4) Click on "Try this repairs as an administrator" (no matter if you are logged in as an administrator, Windows 7 will not recognize you as one) and "Apply this fix". It will fix the problem. Now close the troubleshooter and start browsing.

Note that, in our case, all the computers are quite capable to connect to internet -without major problems- using wireless. For that matter, it is a PITA to see Windows 7 connecting to a very slow and far away WiFi (we must turn off the WiFi radio of the computers to push Windows to find the LAN instead) , when it has a patch cord directly plugged to a gigabit fiber connection...

Peter (MCSE, MCPS, MCSA, MCSAM, MCNPS) tecnologia AT doctor.com



THANK YOU!!
It worked and solved my problem that last for 6 hours!
Anonymous
a b $ Windows 7
October 24, 2009 8:35:25 AM

I have found this to be the firewall in Windows 7 probably conflicting with the firewall on you router. Try turning one of them off, reboot and see what happens.
October 26, 2009 7:21:23 PM

Works for me!!!

I had same problem. I went into Device Manager and uninstalled the wireless adapters, rebooted and let windows reinstall. Didn't seem to cure the problem. I then removed the connection from the Homegroup in Network and Sharing Centre. Presto!....wireless problems cured
October 29, 2009 10:30:39 AM

wow for three days now trying to get windows 7 to connect to the internet.I bought the family pack for 3 computers but damn I am not putting this on 3 computers way too many bugs. first I could not enter product key kept saying invalid key please re enter after installing 4 times finally it took the key.now the internet thing.been going on for 2 days.I still got to put my programs on this I should of stayed with my xp pro and puppy Linux dual booting.Everybody was talking about how great it was so I fell for the hype and wasted my money on windows 7. don't waste your money on windows 7 stay with xp it will be good till 2014 by then windows 7 should be well gone. I reformatting and going back to dual booting xp and linux. putting this family pack on craigslist or ebay for 100 bucks.
November 11, 2009 12:43:05 PM

tzenithra said:
I also have a problem with the internet connection in win 7, though this problem appear only couple of days ago. I've disabled both firewalls (Windows and Nod32), but still no internet connection. At the same time, internet works just fine in XP (I have both systems installed).
Could anyone give me a hint on this issue?
thanks.

Did you find a solution? Interested since I have faced the same problem you mention.
Thanks!
December 1, 2009 5:14:40 AM

Funny how things work, I have had 7 beta for about 9 months now and have had NO problems with it or connecting it to the internet. Plus I have installed the real copy on many of my customer's computers and they have been supper happy with 7. 7 is like xp with all of vista's bells everything works fine with it.

Bert if you give me a call, I would be happy to get your 7 to work. Plus if you would of called before I would of saved you the money and hooked you up with it!

Anyway take care all happy computing!

Phil




bertsbug said:
wow for three days now trying to get windows 7 to connect to the internet.I bought the family pack for 3 computers but damn I am not putting this on 3 computers way too many bugs. first I could not enter product key kept saying invalid key please re enter after installing 4 times finally it took the key.now the internet thing.been going on for 2 days.I still got to put my programs on this I should of stayed with my xp pro and puppy Linux dual booting.Everybody was talking about how great it was so I fell for the hype and wasted my money on windows 7. don't waste your money on windows 7 stay with xp it will be good till 2014 by then windows 7 should be well gone. I reformatting and going back to dual booting xp and linux. putting this family pack on craigslist or ebay for 100 bucks.

February 15, 2010 3:19:42 PM

Try disabling TCP auto-tuning.

In an administrator command prompt:

Code:

--------------------------------------------------------------------------------
netsh interface tcp set global autotuning=disabled
--------------------------------------------------------------------------------

If it doesn't do anything, turn it back on:

Code:

--------------------------------------------------------------------------------
netsh interface tcp set global autotuning=normal
--------------------------------------------------------------------------------


They rewrote the network stack to try to maximize gigabit, and sometimes it just f***s things up and you'd be best off just turning it off. If I don't turn it off on my machine, I get a solid 60kbp/s on downloads and file transfers over my network, and I'm on wireless-n, plus it also happens through gigabit ethernet. Without autotuning I'm up in the 300kbp/s range.


This is from Mustachio Joness' post http://forums.penny-arcade.com/showthread.php?t=95324
It increased my speeds by 2000kb/s just from disabling and works like a charm. I hope this helps anyone :) 

Cross post from the Windows 7 thread.

edit:

easiest way to get to an admin cmd prompt is windows key + R for a Run window, then in the run box "cmd", sans quotes.
February 17, 2010 2:58:24 AM

I have seen this issue numerous times on several different PC's. The issue is directly related to the NIC card not supporting Windows 7 going into sleep mode. Go into Control Panel, Select view by small icons, select power options, and then next to Balanced (recommended) select Change Plan settings. On the option to put computer to sleep select never
a c 215 $ Windows 7
February 17, 2010 3:01:43 AM

Please do not necro post. Closing thread.
!