Sign in with
Sign up | Sign in
Your question

Sky is flickering in Crysis

Last response: in Video Games
Share
June 4, 2009 6:16:38 PM

I finally have a rig that can run Crysis somewhat decent, but there is one big issue: portions of the sky flicker annoyingly unless detail is set to low (where the sky has no detail). Does anyone else have this problem? I did try setting the graphics clocks back to stock and that did not help.

system specs:

CPU: AMD Phenom II 720 (2.8 GHz triple core) - OC’ed to 3.6 GHz
Graphics: (2) Sapphire HD4870’s (1 Gb ea.) in Crossfire - OC’ed to 810/1050
Mobo: Asus M4A78T-E – 790GX / SB750
RAM: G.Skill 8 Gb - DDR3 1333 MHz
HDD: WD Caviar Black 750 Gb – 7200 rpm / 32 Mb cache
PSU: PC Power & Cooling Silencer 610
Case: Antec Nine Hundred (without stupid LED fans)
CPU Cooler: Xigmatek S1283 w/ 120mm Fan
Case Fans: (4) Scythe 120mm’s & (1) Antec 200mm
Fan Controller: Scythe KazeMaster
OS: Vista Home PremiumWindows 7 64-bit

game settings:

1280x800
AA off
All settings at medium

More about : sky flickering crysis

June 4, 2009 9:13:23 PM

I had the same problem...I fixed it by going back from Vista 64bit to XP 32 bit...I suppose the switch from DirectX 10 to 9 did the trick.
June 5, 2009 12:25:56 AM

tomvertommen said:
I had the same problem...I fixed it by going back from Vista 64bit to XP 32 bit...I suppose the switch from DirectX 10 to 9 did the trick.

Ouch! I'd hate to have to take a step backwards in order to run one game. Especially since I got about 10 fps (average) more by switching from Vista 64 to W7 64 with the FarCry2 bench.

Driver version: 8.612.0.0 (CCC 9.5)
Related resources
June 5, 2009 1:44:30 AM

Okay, I just downloaded and installed the Hotfixes. I didn't know about them until I did a little research, but now the flickering is gone.

I am wondering what other people are using for settings to get playable framerates though. Considering my system (see 1st post), and games settings as follows:
1280x800
No AA
No AF
All settings to medium
motion blur turned off.

I'm getting about 50 fps average. I really wanted to be able run this game with higher settings, and I'm not even getting good framerates at lousy settings! Hardware-wise and setting-wise, what more can I really do here to be able to play this game the way Crytek intended it to be played??? :??: 
June 5, 2009 4:05:30 AM

Here's an update for anyone who cares:
I found out that Crysis runs WAY better when using the DX9 renderer (sp?) instead of DX10. This is done easily by editing the shortcut target and adding a [ -DX9] to the end of the target line. I can now run the game at the highest resolution, with all settings set to high ("very high" isn't even option when running DX9 - it's grayed out). AA still needs to be turned off though. I now get over 50 fps average and it never dips below 30 fps. :pt1cable: 
June 5, 2009 1:00:08 PM

Quote:
Depends on what you reckon is playable, i get in the 20's and 30's and use 19 x 12, all very high with 4xAA.

...and you must be running DX10 since "very high" is an option. Interesting. Your system and my system are very similar (the only real difference being Intel vs. AMD, but the CPU's are comparable), yet if I run DX10, "very high" settings and 4x AA, I dip into the low teens and the jerkiness is unplayable by anyone's standards. We have basically the same Graphics and CPU speeds (albeit 4 cores vs. 3). I wonder what my bottleneck is?
June 5, 2009 2:28:35 PM

Do you have anything else running while playing?
My system is a bit slower but I find that when I turn everything else off it really helps.
June 5, 2009 3:47:42 PM

I found out that Crysis runs WAY better when using the DX9 renderer (sp?) instead of DX10. This is done easily by editing the shortcut target and adding a [ -DX9 said:
to the end of the target line.]I found out that Crysis runs WAY better when using the DX9 renderer (sp?) instead of DX10. This is done easily by editing the shortcut target and adding a [ -DX9] to the end of the target line.


or you can right click the crysis shortcut inside the "games" folder on vista and click "play dx9".

regarding your systems performance. im guessing you'd get a jump as soon as you get to "crysis:warhead" especially with xfire.
June 5, 2009 4:00:16 PM

Sounds like there's too much over clock on those cards. Back them off. ....... and/or check to see if vsync is off.
June 5, 2009 4:03:46 PM

pat mcgroin said:
Do you have anything else running while playing?
My system is a bit slower but I find that when I turn everything else off it really helps.


Running:
  • Logitech mouse software
  • Ideazon Fang software
  • Avast Anti-Virus
  • Windows Home Server Console

    Turning Avast A/V off makes no difference, nor does closing my WHS Console.
    !