Sign in with
Sign up | Sign in
Your question

Can't get Z-Engine installed for Ideazon Fang on Win7 64 bit

Last response: in Windows 7
Share
September 30, 2009 10:24:24 PM

I have built a new gaming machine that's i7 based running Win 7 - 64 bit edition RTM. Everything's going fine hardware wise except that I cannot get the Ideazon Fang USB gaming keypad device I have to be recognized by it's Z-Engine software.

I have done what was recommended, which is to plug in the USB keypad first, let Win 7 recognize it (which it does) and let Win 7 load drivers, which it says it cannot find. So, after Win 7 informed me that it couldn't find the drivers, I opened Windows Update and let it search for updates for my computer. It then indicated that it found a driver for the Ideazon Fang MM USB input device and a Microsoft HID non-input driver (whatever that is).

So, after I installed those, I installed the latest 64 bit version of the Z-Engine from Steel Series (which now owns Ideazon). However, the Z-Engine icon always shows red indicating that it doesn't recognize an Ideazon USB device. I made sure that legacy USB is enabled in my BIOS, etc. and nothing seems to help. I simply cannot get the Z-Engine to recognize the device.

All of this worked just fine under an older P4 based machine that I was running Win 7 32-bit on.

Any help is greatly appreciated!
October 1, 2009 2:49:24 PM

I have the Fang, I use it in Vista 64 bit, never have install the software and it works fine with all my games. I set up all my games to use the same buttons of course 95% of my games are FPS games.
January 12, 2010 3:45:23 AM

I didn't get the problem there, unfortunately, with the drivers not loading. It loads and works just fine. My problem is that I can't get the stupid thing to allow me to create and edit a custom mod, nor find any mods since about the middle of last year. I don't really mind, ultimately, if they stop supporting this; it's not the latest-greatest-tres-chic powertoy on the market. But I would appreciate at least being able to get the mods on my own so I can continue to use the device I purchased back in the day.

I'm on a Core2Duo E6850 3GHz, with 8GB RAM running Win7 Home Premium 64-bit.
Related resources
January 17, 2010 5:25:30 PM

I am also running Windows 7 /64 and have the Fang hooked up, using the latest copy of the pads software that can be found here - http://www.steelseries.com/download

I don't have any problems with the software and can program custom mods without issue - just did for "Stalker - Clear Sky".

Once you open the Z-engine software, click on "Click here for help" for a How-to on setting up Custom Mods.

Hope this helps...
February 24, 2010 3:26:23 PM

I'm having the same issue.

Fang with the latest drivers Win7 64bit none of my mods will work. Import my old mods that worked under XP nope and re-create them and they still dont work.

maybe its a UAC thing or run in compatibility mode :( 

Feel like sending that Clear Sky mod along?
February 24, 2010 6:22:24 PM

pbat51 said:
I'm having the same issue.

Fang with the latest drivers Win7 64bit none of my mods will work. Import my old mods that worked under XP nope and re-create them and they still dont work.

maybe its a UAC thing or run in compatibility mode :( 

Feel like sending that Clear Sky mod along?



Yes, I can send it. Where to?

WOuld be interesting to see if it loads. It's the Stalker S.O.C. one that came with the Fang software with a couple buttons changed.

Have you checked that the game.exe setting is still correct? I wonder if the change in the game path, from XP to Win 7 is a factor. I didn't save any old mod when I switch operating software.
February 26, 2010 9:45:05 AM

Well that worked.

How did you come up with the game.exe?

Ahh I see now. Maybe its weird because I'm using it via steam.

Thanks I'll keep looking at it to see if thats really the fix.
February 26, 2010 11:00:14 AM

I hadn't even thought about Steam as I haven't used it in a few years. All my games come from disc.

I didn't do anything special in loading the Z-software to my machine. Clean install of Win 7-64 (upgraded from XP-32). Then installed Z-software then games (that order should not make any difference though).

Beyond that, I have nVidia GTX275 and SB X-Fi with the latest drivers.

Good luck.
March 11, 2010 6:28:27 PM

win 7 will download the driver but you won't get the control panel where you can modifiy the buttons. just loaded the vista 64 bit version and in properties i made sure it ran under vista. it working fine with win 7 dual core and now i've gotten a replacement laptop with i7 and just swapped out my harddrive and the fang still works. BUT my biggest question is will they make new mods?? bad company 2 is out and there is no mod. the reason i want the mod is that i can modify it and it will always launch this mod when i start bc2 and launch the bf2 mod when i launch that game etc... at the moment it just launches the generic game mod.
March 12, 2010 2:09:45 AM

Thats the big question...... Will they make new mods. From the lack of response to my support ticket I'd say no.
April 2, 2010 7:47:41 AM

don't know that this will necessarily work for anyone else, but after having the same problem as the OP i tried again just now after having installed and removed and re-installed and removed etc. more than a few times and lo and behold it finally f'n works. what i did:

1. make sure it's uninstalled
2. open your device manager, make note of which keyboard is your Fang (for me it was "HID device") and then uninstall it and unplug the Fang
3. started the latest Zengine install; changed the install directory from the default "...\Ideazon\Zengine" to just "...\Program Files (x86)\Zengine"; & plugged in my Fang when the installer warned me that all devices should be plugged in prior to install.
4. finished install, and voila: it's alive!

like i said, may only work for me, but thought i'd share anyway. all the best.
April 15, 2010 2:14:22 PM

hey guys, maybe it's outdated orso but I've had the same problem and my solution was to simply install the 32 bit software, then it works! everytime I use the 64 bit it doesn't and when I use the 32 bit it works, i figured out that this works not only for Windows 7 64 but but also for Windows Vista 64 bit (on witch the problem occured first in my case)
I hope it helps :) 

Junky
June 8, 2010 9:17:38 AM

It works, i installed the 64bits version but i cant rename or import a custom mod... it has lots of glitches on w7 64bits, i dont recomend this piece of ***.
!