Sign in with
Sign up | Sign in
Your question

Left 4 Dead Lags for 4-5secs in my New PC

Last response: in Video Games
Share
June 23, 2009 3:54:48 AM

CPU- athlon 64 x2 5000 2.6GHz
GPU- 9400GT 1gb
2gb memory
XP SP2

this is my system and whenever i play left 4 dead, it lags, like it freezes for 4-5 sec and an annoying cyclic sound can be heard (usually a sound from 1-2 frames from last play). this usually happens when i go to different location like new rooms or new streets. i tried changing the graphics settings and somehow, the lag lessens, but it is still there.

i can play Crysis in mainstream settings with x4 AA and vsync without lags in 10-12fps. Left 4 dead plays a higher FPS in full settings but the problem is that it lags.

I wonder if i buy another 2GB memory, would it get rid of the lag? or should i reinstall the game? i read the system requirements of the game and my system went pass through the required. please help, coz it's really annoying.

More about : left dead lags 5secs

June 23, 2009 6:01:12 AM

It might have nothing to do with your card or memory. First, your connection could be so slow, making your ping high and making you skip as the game catches up to what everyone else is seeing.

You can also check if Multicore rendering is disabled in your settings. My own copy of L4D would skip like how you described, and once I disabled this option, the issue went away. http://www.tomshardware.com/forum/101063-13-game-freeze...
June 23, 2009 9:35:17 AM

It HAS to be connection. I've ran L4D on my crappy Vista laptop quite nicely..from 18 to mid/high 20s fps Im sure, and I have a T7200 2.0 C2Duo and a GeForce Go 7300 "turbocache" crapgasm. With a good connection, you should be able to run anything with a Source engine from a computer that isnt older than 2-3 years.
Related resources
June 23, 2009 6:06:08 PM

Strange...

I can run L4D with laptop, C2D, Mobility HD 3470 and 4GB of memory. And best thing is, I can run L4D at HIGHEST settings I can set it with 15-30fps.

And Nvidia has stuttering problems on GTX 295 with crysis, that might same as for you...
June 24, 2009 12:54:01 AM

hey guys, thanks for the reply.

btw, i'm experiencing lags in single player mode not with internet connection. although i also play through garena. I'll check the multicore rendering as j29ville said.

it is really strange coz i can play NFSU in great settings with the cars and environment set to medium to high with no lags. although it lessens the FPS but it has no single lag.

thanks .i hope muticore rendering will do the job. :) 
June 24, 2009 3:42:42 PM

then it could be the the has a problem cuz i dont see any prob on your specs..

have you tried to update the game?
June 25, 2009 1:34:38 AM

Hey guys, that actually worked. i disabled the" multicore rendering" in the graphics options in my left 4 dead and there is no lag anymore. Left 4 dead said in the captions that we should enable the multicore rendering whenever we are using a multicore processor (i.e. dual core, core 2 duo) and i'm actually using a dual core and enabling it causes some lags.

i don't know why but disabling it surely solve the problem. thanks so much.
June 25, 2009 2:20:38 AM

Yeah common knowledge if you search...*eye roll*
!