Oblivion/Morrowind run awful

Allright, i've been having this problem for over a month now, ever since i bought the games. Im not running any mods. I've been to COUNTLESS forums, and no one has been able to help me, i tried everything people have suggested, and nothing worked. Interestingly, Oblivion and Morrowind suffer from the same problem, they start to slow down around NPCs/during fights with multiple enemies and whatnot, or when two enemies are fighting each other in the wilderness, you get the idea. A good example is the beggining, everything runs smoothly until the king and his men arrive (Oblivion). Also, the Market disctrict in the Imperial City is another good example, when NPCs are walking about. Indoors, my Framerate is awesome, and completely flawless, if i stare at a wall, ill get well over 100 Frames. I've tried going to tweak guides and reading that conflagaration of information, and it didnt help me. I've tried disabling sound in the .ini. file, changing thread settings in the .ini file, and various other things. All of the other games i play perform flawlessly. My computer isnt the best, but i know its good enough for Oblivion...and Morrowind is completely out of the question. People have suggested a disk defrag, yadyadyada... The computer is new, and i do spyware checks and maintain my PC health.

My system: AMD Phenom X3 8550 2.2GHz
Radeon HD 4850
55 answers Last reply
More about oblivion morrowind awful
  1. I assume youve checked you cpu usage during game play? Its definately cpu bottlenecking. Problem is identifying it, then correcting it, as your cpu can run the games fine. Have you check your apps usage during game play? Is other apps starting/running during it? Are they resource hogs?
  2. If all else fails, you can re-install Windows. Wiping the Registry can do wonders.
  3. Another thing you can do is check to see if there are any patches for the game.
  4. eerrm.... Well, i performed a clean boot with literally nothing working in the background, and, same deal. Nothing in particular is running in the background. Also, i use CCleaner, and heard it can clear your registry, how do i do that? I only use it for clearing my net cache and keeping my computer up to speed. I DO have norton running , but it has never caused a problem for my other games.
  5. I used to run Oblivion @ 12x10 with a AMD single core 3700 at stock with a 1900XT and have slow downs in battles. Dual core eliminated that. This just doesnt make sense
  6. yeah, this is actually the second time i have had my computer, so to speak.. I got it and it was damaged, so i took it to where i bought it and everything had to be replaced, Mobo, RAM, CPU, everything. I remember Oblivion had the same problem. I....eer....got a burnt copy, but once the computer was fixed, i bought the game via Steam. Also, is it possible that when i installed the burnt version some files could have been faulty? Could they have not been completely erased from my computer? They DID replace my HD...but since i was being my impatient self, i did the same thing from when my computer was in its damaged state and installed the burnt copy. Once the offer appeared on Steam, i bought it. I uninstalled the burn of course... Other than that, i cant think of anything, this is almost unsolvable..... The game lags when NPCs are around/talking, or during fights, and scripted events in general. Also, why in the HELL would Morrowind have the same problem aswell??? I mean...look at it! not to mention the system requirements....Pentium 3 500MHz
  7. Hmmm that could be it. Was morrowind burned as well? There could also be other things at play, cant remember what its called, but it does prevent things in game, like shooting straight etc from happening, another DRM type of thing. I dont ever cheat, I buy, so Im not up on all of that, but may be worth looking into, or it could just be bad files as well, as you said, but both games?
  8. Oblivion was the only burn. I bought both games on Steam. Also.... When i opened up "msconfig" and changed the number of processors from "1" to "3" i THINK it gave it a bit of a performance boost...while in the Imperial City.. Also, whenever the BSTask count number goes high, its pretty much hit rock bottom from there, the performance if poor all around, no matter what the situation is in the game. I performed a clean boot, and...nothing... Also tried reinstalling my video drivers several times. Its definately a CPU thing, seeing as i can turn the resolution all the way down to 640 x 480 and all low graphical settings, and STILL, it doesnt fix anything...
  9. Turning down the res only puts more strain on the cpu, as theres less for your card to produce, its easier on the card, harder on the cpu to keep up. Do a fraps fps count when changing res, if it doesnt improve going to lower res, then youll know for sure. Unless youre severly cpu bottlenecked that is, your fps should improve at lower res some
    To explain this better, it is harder on the cpu, and easier on the gpu, tho your fps should see improvement. If not, youve got a huge cpu bottleneck. Check for minimum fps, as thats where the cpu will show up mostly
  10. I'm going to sound like a broken record here but............. there isn't enough video memory on that card to render everything. Your system is offloading or swapping to the hard drive and that's causing a slow down. This a 512 card by chance ? Oblivion is a resource hog. You'll have to turn your settings way down for it.
  11. It ran fine on my nVidia 320GTS
  12. it runs fine on my computer i dont know what is going on with your system though i never did like the 3core phenoms...
  13. "I had a massive headache with oblivion a few months after upgrading graphics cards (properly cleaning graphics drivers etc) I went to play the game again and realised I had some textures really washed out and allsorts of graphical anomalies, I knew my graphics card was working fine, so I assumed file corruption so I uninstalled and reinstalled oblivion - then the game wouldnt even launch without crashing, I tried uninstalling oblivion and reinstalling on another drive, I tried different patchs different forms of uninstall and reinstalling to make sure old damaged files werent being undeleted instead of actually installed fresh, I went through reinstalling the game and all the plugings 6 times before I solved the problem...

    Eventually the cause of my problem turned out to be a configuration file in my documents\my games\oblivion that the game sets up first time its ran, but doesnt delete with uninstallation and reinstallation. Once I deleted the file and allowed the game to recreate it everything worked fine, I dont think I ever actually needed to reinstall the game in the first place... "


    Not sayin this is your problem, but you could look into it, google may be your friend once again

    PS Just realized, unless Morrowind is the same, its probly not the problem
  14. swifty_morgan said:
    I'm going to sound like a broken record here but............. there isn't enough video memory on that card to render everything. Your system is offloading or swapping to the hard drive and that's causing a slow down. This a 512 card by chance ? Oblivion is a resource hog. You'll have to turn your settings way down for it.

    Like i said, i can turn the settings down to the very lowest, and it wont solve the problem. Also, i've seen other people on youtube and whatnot getting good overall performance with the same card. And btw, i've got 2GBs of video memory available, so thats completely out of the question..
  15. hhmm...well, so far only one critical item has been found, it says; Invalid Startup Item: *some type of MRI.exe file* Ill wait for it to finish and start up Oblivion again. Interestingly, its found in the OS directory....
  16. Ok, the spyware scan and removal of that startup item didnt seem to do anything...Although, i found something very strange, and .....just...weird. I whent into the technical support section, and "System Info" and take a look at this:

    Hardware information:
    OEM ID: 0 Number of Processors: 1
    Page size: 4096 Processor Type: 586 (Revision 515)

    Software Information:
    Microsoft Windows 2000
    version 5.1 Service Pack 2 (Build 2600)

    First off, can someone explain this, second, im running Vista Home Premium 64 and, its saying "1" under number of processors......um...WTF!?
  17. I just wanted to see if anything was using up the memory on you. Spyware's good for that. Go into the devise manager and open up the processor and see how many cores are there. If less than you have right click and do an update on it/them... ... start/right click computer/devise manger... ( upper left ) have you done a windows update lately ? bed for me now. will check thread tomorrow. good luck.
  18. Can someone explain this hardware situationÉ....also, im just throwing this in here, sometimes question marks appear as these weird Es......like you see before you. Anyhow, why would it say that im running Win 2000 and a Type 586 processor.. Those were made back in the 90s!
  19. Allright, i performed a Windows Update, and it upgraded Vista to SP2, and...no dice. I can even change the .ini. file settings and enable all multithreaded options, no dice.
  20. Its like I said earlier. When the game first starts, it evaluates your setup, and places you in that tier. The evaluation is somehow skewed
  21. It's definately your slow processor.
  22. I ran it on a 2.2 AMD single core K8. It did the same, but once Id upgraded to a 2.6 dual, same rig, it ran fine. His 2.2 P1 should do alot more at the same frequency than my single K8
  23. bpogdowz said:
    It's definately your slow processor.

    Um...its definately not, seeing as you need a Pentium 4 to play the game, and i know a guy running it on an Athlon getting much better performance, actually playing the game the way its meant to be played...smooth, and slow? I dont know why you would assume that, but OK. If it was slow i wouldnt be able to run all the other games i play... Let me guess, its too slow for Morrowind? ...pfft. You need a Pentium 3 for Morrowind, in case you didnt know.
  24. Try o'clocking your cpu to at least 2.6ghz..it's 2.2ghz might be waaay too slow for your video card,even an 8800gt needs 2.6 to not be bottle necked,FYI I am running my system with 2g of ram single stick 64bit and no swapfile...:)
  25. There's no way in hell im overclocking my CPU and taking a risk of messing up my hardware. You need cooling for that, in case you didnt know... And its not like im increasing by only 100MHz... Also, clock frequency doesnt determine how good a processor is. You can put an AMD Duron overclocked to 8.0GHZ (lets just say) up against a Pentium 4 with a stock clock of 2.4 GHz, it'll get annihilated by that P4. And according to this: http://www.uesp.net/wiki/Oblivion:System_Requirements any Phenom can run the game. Also, on system requirementslab, i get way past recommended when i testy it for Oblivion.
  26. He has a point tho. Ocing it for the test only eliminates certain things, and also points to other things.
    One thing I do remember. When I first setup Oblivion to run, it tests your components, and limits your settings etc, and I can remember my 2.2 Athlon 3700, which was running with cool n quiet on, which baries the speed on the cpu, per usage, well Oblivion would recognize my cpu as being too slow, as it wasnr clocked up because of cool n quiet, so I didnt want to remove that feature at the time, instead, I just made sure other apps were running at the same time that would shut off right away, and also validated my cpu as being fast enough.
    I have the feeling its somehow connected to steam for both games.
  27. Allright, Oblivion itself first gave me my "system info" and it was weird. The type 568 processor and whatnot. Now, i just opened CPUZ and its saying number of processors: 1, Threads: 1...... Ok, im scared now, whats going on? :(

    Oh yeah, and Oblivion has always said it doesnt recognize my video hardware....
  28. Yeah right. 2.6Ghz? We're talking 3.2Ghz and beyond with at at least 2 threads to eliminate any bottleneck from the graphics card. You have no class.
  29. Open task manager, see what it says
  30. Physical memory 40%, memory usage 1.62GB, Threads:825, Processes: 72.
  31. It should have 4 windows, each showing its own cores usage
  32. 4 windows? In task manager? I see six tabs, thats it.
  33. Go to performance, view,then cpu history, then check 1 graph per cpu
  34. no "view" option, only the resource monitor, which is showing one graph for the CPU. Yeah, and whats with the CPUZ thing? its saying that there's only one core.
  35. If you can only get one graph, then only 1 cpu is working, which may be the cause of all this. Possibly a mobo bios
  36. Download process explorer
    Check to make sure all 4 cores are up and running, also checl for hardware interrupts while your pc is in use for anything thats not working correctly
  37. EErr...there's just one problem, i've tried getting into BIOS before, and i tried numerous keys, like Delete, Esc ,and the F keys, and nothing worked...
  38. When it first boots, as soon as you see anything, start hitting the f keys, repeatedly. try f1 or f8 or even f5. Just keep trying, but hit the key repeatedly, making sure its being read by your pc
  39. i honestly dont know what to tell you, eerr.... It looks good? Also, how do i check the individual cores. And a little graph is indicating that Oblivion is using 97% of CPU usage, at least thats what i think it is, its the first mini-graph on the left.
  40. Oblivion should do a lil load balancing, as its one of the first games to benefit from multi core cpus. So, you have 4 graphs, 1 for each cpu?
  41. Dble click on that mini graph
  42. There's 4 minigraphs, and one of which is the processor graph. One is CPU Usage, Commit, I/O Bytes, and Physical

    So yeah, three graphs arent showing...How can this even happen, the other cores being disabled by themselves??? This is just, weird...
  43. Look up your mobo, see if there bios replacements, or how to reset your bios, if theres no alternative, or try it first anyways, Did you replace your cpu by the way? Or is it original?
  44. Everything was replaced, including the processor. Ill go to the manufacturer's website, ill try to find a BIOS update, as for resetting the BIOS, have no idea how to do that.
  45. Should be on the site
  46. allright, there's a BIOS update that's two months old, ill go ahead and install that.
  47. GL, hope it solves your issue. BTW, while you were on your mobo makers site, did it say whether your cpu was supported?
  48. Might be time to move to a phenom 2, that cpu is holding you back, although thats and old game, and it shouldnt be doing that, but hell still get a phenom 2
Ask a new question

Read More

PC gaming Oblivion Video Games