Sign in with
Sign up | Sign in
Your question

Can't play Crysis/Far Cry2/GTA IV on 32 bit color in Vista 64bit

Last response: in Video Games
Share
July 27, 2009 1:26:14 AM

When I launch a game like Crysis, Far Cry 2, GTA IV, or Fallout 3, i get an error saying that the game won't launch...

For example the error for GTA IV is: GTA IV FATAL ERROR DD3D30

GTA IV Fatal error D3D error please reboot your system and theres a button that says ok.

I don't reboot the system

The solution to this is I change my desktop color setting from 32 bit to 16bit, then I'm able to play all the games without any issue. In fact I'm able to go back to windows, switch it to 32 bit and then switch back to the game, and it still plays without any problem.

Here are my specs

DELL StudioXPS
Intel i7 920 @ 2.67ghz
6 Gigs DDR3 1066mhz
1.5 TB hard disk (1 500 gb, 1 1tb)
ATI Radeon 4850HD
Windows Vista 64bit Home Premium SP2

I haven't done any overclocking on my system, and in general it runs like a dream. Its really not an issue, but as you can imagine, its kind of irritating having to switch the color to 16bit whenever I play a game.

I have also updated all my drivers to the latest version, and have been doing so in the past on a regular basis.

I currently have the latest version of Direct X 10 as well, if people thought that might have been an issue.

July 27, 2009 2:16:55 PM

Bump, can someone offer some advice on this please?
m
0
l
July 27, 2009 6:04:09 PM

Hmm, well, I play GTA IV, Farcry 2 (though I hate it), and Fallout 3 on my system, which is:

AMD Phenom II x3 @2.6
ATI Radeon 4890
4 GB DDR3
Vista 64 Home Premium SP1

Might be an issue with SP2? I installed GTA and Farcry in the default location, but Fallout doesn't like it there due to the extra security, at least, if you intend to mod, so I installed that to a directory right on c:.

Also, being a Dell, are you sure you actually have a physical Radeon 4850, in a PCI-E slot? Or is it just a 4850 -chipset- on your MB? 'cause without the V-RAM on the PCI-E card, the chipset is worthless, and might be causing problems.
m
0
l
Related resources
July 28, 2009 1:49:05 PM

Its defintely a real ATI Radeon HD 4850. I've looked inside the PC as well. Besides, if it weren't would I be able to upgrade the drivers on a regular basis from the ATI website?

Also, I hoped that SP1 would actually alleviate the problem, but in fact it was the same. I've encountered the issue of not being able to play the games since the day I got the PC. I haven't bothered reporting it to DELL because I'm still able to play the games, and can even switch it back to 32bit after pressing the windows key and then switching back.

For some reason, the startup will not run in 32 bit.

There are a few games that I can run in 32 bit though, the include, NBA 2k9, FIFA 09, FEAR, THE SIMS 3, and Burnout Paradise the Ulitmate BOX.


Strangstranger? Which SP2 do you mean is a type? For Vista SP2? SP2 came out almost a month back..
m
0
l
July 28, 2009 1:50:17 PM

Oh and strangstraner, they're not running in a compatibility mode. They're running normally. In fact, I tried to play them in compatibility mode in an attempt to start the game up in 32bit color, but no dice...
m
0
l
July 28, 2009 4:35:03 PM

try downloading the full directx runtime from microsoft. That may fix the issue.
m
0
l
July 28, 2009 4:51:08 PM

the runtime, instead of the actual installer?
m
0
l
July 28, 2009 4:52:43 PM

Um...actually thats exactly what I tried to download yesterday, and it said that I already had the latest version.
m
0
l
!