Wrong keys on keyboard

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

Not sure if this is the right place for this question but here goes.
The @ & the " on the keyboard are
reversed.................how do you swap them around?
16 answers Last reply
More about wrong keys keyboard
  1. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    On Thu, 12 May 2005 07:48:05 -0700, "Mike"
    <Mike@discussions.microsoft.com> wrote:

    >Not sure if this is the right place for this question but here goes.
    > The @ & the " on the keyboard are
    >reversed.................how do you swap them around?
    Check Control panel\ Regional and Language options\ Languages\ Details
    to see what country your keyboard "belongs" to, if incorrect just add
    the correct one and remove the old one.
    Mike H
  2. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    It's already set to English (United Kingdom)

    "Mike Hyndman" wrote:

    > On Thu, 12 May 2005 07:48:05 -0700, "Mike"
    > <Mike@discussions.microsoft.com> wrote:
    >
    > >Not sure if this is the right place for this question but here goes.
    > > The @ & the " on the keyboard are
    > >reversed.................how do you swap them around?
    > Check Control panel\ Regional and Language options\ Languages\ Details
    > to see what country your keyboard "belongs" to, if incorrect just add
    > the correct one and remove the old one.
    > Mike H
    >
  3. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    In news:98BA4DAB-12AA-4A44-AC35-D14BC95A2081@microsoft.com,
    Mike <Mike@discussions.microsoft.com> typed:

    > It's already set to English (United Kingdom)


    Assuming that you are in the UK, and you're set for the UK
    keyboard layout, is it possible that you're using a US keyboard?

    --
    Ken Blake - Microsoft MVP Windows: Shell/User
    Please reply to the newsgroup


    >
    > "Mike Hyndman" wrote:
    >
    >> On Thu, 12 May 2005 07:48:05 -0700, "Mike"
    >> <Mike@discussions.microsoft.com> wrote:
    >>
    >>> Not sure if this is the right place for this question but
    >>> here goes.
    >>> The @ & the " on the keyboard are
    >>> reversed.................how do you swap them around?
    >> Check Control panel\ Regional and Language options\ Languages\
    >> Details to see what country your keyboard "belongs" to, if
    >> incorrect
    >> just add the correct one and remove the old one.
    >> Mike H
  4. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    I am in UK. It's a Dell computer & keyboard so I guess it could be a US
    keyboard. Will try setting up as US one. Anything else that it could be?


    "Ken Blake" wrote:

    > In news:98BA4DAB-12AA-4A44-AC35-D14BC95A2081@microsoft.com,
    > Mike <Mike@discussions.microsoft.com> typed:
    >
    > > It's already set to English (United Kingdom)
    >
    >
    > Assuming that you are in the UK, and you're set for the UK
    > keyboard layout, is it possible that you're using a US keyboard?
    >
    > --
    > Ken Blake - Microsoft MVP Windows: Shell/User
    > Please reply to the newsgroup
    >
    >
    > >
    > > "Mike Hyndman" wrote:
    > >
    > >> On Thu, 12 May 2005 07:48:05 -0700, "Mike"
    > >> <Mike@discussions.microsoft.com> wrote:
    > >>
    > >>> Not sure if this is the right place for this question but
    > >>> here goes.
    > >>> The @ & the " on the keyboard are
    > >>> reversed.................how do you swap them around?
    > >> Check Control panel\ Regional and Language options\ Languages\
    > >> Details to see what country your keyboard "belongs" to, if
    > >> incorrect
    > >> just add the correct one and remove the old one.
    > >> Mike H
    >
    >
    >
  5. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    On Thu, 12 May 2005 08:36:21 -0700, "Mike"
    <Mike@discussions.microsoft.com> wrote:

    >It's already set to English (United Kingdom)
    In control panel\regional and languages?
    Well, it's definitely behaving like a US keyboard; try setting it to a
    US keyboard (in the above) and deleting the UK one, reboot and try it.
    Then reselect the UK option and remove the US one and reboot.
    MH
  6. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    Not likely to be anything else.
    If your settings do not fix the problem, however, try another keyboard.

    Mike wrote:
    > I am in UK. It's a Dell computer & keyboard so I guess it could be a
    > US keyboard. Will try setting up as US one. Anything else that it
    > could be?
    >
    >
    > "Ken Blake" wrote:
    >
    >> In news:98BA4DAB-12AA-4A44-AC35-D14BC95A2081@microsoft.com,
    >> Mike <Mike@discussions.microsoft.com> typed:
    >>
    >>> It's already set to English (United Kingdom)
    >>
    >>
    >> Assuming that you are in the UK, and you're set for the UK
    >> keyboard layout, is it possible that you're using a US keyboard?
    >>
    >> --
    >> Ken Blake - Microsoft MVP Windows: Shell/User
    >> Please reply to the newsgroup
    >>
    >>
    >>>
    >>> "Mike Hyndman" wrote:
    >>>
    >>>> On Thu, 12 May 2005 07:48:05 -0700, "Mike"
    >>>> <Mike@discussions.microsoft.com> wrote:
    >>>>
    >>>>> Not sure if this is the right place for this question but
    >>>>> here goes.
    >>>>> The @ & the " on the keyboard are
    >>>>> reversed.................how do you swap them around?
    >>>> Check Control panel\ Regional and Language options\ Languages\
    >>>> Details to see what country your keyboard "belongs" to, if
    >>>> incorrect
    >>>> just add the correct one and remove the old one.
    >>>> Mike H
  7. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    Tried this but still not working correctly.


    "Mike Hyndman" wrote:

    > On Thu, 12 May 2005 08:36:21 -0700, "Mike"
    > <Mike@discussions.microsoft.com> wrote:
    >
    > >It's already set to English (United Kingdom)
    > In control panel\regional and languages?
    > Well, it's definitely behaving like a US keyboard; try setting it to a
    > US keyboard (in the above) and deleting the UK one, reboot and try it.
    > Then reselect the UK option and remove the US one and reboot.
    > MH
    >
  8. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    On Fri, 13 May 2005 07:29:34 -0700, "Mike"
    <Mike@discussions.microsoft.com> wrote:

    >Tried this but still not working correctly.
    >
    >
    >"Mike Hyndman" wrote:
    >
    >> On Thu, 12 May 2005 08:36:21 -0700, "Mike"
    >> <Mike@discussions.microsoft.com> wrote:
    >>
    >> >It's already set to English (United Kingdom)
    >> In control panel\regional and languages?
    >> Well, it's definitely behaving like a US keyboard; try setting it to a
    >> US keyboard (in the above) and deleting the UK one, reboot and try it.
    >> Then reselect the UK option and remove the US one and reboot.

    ??? if the PC's still under warrenty I'd be having words with Dell.
    MH
  9. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    On Fri, 13 May 2005 07:29:34 -0700, "Mike"
    <Mike@discussions.microsoft.com> wrote:

    >Tried this but still not working correctly.
    >
    >
    >"Mike Hyndman" wrote:
    >
    >> On Thu, 12 May 2005 08:36:21 -0700, "Mike"
    >> <Mike@discussions.microsoft.com> wrote:
    >>
    >> >It's already set to English (United Kingdom)
    >> In control panel\regional and languages?
    >> Well, it's definitely behaving like a US keyboard; try setting it to a
    >> US keyboard (in the above) and deleting the UK one, reboot and try it.
    >> Then reselect the UK option and remove the US one and reboot.
    Is it possible for you to swap it with a friends/colleagues "working"
    keyboard to see if the problem persists?
    MH
  10. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    Mike wrote:
    > Not sure if this is the right place for this question but here goes.
    > The @ & the " on the keyboard are
    > reversed.................how do you swap them around?

    Was it always like this or just happened recently?

    Try pressing the ctrl key and the shift key at the same time and try
    your symbols then.
    I have done this a few times inadvertantly myself when typing and it
    will swap them over. If you get total garbage, do the pressing of the
    keys again.

    Once is normal like now - abc @" - correct
    twice is not normal and goes into Dvorak I beleive - axj _@ - incorrect
    third time is opposite way to first - abc "@ - the letters are ok but
    the symbols are not

    In each of the above cases I typed abc followed by the @ and " symbols.

    Hope this helps.

    --
    Kath Adams
    MS MVP - Windows (IE/OE)
  11. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    This didn't work either..........it's a new computer with new keyboard so
    will sort it out with Dell. Thanks for all the suggestions though.

    "Kath Adams" wrote:

    > Mike wrote:
    > > Not sure if this is the right place for this question but here goes.
    > > The @ & the " on the keyboard are
    > > reversed.................how do you swap them around?
    >
    > Was it always like this or just happened recently?
    >
    > Try pressing the ctrl key and the shift key at the same time and try
    > your symbols then.
    > I have done this a few times inadvertantly myself when typing and it
    > will swap them over. If you get total garbage, do the pressing of the
    > keys again.
    >
    > Once is normal like now - abc @" - correct
    > twice is not normal and goes into Dvorak I beleive - axj _@ - incorrect
    > third time is opposite way to first - abc "@ - the letters are ok but
    > the symbols are not
    >
    > In each of the above cases I typed abc followed by the @ and " symbols.
    >
    > Hope this helps.
    >
    > --
    > Kath Adams
    > MS MVP - Windows (IE/OE)
    >
    >
    >
  12. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    On Thu, 12 May 2005 07:48:05 -0700, Mike wrote:

    > Not sure if this is the right place for this question but here goes.
    > The @ & the " on the keyboard are
    > reversed.................how do you swap them around?

    Mike, usually this happens due to a wrong language setting. A mismatch of
    English-US and English-UK (or other English alternative). There are several
    places to check in the Regional and Language Options.

    Global language setting is on the Regional Options page (where format for
    number, currency and other examples are shown).

    Advanced page has a language setting for non-unicode programs.

    Languages page (probably the most important for keyboard settings): Click
    the Details button. On the next screen that appears, check "Default Input
    Language" and under Installed Services, check language assigned to
    keyboard.

    --
    Sharon F
    MS-MVP ~ Windows Shell/User
  13. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    Are the keys themselves reversed on the keyboard or when you hit the @ key,
    you get " and vice versa?

    It sounds like you've got an English-US keyboard, Mike, along with an
    English-US version of WinXP. Yes, you can switch the keyboard layout to
    English-UK but you'll have to learn the correct location of the keys.

    You can use Windows Keyboard Layouts
    (http://www.microsoft.com/globaldev/reference/keyboards.aspx) to display an
    on-screen UK keyboard for reference. This keyboard display may be saved to
    your hard drive for later, offline use and/or you can print it
    (http://www.microsoft.com/globaldev/drintl/columns/007/default.mspx#Q4).

    Also see:

    The Microsoft Keyboard Layout Creator:
    http://www.microsoft.com/globaldev/tools/msklc.mspx

    Windows Keyboard Layouts:
    http://www.microsoft.com/globaldev/DrIntl/faqs/kbdfaq.mspx

    *OR* contact Dell and exchange your system for an English-UK version of
    WinXP along with an English-UK keyboard. IIRC Dell as a 30 Day Exchange
    policy.
    --
    ~Robear Dyer (PA Bear)
    MS MVP-Windows (IE/OE) & Security


    Mike wrote:
    > It's already set to English (United Kingdom)
    >
    > "Mike Hyndman" wrote:
    >
    > > On Thu, 12 May 2005 07:48:05 -0700, "Mike"
    > > <Mike@discussions.microsoft.com> wrote:
    > >
    > > > Not sure if this is the right place for this question but here goes.
    > > > The @ & the " on the keyboard are
    > > > reversed.................how do you swap them around?
    > > Check Control panel\ Regional and Language options\ Languages\ Details
    > > to see what country your keyboard "belongs" to, if incorrect just add
    > > the correct one and remove the old one.
    > > Mike H
  14. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    Sorted.........didn't realise there were so many places that English (UK) &
    English (US) could be selected.
    Thanks for all the help.


    "Sharon F" wrote:

    > On Thu, 12 May 2005 07:48:05 -0700, Mike wrote:
    >
    > > Not sure if this is the right place for this question but here goes.
    > > The @ & the " on the keyboard are
    > > reversed.................how do you swap them around?
    >
    > Mike, usually this happens due to a wrong language setting. A mismatch of
    > English-US and English-UK (or other English alternative). There are several
    > places to check in the Regional and Language Options.
    >
    > Global language setting is on the Regional Options page (where format for
    > number, currency and other examples are shown).
    >
    > Advanced page has a language setting for non-unicode programs.
    >
    > Languages page (probably the most important for keyboard settings): Click
    > the Details button. On the next screen that appears, check "Default Input
    > Language" and under Installed Services, check language assigned to
    > keyboard.
    >
    > --
    > Sharon F
    > MS-MVP ~ Windows Shell/User
    >
  15. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    On Thu, 19 May 2005 09:06:01 -0700, Mike wrote:

    > Sorted.........didn't realise there were so many places that English (UK) &
    > English (US) could be selected.
    > Thanks for all the help.

    You're welcome. Unless you dig into these settings, you wouldn't realize
    it. The way it is now, the keyboard language options are easy to miss. Am
    glad to hear that you now have this sorted.

    --
    Sharon F
    MS-MVP ~ Windows Shell/User
  16. Archived from groups: microsoft.public.windowsxp.newusers (More info?)

    Thanks for tips. Had it sorted nicely. Just needed to re-start
    computer for settings to take effect.


    --
    jlfPosted from http://www.pcreview.co.uk/ newsgroup access
Ask a new question

Read More

Microsoft Keyboards Windows XP