Sign in with
Sign up | Sign in
Your question

Abnormal Prog Term using Unix Emulation

Last response: in Windows XP
Share
Anonymous
May 22, 2005 1:58:01 PM

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

On XP Pro.

I have ICE.TEN software to use an emulatortor to interface with our Unix
system (via the serial port). The software works fine when I'm logged on as
the Administrator.

When I'm logged on as a limited user, the program doesn't open and gives me
the error: MS Visual C++ Runtime Library- Runtime Error!- abnormal program
termination

I spoke with the people at James River Group (ICE.TEN software producers)
and they said it sounds as though the user doesn't have proper access to the
serial port. I can't find any info on changing or controliing the serial
port.

It's a new PC. I have scanned with Norton and Trend Micro (with and without
the System Restore on) and found nothing. I have also disabled Sun Java in
Internet Explorer options. I doubt it was either of these issues as the
software works fine under the Administrator.

Anybody have any ideas on this freaky little problem?

Thanks for solutions or clues!
Anonymous
May 22, 2005 3:16:37 PM

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

Banff500 wrote:
> On XP Pro.
>
> I have ICE.TEN software to use an emulatortor to interface with our Unix
> system (via the serial port). The software works fine when I'm logged on as
> the Administrator.
>
> When I'm logged on as a limited user, the program doesn't open and gives me
> the error: MS Visual C++ Runtime Library- Runtime Error!- abnormal program
> termination
>
> I spoke with the people at James River Group (ICE.TEN software producers)
> and they said it sounds as though the user doesn't have proper access to the
> serial port. I can't find any info on changing or controliing the serial
> port.
>


The James River Group apparently needs to hire some support technicians
who know a little something about WinXP. It has nothing to do with any
given user's access permissions to the serial port. There's no such
thing; the OS and its HAL control all application access to hardware
devices, regardless of the user's permission level. (Unless you've a
group policy in place that limits users' access to specific devices?)


> It's a new PC. I have scanned with Norton and Trend Micro (with and without
> the System Restore on) and found nothing. I have also disabled Sun Java in
> Internet Explorer options. I doubt it was either of these issues as the
> software works fine under the Administrator.
>


You're correct. None of the above are at all likely to be factors in
this problem.


> Anybody have any ideas on this freaky little problem?
>


This is a purely software design issue.


> Thanks for solutions or clues!


You may experience some problems if the software was designed for
Win9x/Me, or if it was intended for WinNT/2K/XP, but was improperly
designed. Quite simply, the application doesn't "know" how to handle
individual user profiles with differing security permissions levels, or
the application is designed to make to make changes to "off-limits"
sections of the Windows registry or protected Windows system folders.

For example, saved data are often stored in a sub-folder under the
application's folder within C:\Program Files - a place where no
inexperienced or limited user should ever have write permissions.

It may even be that the software requires "write" access to parts
of the registry or protected systems folders/files that are not normally
accessible to regular users. (This *won't* occur if the application is
properly written.) If this does prove to be the case, however, you're
often left with three options: Either grant the necessary users
appropriate higher access privileges (either as Power Users or local
administrators), explicitly grant normal users elevated privileges to
the affected folders and/or part(s) or the registry, or replace the
application with one that was properly designed specifically for
WinNT/2K/XP.

Some Programs Do Not Work If You Log On from Limited Account
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q307091

Additionally, here are a couple of tips suggested, in a reply to a
different post, by MS-MVP Kent W. England:

"If your game or application works with admin accounts, but not with
limited accounts, you can fix it to allow limited users to access the
program files folder with "change" capability rather than "read" which
is the default.

C:\>cacls "Program Files\appfolder" /e /t /p users:c

where "appfolder" is the folder where the application is installed.

If you wish to undo these changes, then run

C:\>cacls "Program Files\appfolder" /e /t /p users:r

If you still have a problem with running the program or saving
settings on limited accounts, you may need to change permissions on
the registry keys. Run regedit.exe and go to HKLM\Software\vendor\app,
where "vendor\app" is the key that the software vendor used for your
specific program. Change the permissions on this key to allow Users
full control."


--

Bruce Chambers

Help us help you:
http://dts-l.org/goodpost.htm
http://www.catb.org/~esr/faqs/smart-questions.html

You can have peace. Or you can have freedom. Don't ever count on having
both at once. - RAH
!