Sign in with
Sign up | Sign in
Your question

Red Faction Guerrilla Lag

Last response: in Video Games
Share
September 20, 2009 1:20:04 PM

Hi guys, just got Red Faction Guerrilla. It's a great game the physiques in this game are really fun especially blowing up buildings :sol:  . The problem is that the game takes a minimum of 90% of my cpu power ( got the reading from my g15 LCD). And, it freezes for 5 to 15 secondes when I blow a building up. I'm wondering if it's my specs but think I have a reasonable rig :

CPU :e8400 @ 3.6Ghz (I used the app that came with the mobo, think it's called Easy Tune Build 6)
GPU : Sap Vapor-X 4870 1GB
Mobo : GA-EP45-UD3P
RAM : G.Skill Pi Black Ed. 4GB
PSU : OCZ StealthXStream 600W

Any ideas why this lag is occurring? BTW turning down the gfx doesn't change anything.
Thx, Mojito
September 21, 2009 5:30:26 PM

Still no answers... anyway I took the liberty to see if my cpu was stable, I dida 27h30 torture test with prime 95 and it came out saying that my cpu was in tip-top condition. Btw, appart from my other question above, can I overclock my e8400 beyond 3.6Ghz even though I got 800mhz ram?
Thx, Mojito
September 21, 2009 6:26:42 PM

I've read on the Steam forums about people having issues using dual core CPUs on this game (as opposed to quad cores). Personally I have a Q6600 @3.3Ghz and the game runs great. I also tested it on my laptop which has a dual core and it still runs great.

A couple of questions I would as is what OS are you running and have you tried the game in windowed mode. I think running it in windowed mode on Vista can help unload some of the work from the CPU to the GPU or something like that.
Related resources
September 21, 2009 7:12:40 PM

I am running Vista Ultimate 64, I don't know if I'm running it in windowed mode. On the display options it says "windowed : True" but i don't see it being windowed.
September 21, 2009 7:22:37 PM

A small tip that worked for me - When the game is running, pause it and open the task manager. Find the rfg.exe process, and check its priority. For some reason, it seems to default to above normal. When I put mine back to normal, everything ran fine after that, no matter what I blew up and how.

Give it a try, and see if that works for you. If it does, the only bugbear there is that you might have to do it each time you run the game. but hey, it runs fine on my E6600 with 2Gigs when you set it like this.

Be warned though, ymmv, so you might not get the same results. Worth a try though.
September 21, 2009 8:11:14 PM

And you may be able to hit 4ghz with 800 RAM, if you can't it will more likely be CPU heat that holds you back.
Anonymous
September 22, 2009 6:46:18 PM

Hy! I have Ati 4850 used 9.9 latest catalism and I played with RFG and crashed all the time in game then I installed the 9.8 catalism driver and now it works perfectly. For catalism users that works.
October 13, 2009 6:45:52 PM

What I did was went to task manager and changed my priority for rfg.exe to normal from above normal and it works perfect. The drw back is everytime you start the game you will have to do this.

Hope I helped
Boro
October 14, 2009 8:14:01 PM

Saints Row in space = RFG
October 14, 2009 8:16:32 PM

Run in windowed mode. My GF did this and it doesnt not lag ne more for some reason
!