The Witcher Enhanced Edition HELP!!

So here's the story: I just bought the Witcher (EE), and I love it. It ran fine for like three days or so, then all of a sudden every time I try and run it I get a black screen for about a second, then it says a problem caused The Witcher to close. I've tried all the basics, i.e.: reinstalling, dl'ing latest patches, dl'ing latest drivers, etc... And I've browsed the internet for a while to find that people with similar problems turned down hardware acceleration and were then able to run the game. Problem is, when going into dxdiag to turn down hardware acceleration, there is no slider for it (like in Windows XP). Anyone with a similar problem and solution PLEASE HELP!! I do not want a 40$ paper weight and those A*% F*%^$ at Best Buy will most likely not let me return my game. :)

-Thanks a ton
3 answers Last reply
More about witcher enhanced edition help
  1. Have you tried the Vista hotfix? Here's a link:

    This may help also:
  2. Yeah I already got the Hotfix, and I run on a 64-bit Vista so the other problem shouldn't apply. It sounds like it is for certain the hardware acceleration on the sound card, if someone could please tell me how to turn it down on Vista it would be greatly appreciated.

    -Thanks again
  3. Display Settings> Advanced Settings> Troubleshoot> Change settings
Ask a new question

Read More

PC gaming Video Games