Sign in with
Sign up | Sign in
Your question

Having trouble with Windows 7, boot disc errors and freezing

Last response: in Windows 7
Share
August 31, 2010 2:38:52 AM

I am having some trouble with my computer and Windows 7. The first problem is Windows related, but I am unsure what causes problem #2.

Problem #1.

My computer currently has three internal hard drives, A 1TB Seagate, a 250 GB Maxtor and a 1 TB Seagate. I mentioned the two Seagate’s separately, since one has a .11 on the label, while the other is a .12. The OS Windows 7 X64 is on the .12 TB drive. Both Seagate’s are SATA II, while the Maxtor is SATA1

My primary TB drive (.12) is the newest of the three drives at only a few months old, so should be fine, unless the .12 batch of Seagate drives is faulty?

Anyways, recently one of the drives (don't remember which, but most likely my primary drive) had either the SATA Cable or power cable come lose, and when I started Windows 7, I got a boot disc error. Before realizing a cable had come unplugged, I put in the Windows 7 DVD and tried to repair the installation. It was during the attempted repair that I discovered it was only detecting 2 of three drives, one of the TB drives and the 250GB Maxtor.

I shut down my system and reconnected the 3rd drive, then proceeded to power up my system. I assumed the boot disc error was because of the hard drive coming unplugged. However, I got a boot disc error again! I put the Windows 7 DVD in and repaired the installation and Windows 7 started just fine at first.

However, I now get a boot disc error every time I reboot or start up the computer, and have to constantly repair the installation so I can get into Windows.

My initial thinking was that maybe Windows loaded some startup or boot files on my other drives and that’s causing the trouble, but I reformatted my non OS TB drive and unplugged the 250GB drive, leaving my main OS as the only one active, but it still gives me boot disc errors, no matter how many times I put in the disc and try to repair the OS installation. Having to repair the installation every time I want to use my computer is a pain in the neck, so currently I just put it to sleep to avoid the problem as much as possible.

Problem #2. Occurred before problem #1.

Recently (since late July), my computer has been randomly freezing up on me. One minute it will be doing just fine, then the next it will freeze up for like 5-10 seconds. Sometimes the whole computer freezes up, other times its just random programs. Sometimes program A will freeze up and then a few seconds later program B will freeze up.

The frequency of the freezes varies, as sometimes it can happen multiple times in under a minute, or go hours without a problem.
Internet Explorer, Diablo 2, iTunes and others have all had this problem. Its very noticeable on iTunes, when tracks randomly stop playing for 5-10 seconds before continuing or on Diablo 2 when the game freezes up for a few seconds and then un freezes just a quickly. When internet browsing with IE, the problem is even more noticeable, as the internet tends to start lagging before it freezes up.

The other computers in the house don't have any freezing issues, so it can't be the internet, at least not entirely.
Additionally, my mainboard has 2 Ethernet jacks, and I have tried using the 2nd jack, although the problem just got worse, not better.
I have run Mcafee and Windows Security Essential scans and no spyware, malware or virus was detected.

My motherboard is an Asus M2N - SLI Deluxe, which I have had for about 4 years now. I also have an EVGA 9800GTX+ for my video card an a 4 year old Athlon 4200 2.2 GHz processor.

Finally, I have not tried using my desktop for prolonged periods with the internet cable unplugged, as most of the programs I use require an internet connection. So I cannot say yet if the freezing problems would go away if I leave the internet cable unplugged.

My theories are that either:

A. the Ethernet jacks on my motherboards are failing.
B. There is a hardware problem with my computer
C. There is a problem with my internet connection
D. I should reformat, reload Windows 7 X64 on the other TB drive and See what happens.
a b $ Windows 7
August 31, 2010 2:57:30 AM

My best guess is a hardware problem with the .12 Seagate. That could easily cause the boot disc errors, as well as programs temporarily freezing if the HDD messes up or drops certain I/O operations the programs are trying to perform. Download and run SeaTools diagnostic (might take a while for a 1TB drive, but I recommend the deepest, slowest scan available to make sure the result is accurate).
m
0
l
August 31, 2010 3:50:19 AM

Bolbi said:
My best guess is a hardware problem with the .12 Seagate. That could easily cause the boot disc errors, as well as programs temporarily freezing if the HDD messes up or drops certain I/O operations the programs are trying to perform. Download and run SeaTools diagnostic (might take a while for a 1TB drive, but I recommend the deepest, slowest scan available to make sure the result is accurate).


Thanks for the reponse Bolbi.

I downloaded Sea Tools for Windows as you suggested, but the only test I can run is a short Generic Test, which my drive passed. However, when I try to run any of the other tests, it just says test unavailable.

I should also mention that I have my primary hard drive partitioned, with about 250GB for the C drive, the tiny partition Windows 7 creates and a 3rd partition, the D drive.
m
0
l
Related resources
a b $ Windows 7
August 31, 2010 1:06:36 PM

Is this with the other drives disconnected? The presence of another brand HDD might stop the extended tests. If you can't get SeaTools for Windows to work, I would try SeaTools for DOS. (You can run it from a CD or USB drive.)
You might also run chkdsk /r from the command prompt if you haven't already.
m
0
l
August 31, 2010 10:58:14 PM

Bolbi said:
Is this with the other drives disconnected? The presence of another brand HDD might stop the extended tests. If you can't get SeaTools for Windows to work, I would try SeaTools for DOS. (You can run it from a CD or USB drive.)
You might also run chkdsk /r from the command prompt if you haven't already.


I had the Maxtor drive unplugged when I tried the Seagate Tools, so only my two 1TB Seagate drives were plugged in. I will try the test again with only 1 drive plugged in at a time though.

Still working on trying to solve problem #1.


On a side note, I think problem #2 has ben fixed!

Today in addition to the usual boot disc error message, I was also getting a "bootmgr could not be found" error. I did the usual repair installation and even did a partial Windows Installation. Did the Windows install, just long enough to get to the point where you select a drive for installaing, and then restarted the computer. It seems either doing a system repair or letting it do part of the installation process are both viable options for temporarily fixing the boot disc errors, although one of the two had to be done every time I started the system.

That was not what fixed the problem however. I went into BIOS and found that my primary hard drive was listed as drive #2, when it should have been drive #1. Not sure how that happened, and I will have to switch the cables around later, but for now I swapped the two drives on the disc drive priority list, and the system booted up just fine. Did several boots without having any startup errors.

In addition to that, there were some Windows installaton files on the 2nd SATA drive, which may have also been contributing to my problem. Like I mentioned in the first post, my original boot problem had started when SATA drive 1 had a cable come unplugged. At that time, I had simply put in the Windows 7 DVD to repair the installation (didn't know a cable had come unplugged and thus tried the repair OS option) and got to the part where you select a drive, only to discover SATA drive 1 was not listed. At the time the Windows 7 DVD likely would have installed some system files on SATA drive 2, since it didn't detect any other OS and thought I was loading a new OS. When I eventually reconnected the other drive, Windows would have detected system files on two different hard drives, a complete Windows 7 installation and a partial installation and that likely would have confused the system on what to do, causing a boot disc error.

Reformatting SATA drive 2 to remove the installation and boot files Windows 7 put there and fixing the boot priority in the BIOS seems to have solved problem #2!

Now that problem #2 is fixed, I will see if that causes any changes related to problem #1.
m
0
l
a b $ Windows 7
August 31, 2010 11:11:15 PM

Great! So, now the only problem is programs/computer freezing up? If so, that changes the dynamic a bit. I was targeting a HDD error because of both problems together; now we get to run through a bunch of other things. :na: 
m
0
l
!